summaryrefslogtreecommitdiff
path: root/dev-python/sybil/sybil-6.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sybil/sybil-6.0.2-r1.ebuild')
-rw-r--r--dev-python/sybil/sybil-6.0.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sybil/sybil-6.0.2-r1.ebuild b/dev-python/sybil/sybil-6.0.2-r1.ebuild
new file mode 100644
index 000000000000..0a280c114202
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/simplistix/sybil/pull/108
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}