summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.13.3.ebuild14
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index eba9752df83d..fd2666986370 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,3 @@
DIST sympy-1.13.3.gh.tar.gz 7919933 BLAKE2B 94c601e79caf87eb0f08e15ca4cb79e16bcd97d347e1fd948b6ea98b044133ea99f52032f09e290668e4485393425254ff4062ccfd3a3ac0b8afba080da6ba19 SHA512 2ae7a400d4a2d9c826cfaa165e3e1f5d9ba210c25647984d997775d4ec3d7c8f3ad3c5468d9adf141a1dceec864ca988b4f3a01fd934b923c4486ddd458670a3
-EBUILD sympy-1.13.3.ebuild 2944 BLAKE2B 730e11f2a9673918bccc968504dadb36719b16f8c0ab658cb982a7220e57b98b66a4410684cf3960c20a4a0684c5908985ec57586fdde2c4c3e53b6695dc745f SHA512 98d21fd7dafcae789a864c74f862f239182e98513b8a6002c925ef64a187bec7ff250158f4d9893d2882e2d72be9957f7753c42c3bb6e5dec5461232b95c0267
+EBUILD sympy-1.13.3.ebuild 3052 BLAKE2B 2ea9a78660cb1d0563a6236df5b09a14716a4735a4d88eb0a7bd1993b687a6cbfa3068c1ccafe64c0bd8f59ab3ee6ead23a20d198668597a29a6151c1a6ed6d2 SHA512 14abce996b22a4966ced116e47705be528472ef156e7e2c0d6c5e1e95c243a9562e079e4a904997306eb82d6243652634a735459266b96c6080697f6f464368a
MISC metadata.xml 1639 BLAKE2B b539888e4658c640442db1cb6bd6561664ee6c50109926d69572f4e2cfcdbef230a56909e799b09b860a8688ce66455ae5c5ac86099893ba667feb0198f65abe SHA512 9ba4c310c759e9e7fa3a726850b342e79ed07e4ab369ad126a35b1741fd4d343ba75af457cfcd76c5539b3259e0eb198fb58ae965c231bb38a94c83c00f52e48
diff --git a/dev-python/sympy/sympy-1.13.3.ebuild b/dev-python/sympy/sympy-1.13.3.ebuild
index 12540dc6a32e..882426907542 100644
--- a/dev-python/sympy/sympy-1.13.3.ebuild
+++ b/dev-python/sympy/sympy-1.13.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
inherit distutils-r1 virtualx
@@ -31,7 +31,9 @@ RDEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
ipython? (
- dev-python/ipython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' pypy3 'python*')
)
latex? (
virtual/latex-base
@@ -40,7 +42,11 @@ RDEPEND="
pdf? ( app-text/ghostscript-gpl )
)
mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ opengl? (
+ $(python_gen_cond_dep '
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ ' pypy3 'python*')
+ )
pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
texmacs? ( app-office/texmacs )