summaryrefslogtreecommitdiff
path: root/dev-python/telarchive
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/telarchive')
-rw-r--r--dev-python/telarchive/Manifest3
-rw-r--r--dev-python/telarchive/metadata.xml18
-rw-r--r--dev-python/telarchive/telarchive-1.8.3.ebuild22
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/telarchive/Manifest b/dev-python/telarchive/Manifest
new file mode 100644
index 000000000000..62dd92fad07a
--- /dev/null
+++ b/dev-python/telarchive/Manifest
@@ -0,0 +1,3 @@
+DIST telarchive-1.8.3.tar.gz 79377 BLAKE2B 9f246f7247bd4d72b7a494b35ec92cbd450b64be57a097d66c47e8451d38a7b5a164087d473ea4674400d5bdfe8616547fce493f5286c27267ce21c48230230f SHA512 628937f8556d7197317aaa08b0ed757d92770a0929e77ea30245c1e52a3bf04e425d86c16e4711359634d0156f1d7128780abbead163ed119262fae22e9f35ae
+EBUILD telarchive-1.8.3.ebuild 499 BLAKE2B 512338409b39459ba6a7954ec30dc946ec5dc87e5a6ab0b30a7036e22324d0a690a92fac0c13609b4df2742d36c5e3ec8003023fe3915cd638c0cdefd8f406fe SHA512 6052352b6ca8c202dcc44ba6adbe754f8c66bd6cf170dd308d1ec60edbdcbc61f6ea1c372c44869696eb367bd2f705963801fe12fe0cac0c2393cdcbb4439d99
+MISC metadata.xml 718 BLAKE2B 7e29a8d4dd2caf72df751343f9c90a9ea4f9d0337e04d19f5eca9059d8f3050caa85c53c8fdc573a940fefd570eabb14fc48d28926634cc74e0704564c0de7fc SHA512 c124628773be76764508241a450c053b05f28f264c64e070b9b135646841278ce98e6b13221a01ad6840e66fcf11c81258482b3bf15a4ddee8109cc2fd73fc1c
diff --git a/dev-python/telarchive/metadata.xml b/dev-python/telarchive/metadata.xml
new file mode 100644
index 000000000000..498822a1f085
--- /dev/null
+++ b/dev-python/telarchive/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ telarchive is a Python command-line program for searching multiple
+ public telescope archives. It takes the name of an astronomical
+ object -- or a set of coordinates -- and checks the telescope
+ archives to see if they have observations within a user-specified
+ box centered on the object/coordinates.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">telarchive</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/telarchive/telarchive-1.8.3.ebuild b/dev-python/telarchive/telarchive-1.8.3.ebuild
new file mode 100644
index 000000000000..d42b8b33dbfa
--- /dev/null
+++ b/dev-python/telarchive/telarchive-1.8.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Script for automated searches of astronomical telescope archives"
+HOMEPAGE="http://www.mpe.mpg.de/~erwin/code/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"