summaryrefslogtreecommitdiff
path: root/dev-python/test
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/test')
-rw-r--r--dev-python/test/Manifest2
-rw-r--r--dev-python/test/metadata.xml9
-rw-r--r--dev-python/test/test-0.ebuild45
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/test/Manifest b/dev-python/test/Manifest
new file mode 100644
index 000000000000..10a6f0e0d9a3
--- /dev/null
+++ b/dev-python/test/Manifest
@@ -0,0 +1,2 @@
+EBUILD test-0.ebuild 1017 BLAKE2B f7a7f4e6eb6962c91b70ba5a24608c64023be5ffec659ea10604399b4234453a62d0717e25245c2b2ed90b18740a177360e1ccb0ad27df491b796aa07e9bb0eb SHA512 953596cda4fd08e47c85a8b80d4e204a3bcb0c7976dc837e4d2e4d9f834eb1d520dd914599b86d83a36b1fc7bbeeb0abe88b817d7532afdf9f33b4ff0e36433d
+MISC metadata.xml 265 BLAKE2B 369a57fab1283b596588a82815bfe567fe7617b5c0cb17e97f6694beefdd1e932b0d9ffc1fcb23c6ef05b33d97b3c1d1bb3960618ffdf4924c4ebad262794282 SHA512 a682dac348f2d95b986749f4d33e5702c1e8f66cf2ff7a32a5c2a8d388ddbfde2919d97345028c2007415368d395c7cf657184be89f7def27c949f1af5c30170
diff --git a/dev-python/test/metadata.xml b/dev-python/test/metadata.xml
new file mode 100644
index 000000000000..6ef265a39adb
--- /dev/null
+++ b/dev-python/test/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/test/test-0.ebuild b/dev-python/test/test-0.ebuild
new file mode 100644
index 000000000000..d236bc07147c
--- /dev/null
+++ b/dev-python/test/test-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit python-r1
+
+DESCRIPTION="Virtual to install 'test' package from stdlib"
+HOMEPAGE="https://docs.python.org/3/library/test.html"
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_impl_dep 'test-install(+)' pypy3)
+ $(python_gen_cond_dep '
+ || (
+ dev-python/python-tests:3.10
+ <dev-lang/python-3.10.14_p3-r1:3.10
+ )
+ ' python3_10)
+ $(python_gen_cond_dep '
+ || (
+ dev-python/python-tests:3.11
+ <dev-lang/python-3.11.9_p2-r1:3.11
+ )
+ ' python3_11)
+ $(python_gen_cond_dep '
+ || (
+ dev-python/python-tests:3.12
+ <dev-lang/python-3.12.5_p1-r1:3.12
+ )
+ ' python3_12)
+ $(python_gen_cond_dep '
+ || (
+ dev-python/python-tests:3.13
+ <dev-lang/python-3.13.0_rc1_p3-r1:3.13
+ )
+ ' python3_13)
+"