summaryrefslogtreecommitdiff
path: root/dev-python/testify
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/Manifest3
-rw-r--r--dev-python/testify/metadata.xml12
-rw-r--r--dev-python/testify/testify-0.11.0.ebuild45
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
deleted file mode 100644
index e2fb7f799ccd..000000000000
--- a/dev-python/testify/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST testify-0.11.0.tar.gz 67914 BLAKE2B 8518f7f95ed83c7c8d779b58962f9b111639b4d5b9bbe80907a6e25ca70781945aa320a0cdcfefebe6c96b0a7f471f8334af332dad32beab5848e7601ed277e0 SHA512 ed19a9b5cfa509b65bfa366aa8c5fb311f00a2996dca9b5028a7dfe8d7ad06ab88964dd7e7ea7aa31e183537d769bbd81eb6dbd7d57d7576b6ec8fca9b684dd0
-EBUILD testify-0.11.0.ebuild 1310 BLAKE2B 4d5068a56b75848dbd1f5a2db9fdfcd9d40c52c1d45008bc9793354f062fd8b4c6bd9a252a7d0711080dc8deba1f65c9b31e2751358a8e7fc9be8501094942f7 SHA512 e06c24e0f576a7f04a7a26610f42cf778f8dbae2b562cb5a4fd6d193983299fb10503b1be7ff99f72a7b1a30f05b89f21798026c0cf59195810592d16f3868ae
-MISC metadata.xml 374 BLAKE2B 28e2fec88ebfc9fa2560301c0f566f72e6d4fd86ae01f61c6fc2161176b2855156d37a21383190c62d13c587c3cdef70f41c756013d7142226883fb45ae81fba SHA512 668324c1ff0e2977568abc0ff574acf07d445bb47e17781b7e6d4f409118496c5ab4668ea500e94a615ffcd93c4c5dd59960cb00b886b9c57174ae62ce24c8b0
diff --git a/dev-python/testify/metadata.xml b/dev-python/testify/metadata.xml
deleted file mode 100644
index 643f2eb0cc32..000000000000
--- a/dev-python/testify/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">testify</remote-id>
- <remote-id type="github">Yelp/testify</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/testify/testify-0.11.0.ebuild b/dev-python/testify/testify-0.11.0.ebuild
deleted file mode 100644
index 7ff7f6292538..000000000000
--- a/dev-python/testify/testify-0.11.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify https://pypi.org/project/testify/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- # Correct typo in setup.py
- sed -e 's:mock,:mock:' -i setup.py || die
-
- # Correct use of local importing in pertinent test_ files
- sed -e s':from .test:from test:' \
- -i test/test_runner_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
- einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
- for test in test/test_*_test.py;
- do
- "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
- done
-}