summaryrefslogtreecommitdiff
path: root/dev-python/texttable/texttable-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/texttable/texttable-1.7.0.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.7.0.ebuild b/dev-python/texttable/texttable-1.7.0.ebuild
new file mode 100644
index 000000000000..1358c9d6c218
--- /dev/null
+++ b/dev-python/texttable/texttable-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module to create simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable/
+ https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/texttable/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}