summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild')
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
new file mode 100644
index 000000000000..c80290ae5121
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+)