summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.61.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 67904538a4e9..18b37ab0fbd1 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,4 +1,6 @@
AUX tqdm-4.61.1-py310.patch 1030 BLAKE2B 7505087ca6b5db8523a91c831d48f2dcbe34912d6eba34f80f48044bf5ff8a3c0166c02f5b4e2a693dbe49bc8a7db2682813ed495440f3f8f9fc0e69d93d31a3 SHA512 1de7036c469c078028fe0a9044ecb0ad1dc16d3642d65d13a7c61e6fccac9bea652da0dd385a238ed68a423d481b5bbaa09b2deb9a859a07d64d2eee617c53e8
DIST tqdm-4.61.1.tar.gz 169637 BLAKE2B 8b89f320e13119b24a9e121747bce0b5c6625c31feb8c427a97e71da52797d9de764ce5e5c41c07d5954a1e5e4e21913335a4691837bc243db473821b2dad1ac SHA512 6092a30389380a511abc8bee7e6144556d6dc1a993ba4a2685707afa2838a12f472aa216ac5e55d144da74f9be1d398d4c6f5352986a200557e4aba67831a505
+DIST tqdm-4.61.2.tar.gz 169665 BLAKE2B f5dff67eb549cab0dd667815c25f6e885a2e0cefc2ad68e97fdc09599eb41b13589f7a88d5a445813973454a5e5f835b3139651ec2e09b717db0fd6dc705890e SHA512 bc33e8fe00244f90f61ab51d0c7c0b98d5580efebd9758284d9dbe2a699eabeb0d92871eedc2f95f377e29dd0f7ea4b5247b96cb4cc1687dcfea3a9ed1152ab7
EBUILD tqdm-4.61.1.ebuild 1200 BLAKE2B 0a796c10c2f1d1da67c2790fbdea9192b2ab613427468c73c6e3ba395c10a0aeb7d9db0621a8aba0bba23cd72176f8b7c442069f7c7b12cf46200a685b726945 SHA512 486fffe2e60ef08a9924ecb81588c4a4dace8d1aa5576ed8a2018e1485dab2381c4c176c92fd0cfd75a901433bbe5adf808d9643c4124c330dadf1441ddc60e3
+EBUILD tqdm-4.61.2.ebuild 1163 BLAKE2B 3498857b43003f27f533ea645e815e37e9462d1ea786028c11454b2fe0244e9036d34075c03648253defa0d8404359d4799cf47822478f4a2fe3f6dc1bb43887 SHA512 0e4b11197bbcd9f2b291ddad36afc2a6e442671afd0fc08687ade7c6612287f725d4711aee2c77e160bf6ba44f6696e03cd22b8c227a38bebd276a07cd88eced
MISC metadata.xml 604 BLAKE2B 574eef287a9260a1c115d2e8751c417962cbc09fdd18c68b189898974c8396bc7fab56fcb71a067477e0701916cc9e4dd6701d19e86e62027fd8a34e630b3f17 SHA512 d12b1ccb6601676fcb18122a94d0f397ed1d411a8f8a40d32e595bf36faa08d5a9aeada278c471f063ea75605d7657f6697c2ed45ccc658b9e7f57a0114e7982
diff --git a/dev-python/tqdm/tqdm-4.61.2.ebuild b/dev-python/tqdm/tqdm-4.61.2.ebuild
new file mode 100644
index 000000000000..376ba7ad0389
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.61.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}