summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.5.3.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 846695ad8650..b0c1dd3435fa 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,5 @@
DIST trimesh-4.5.2.gh.tar.gz 13616030 BLAKE2B 1201b0d3f2780564c970d7c14331905e4fe808df3f0185dbdd1cdf383d4358d9dd50d3bdbedd6a3ada843657452a5aabb0ca3eaab6b56c65373ebc9a1ca91ad5 SHA512 13fedd9bac79e25d510b776166d9ea04cf60638f3702cdf3a8a7f14e4297fe26fa4b9eacffb9a22f1b175c01bf75d4452e57a073ca8eb4858b028abca99d2e5b
+DIST trimesh-4.5.3.gh.tar.gz 13618342 BLAKE2B 1bb74c872a09d928b9ccd4b098377f584ef05e444c1f3eee50ec456e108485a14757b1bdcb2920118e8ea6f557d56c2708784d51979c18cee956d9b7aac6093a SHA512 4000ae55e8020bf1fd884a646d18db77f55abbb5de2ccc9f89ada4854b2001c0da377d53b834e48f7f43fa4ea1681fd0cf092697bb59e888c5416cf4a245a847
EBUILD trimesh-4.5.2.ebuild 2137 BLAKE2B 2ce922359cdb4fbba7e4c40c14742d30dcdaacb0b47ff2b6e4c169923ed25053f43263457fea7eb3bc98b5e9ba34672851933f7081f88961e19f4731598d6a63 SHA512 2f4a9dc06e4112786d55aa7ba015a318b6bbb782692760ad4799ccb62933abc2f869862ecb9dda5b0e32d34e31989f48a664136287f84fe931839fafac1c9b8e
+EBUILD trimesh-4.5.3.ebuild 2139 BLAKE2B 2b95f1452a1f9b007bb085b0abca7f171d7fdeba6c7c666de89cdd734f02b232551bd66c990adbac7a7fb5e17daba3feff5436d4abbe29c4303754d207b4f7d3 SHA512 170771013ace7431e0e573f97ff72cc11da9ecdac86ebdee7204e19fc4aa6aed40147d4c4ccea7aa1bc73b9d0c75855fcbf5d5a1fc90646af30676ac9081f104
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.5.3.ebuild b/dev-python/trimesh/trimesh-4.5.3.ebuild
new file mode 100644
index 000000000000..7b71b21dd4d0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.5.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires manifold3d
+ tests/test_boolean.py::test_multiple_difference
+ )
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}