summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest4
-rw-r--r--dev-python/trimesh/trimesh-4.4.7.ebuild74
-rw-r--r--dev-python/trimesh/trimesh-4.4.9.ebuild2
3 files changed, 2 insertions, 78 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 404fc89c9f89..710c3f18de9f 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,3 @@
-DIST trimesh-4.4.7.gh.tar.gz 13606593 BLAKE2B 1847d601711df60257a8f1248cdea66fcc6489b570606c9ab1d360db2742a9e7c1f0d6093924afa7105a5a272e80c291b1c3568b041db2ee4d144e72ab44fbd8 SHA512 b3e1a670b8dec26df3357cad4205431e94fc2b59b87af976b0754ac8e46f4f930f768322f0aa236a6205c289b9037f2343ec6aaeb0e281f021a03d3147be3d20
DIST trimesh-4.4.9.gh.tar.gz 13612220 BLAKE2B 9ee21f8a3f0db041133b2843948a00e8ee6bf52e3de1d2ca9ac88391ef1c07a4b540c75b439da3e137923f0822399cdf759072729363253ad8137a06cb208791 SHA512 3b58a0378231dd1111ac4ffe030b1dd18d24647e22fe815bc411a7854f83e12a9482cb0b48d5333be9f6f6ebf622c15e29c446531ce27ff12c1835a6f25cc51a
-EBUILD trimesh-4.4.7.ebuild 2034 BLAKE2B 28b0063eefd036c6d882d0907b04eed1abacaf1206be8677b9e72c5e0d479bacbce43150227383ac9d2163b65f6dc405456e7064642f34f3c3d9b93e17964935 SHA512 624b55d78b99eddaf8e3446cf07d04344fe83c1f4b3033b75c076841f721e2bdc798e8b5e8cfddbc01db1d9e36f7232f5ff9145325c5e82bd5faea34b417ddfe
-EBUILD trimesh-4.4.9.ebuild 2036 BLAKE2B fdc3533e944166ed99e70415f599e526e0a0eef5408ebea3e794a308ad5f2d98301a7984b9ad7570cdb939fcc528a3b01c9d6f8247cb195b54a4a4af338cefa3 SHA512 ff6e93c70c01ba4a711610db9e2a4ab818fdd4a78d9dbd35e410ac1fb3519a9358625fc0c5529eb95411a7329f56349c76b1ffe8c5f3c32ca1ca24add807fcbd
+EBUILD trimesh-4.4.9.ebuild 2034 BLAKE2B 28b0063eefd036c6d882d0907b04eed1abacaf1206be8677b9e72c5e0d479bacbce43150227383ac9d2163b65f6dc405456e7064642f34f3c3d9b93e17964935 SHA512 624b55d78b99eddaf8e3446cf07d04344fe83c1f4b3033b75c076841f721e2bdc798e8b5e8cfddbc01db1d9e36f7232f5ff9145325c5e82bd5faea34b417ddfe
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.4.7.ebuild b/dev-python/trimesh/trimesh-4.4.7.ebuild
deleted file mode 100644
index 98c2977bc8ed..000000000000
--- a/dev-python/trimesh/trimesh-4.4.7.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python library for loading and using triangular meshes"
-HOMEPAGE="
- https://trimesh.org/
- https://github.com/mikedh/trimesh/
- https://pypi.org/project/trimesh/
-"
-SRC_URI="
- https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/colorlog[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pycollada[${PYTHON_USEDEP}]
- dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
- dev-python/svg-path[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- dev-python/xxhash[${PYTHON_USEDEP}]
- dev-python/rtree[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mapbox-earcut[${PYTHON_USEDEP}]
- dev-python/pillow[webp,${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_TIMEOUT=1800
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # require pyinstrument
- tests/test_sweep.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-pkg_postinst() {
- optfeature_header "${PN} functionality can be extended by installing the following packages:"
- optfeature "making GUI applications with 3D stuff" dev-python/glooey
- optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
- optfeature "loading a number of additional mesh formats" dev-python/meshio
- optfeature "figuring out how much memory we have" dev-python/psutil
- optfeature "marching cubes and other nice stuff" dev-python/scikit-image
-}
diff --git a/dev-python/trimesh/trimesh-4.4.9.ebuild b/dev-python/trimesh/trimesh-4.4.9.ebuild
index 37fd5b19ad93..98c2977bc8ed 100644
--- a/dev-python/trimesh/trimesh-4.4.9.ebuild
+++ b/dev-python/trimesh/trimesh-4.4.9.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 arm64 ~x86"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]