summaryrefslogtreecommitdiff
path: root/dev-python/tweepy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/Manifest4
-rw-r--r--dev-python/tweepy/tweepy-2.3.ebuild52
-rw-r--r--dev-python/tweepy/tweepy-3.5.0.ebuild2
3 files changed, 2 insertions, 56 deletions
diff --git a/dev-python/tweepy/Manifest b/dev-python/tweepy/Manifest
index 10f783f3e5a6..6ab4ae7fe7b4 100644
--- a/dev-python/tweepy/Manifest
+++ b/dev-python/tweepy/Manifest
@@ -1,5 +1,3 @@
-DIST tweepy-2.3.tar.gz 52352 BLAKE2B 6853f133e73d8a97d5a2326ef6c877a527fad87ba9767e6ee218efcb84f6b8332d4f66b044b572987e71d4d9dd8a7b743c7976cfa9947101f0df5c6f9de5d1c4 SHA512 23317a507174e108cf8d13232aa467d892aba1789ee4f610eef4f5503b045841b5c85e8ae63ddcfd1e07178afbf3bf9f4a9fed939426411a8566f1c949b9b831
DIST tweepy-3.5.0.tar.gz 24348 BLAKE2B ea9d96abe4f364e1f77a97ce28fcd4fca3224ab307698e59a834c20becfa53ab68851e638946085431ef2edc1a4e3bf4f42a113c2ac41561930b7f4638e5d6c4 SHA512 cf87f0b7dea0ca444c17a3fdb9c2ebef814683c110511876c1997630b3202393276d3dd2de3b37fc21eb7a15382d22cc886109bda5a11b3d06a08081704c8c2a
-EBUILD tweepy-2.3.ebuild 1136 BLAKE2B fa335da13355d7c4bfe46543536cfd84d5e2b64dc7416359d8539ea80d93d9bd13f85d44d24fd81e7378982394eac480085b397bec57a5fae5686613bd3bb7bd SHA512 1cfae88261e6af78b8488f01f3c48f848289aabc63661c1136ad6f301d698b52c48f9b1901d0f62770e4536dba931801889e26e05f47bfba29f0737a2e0b4202
-EBUILD tweepy-3.5.0.ebuild 1215 BLAKE2B d8cda39af7587ecfa91991dccdbad50bb828e256f50078acd109f55222a551f47b8af7f6d9352cf7ca5a9fbe42a49d1a394f7fc49758d58450be2703dbf23def SHA512 2efde6202ceb44ca6d0d2dc5247c2262c58bb0f863ad569cffdbb749ce0d9f6dad7390e4bfe53f7f94cfc73c5c3e9eec7bf5470ac905263fb202d668f60c02a1
+EBUILD tweepy-3.5.0.ebuild 1205 BLAKE2B 9abbbd35f91855028b31d30081dd71ed9bec98d58b5221ae5f224c07b24559f2168bf2a9dd6b2d85060abfed5fc621d576f69f2782b997cdb9aacadc263ee8a0 SHA512 dda5d53c3ba30973a14c254ea199bab384b3875a4b3d035e65a0199d3767d9c6b0e7b8860058acaa916e721357b8cc433294c28c615ffea9614da4ce6c8c3fd4
MISC metadata.xml 374 BLAKE2B 54949ade0005d71f03bcbf3c84676c9a8b6b10420c8b28ac1e2e27b772b4cc685d3d88d9fce150c3f8a46b137ee4c3441cb4eb1925487f4e42858b73b2e1596e SHA512 e2785876cc350cb7130905648a4f9013fc79c286697c6fdfac203678ff79217383fad2c4d4d2caa42107d83c6cc29ae0d149acea16d74aab804a3039a3e143fe
diff --git a/dev-python/tweepy/tweepy-2.3.ebuild b/dev-python/tweepy/tweepy-2.3.ebuild
deleted file mode 100644
index 810587b01250..000000000000
--- a/dev-python/tweepy/tweepy-2.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A Python library for accessing the Twitter API "
-HOMEPAGE="https://www.tweepy.org/"
-SRC_URI="https://github.com/tweepy/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-# online tests
-RESTRICT="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/httreplay[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Required to avoid file collisions at install
- sed \
- -e "/find_packages/s:]:,'tests.*','examples']:g" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v \
- tests.test_api tests.test_streaming \
- tests.test_cursors tests.test_utils || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/tweepy/tweepy-3.5.0.ebuild b/dev-python/tweepy/tweepy-3.5.0.ebuild
index 008e2c23fb34..603f325a84ee 100644
--- a/dev-python/tweepy/tweepy-3.5.0.ebuild
+++ b/dev-python/tweepy/tweepy-3.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1