summaryrefslogtreecommitdiff
path: root/dev-python/twine
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest2
-rw-r--r--dev-python/twine/twine-6.1.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index aaae148ff06d..c4285f811a6b 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,5 @@
DIST twine-6.0.1.gh.tar.gz 223827 BLAKE2B ab88eb21908954ee7c32744ae9f7ccd7d50cb2b5207917144ef559e142837c89625596dea2c1bb0be21858bb0967690df999bb8a123e01beb5637a025dc490f9 SHA512 4fa7727d0728da3e05eaca068bf1dd85656225dd61958666ec0747359ee6bd88b25fd443d6c77bd8db245e71418cf8e5b594a6559ac1ecaafe3c079ecaefadba
+DIST twine-6.1.0.gh.tar.gz 163562 BLAKE2B c1fa279f62c5c6c5dfdc59120a9d80776d69527fec69356358963956ce7e1f76f05b432eaef3586c52a4150ce2893975cff252361740a7ce24b2917379c212f8 SHA512 d8235561f13eaaee7607b4b50dd70fdb67b9a9863a7d69fa2d173d8625cb3c44c8adccb27c5fe2203b3c1db7f36a685cc9da7f847aac3d5a3622b8e7125dd2b8
EBUILD twine-6.0.1.ebuild 2003 BLAKE2B 26d277b403871a245d189d96cb0a064b383eccd4fee0fd05692aa36cf6c5ae79a92b72acadf33e1a113eb704c93efe2e375ddee8b9f5200a05346cd37741f209 SHA512 afee62ef43fb994508976489c3877edae99e1579dcdf1219d8f4f68ebb948ca8e56d8a468630df401dba5eb76f3f8b57c0b3cd0a0231a30731be1d207f0db502
+EBUILD twine-6.1.0.ebuild 1986 BLAKE2B d9ec5d3cf8348bc2748aedd1f216913e698714475b0f11774d79474d9bb1e50f7452b4b3fa183862e406b54a524591761538d9e981d05c68875abaeed707821f SHA512 4d9f365313426d6ec4ca5f8b7eb8ec2cb2c022a2f10925edc8dc30a1f218c39780cd78b448c49e50c80c3353165c6b6a8240d3b6ac5cd8b77681a4eef3258b93
MISC metadata.xml 383 BLAKE2B e2a596604a2f3e40ddd0196ea79105e318f8a04d9e5a2c7e458d403d215af1371f2a526fa7d8cbc430f20747f7b65ed6c8546263fb8a54ddd8a6db487c358634 SHA512 cd5c1f1ed89dc5c314975fc5b503108d6828db37826ebba98d6edd580b72cd41867e19e65a9a022f8c07babadecd810f21febeb8a015c51eecec412b9df4f0d5
diff --git a/dev-python/twine/twine-6.1.0.ebuild b/dev-python/twine/twine-6.1.0.ebuild
new file mode 100644
index 000000000000..50b07be03895
--- /dev/null
+++ b/dev-python/twine/twine-6.1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="
+ https://twine.readthedocs.io/
+ https://github.com/pypa/twine/
+ https://pypi.org/project/twine/
+"
+SRC_URI="
+ https://github.com/pypa/twine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ dev-python/id[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-24.0[${PYTHON_USEDEP}]
+ >=dev-python/readme-renderer-35.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Internet
+ tests/test_integration.py
+ )
+ local EPYTEST_DESELECT=(
+ # Avoid needing heavy virtualx
+ tests/test_auth.py::test_warns_for_empty_password
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}