summaryrefslogtreecommitdiff
path: root/dev-python/txaio/txaio-2.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/txaio/txaio-2.9.0.ebuild')
-rw-r--r--dev-python/txaio/txaio-2.9.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/txaio/txaio-2.9.0.ebuild b/dev-python/txaio/txaio-2.9.0.ebuild
deleted file mode 100644
index 2ecf87e168a7..000000000000
--- a/dev-python/txaio/txaio-2.9.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
-HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
- >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
- )
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- default_src_prepare
- # Take out failing tests known to pass when run manually
- # we certainly don't need to test "python setup.py sdist" here
- rm "${S}/test/test_packaging.py" || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- pytest -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}