summaryrefslogtreecommitdiff
path: root/dev-python/ukkonen/ukkonen-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ukkonen/ukkonen-1.0.1.ebuild')
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ukkonen/ukkonen-1.0.1.ebuild b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
new file mode 100644
index 000000000000..1fbfd7a8edd0
--- /dev/null
+++ b/dev-python/ukkonen/ukkonen-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of bounded Levenshtein distance (Ukkonen)"
+HOMEPAGE="
+ https://pypi.org/project/ukkonen/
+ https://github.com/asottile/ukkonen/"
+SRC_URI="
+ https://github.com/asottile/ukkonen/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~riscv x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
+
+distutils_enable_tests pytest