summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
deleted file mode 100644
index 1efd35b52aac..000000000000
--- a/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for calculations with uncertainties"
-HOMEPAGE="https://pythonhosted.org/uncertainties/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests nose
-
-python_compile_all() {
- use doc && "${PYTHON}" setup.py build_sphinx
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
- distutils-r1_python_install_all
-}