summaryrefslogtreecommitdiff
path: root/dev-python/unidiff/unidiff-0.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unidiff/unidiff-0.7.5.ebuild')
-rw-r--r--dev-python/unidiff/unidiff-0.7.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/unidiff/unidiff-0.7.5.ebuild b/dev-python/unidiff/unidiff-0.7.5.ebuild
new file mode 100644
index 000000000000..c9a002931e1e
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.7.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="
+ https://github.com/matiasb/python-unidiff/
+ https://pypi.org/project/unidiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest