summaryrefslogtreecommitdiff
path: root/dev-python/versioningit/versioningit-2.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/versioningit/versioningit-2.2.1.ebuild')
-rw-r--r--dev-python/versioningit/versioningit-2.2.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/versioningit/versioningit-2.2.1.ebuild b/dev-python/versioningit/versioningit-2.2.1.ebuild
deleted file mode 100644
index 2926df7ed5b8..000000000000
--- a/dev-python/versioningit/versioningit-2.2.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A setuptools plugin for versioning based on git tags"
-HOMEPAGE="
- https://github.com/jwodder/versioningit/
- https://pypi.org/project/versioningit/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- <dev-python/tomli-3[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-python/pydantic[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # Tries to do wheel/pip installs
- test/test_end2end.py
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/-cov/d' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -p no:pytest-describe
-}