summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest4
-rw-r--r--dev-python/virtualenv/virtualenv-20.24.5.ebuild106
-rw-r--r--dev-python/virtualenv/virtualenv-20.24.6.ebuild114
3 files changed, 0 insertions, 224 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 5ed787e231f7..c80726c9446f 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,7 +1,3 @@
-DIST virtualenv-20.24.5.tar.gz 7119883 BLAKE2B bc4a0e81feeac8975f259b329f223a286be41af11c9a8f27b68b6a42611668942ba18b691a848195609e47695e3104602d6563cabb930d7fed9f07cc57d2468e SHA512 f77961ed26c3e7314f26c0c18d41ab843572b0a1d157eb7b5e51f955a289da8ecf633d2ad9c936b9292e5b06e4ce9f5b11a100681fbb63dd1fb9fc9bef37f4c4
-DIST virtualenv-20.24.6.tar.gz 7140367 BLAKE2B 7a98219cc7933431720e3105b9e94efe7622ecf769ae7a8a9be45253e6cbd0978a653e341586936428bbe271c25a90aa93aebdc423b0eeafad67dd0394fbea5a SHA512 cd09d05490b22c26220b48566e6df860cc135d142e9a390f85ed920a26f4ca2c0ca129b0b190fb9cb46ed0e2711231aa5966ae73ceabc1e3fa7812b63fc5c53b
DIST virtualenv-20.24.7.tar.gz 7141024 BLAKE2B 1125960c3a0b84f1350a9b427e6387dacbf2b2c5ef827bd21d61b5b0fd2e0c81c01b452390b1ec96ed139ed42d3f061394c82227c06a873bca9c21bd5a8fcfbc SHA512 fdfa763f026665cf8bd624192f71853c00b22f0b34f4bf4cd629c928a3c666f60d3dd7ee10c3c46b9a8b383cce51015c5fdeb891e9c6033b02563686d5e7790e
-EBUILD virtualenv-20.24.5.ebuild 4795 BLAKE2B 01c24799994de8a19456626b84dd4af5029168f25726bf74701eac4545c422e6810f1732280810b3ac0cb16f0574426e02afddfabf9efca2f19edb958572e2de SHA512 c8cf31d71de28a3db7515dc1572d22cfb0094ef468b4527935b62f3f9845e4870038df15f67d87cf4903b195d24ad5f78579c0a63f73237918164275e5f5e3a0
-EBUILD virtualenv-20.24.6.ebuild 5089 BLAKE2B a6fd2f9fd0c7f6d5ddfcba2b0610772da4ae60f40118881b3a1c146bdae0aa84afe8bb64d1031fc60559ecdf625d7ef7d6f446ce1fa7b7b7aec7cd10a7a23221 SHA512 2eaa6c09439d517a1fb484c5fdd9c50d3d4de0faab8b97e6b278ee3af476074f47dc9501fdbbcbd44b0634f2d7aa7667f7a01a0ae2f60740d4ffa612bbd2258b
EBUILD virtualenv-20.24.7.ebuild 5074 BLAKE2B 5d4963c15a4d23d333556814451a1fd43d20854f851f4efb29484b3adfd5637ca7fbd67cca3b736bd774ae605309a431e59213ee0932f2cb0354e1e16604efa0 SHA512 ded615c2a25754aa97ae87e4cc3bf1dd594326ff7f7f832ae2256dceec41a31f009b0e0948071e86ce54152ea55a3c2d265e5c52751dc6d36aac0f5094d089b5
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.24.5.ebuild b/dev-python/virtualenv/virtualenv-20.24.5.ebuild
deleted file mode 100644
index dfdcadbe7e94..000000000000
--- a/dev-python/virtualenv/virtualenv-20.24.5.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND="
- <dev-python/distlib-1[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.7[${PYTHON_USEDEP}]
- <dev-python/filelock-4[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
- <dev-python/platformdirs-4[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
-"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/pytest-freezer-0.4.6[${PYTHON_USEDEP}]
- ' pypy3)
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/time-machine[${PYTHON_USEDEP}]
- ' 'python3*')
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- tests/unit/activation/test_xonsh.py
- tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
- tests/unit/create/test_creator.py::test_cross_major
- # tests failing without python2 installed
- "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
- "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
- )
- [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
- # TODO
- tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
- )
- [[ ${EPYTHON} == python3.12 ]] && EPYTEST_DESELECT+=(
- tests/unit/create/via_global_ref/test_build_c_ext.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x TZ=UTC
- local plugins=( -p flaky -p pytest_mock )
- if [[ ${EPYTHON} == pypy3 ]]; then
- plugins+=( -p freezegun )
- else
- plugins+=( -p time_machine )
- fi
- epytest "${plugins[@]}"
-}
diff --git a/dev-python/virtualenv/virtualenv-20.24.6.ebuild b/dev-python/virtualenv/virtualenv-20.24.6.ebuild
deleted file mode 100644
index 0f7512ee9e82..000000000000
--- a/dev-python/virtualenv/virtualenv-20.24.6.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-SLOT="0"
-
-RDEPEND="
- <dev-python/distlib-1[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.7[${PYTHON_USEDEP}]
- <dev-python/filelock-4[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
- <dev-python/platformdirs-4[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
-"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/pytest-freezer-0.4.6[${PYTHON_USEDEP}]
- ' pypy3)
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/time-machine[${PYTHON_USEDEP}]
- ' 'python3*')
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # workaround test failures due to warnings from setuptools-scm, sigh
- echo '[tool.setuptools_scm]' >> pyproject.toml || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- tests/unit/activation/test_xonsh.py
- tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
- tests/unit/create/test_creator.py::test_cross_major
- # tests failing without python2 installed
- "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
- "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
- )
- [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
- # TODO
- tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
- )
- [[ ${EPYTHON} == python3.12 ]] && EPYTEST_DESELECT+=(
- tests/unit/create/via_global_ref/test_build_c_ext.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x TZ=UTC
- local plugins=( -p flaky -p pytest_mock )
- if [[ ${EPYTHON} == pypy3 ]]; then
- plugins+=( -p freezegun )
- else
- plugins+=( -p time_machine )
- fi
- epytest "${plugins[@]}" -p xdist -n "$(makeopts_jobs)" --dist=worksteal
-}