summaryrefslogtreecommitdiff
path: root/dev-python/vobject/vobject-0.9.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vobject/vobject-0.9.6.1-r1.ebuild')
-rw-r--r--dev-python/vobject/vobject-0.9.6.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.6.1-r1.ebuild b/dev-python/vobject/vobject-0.9.6.1-r1.ebuild
new file mode 100644
index 000000000000..1eab8ca38339
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.6.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="https://eventable.github.io/vobject/
+ https://pypi.org/project/vobject/
+ https://github.com/eventable/vobject"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}