summaryrefslogtreecommitdiff
path: root/dev-python/w3lib/w3lib-1.19.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/w3lib/w3lib-1.19.0.ebuild')
-rw-r--r--dev-python/w3lib/w3lib-1.19.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/w3lib/w3lib-1.19.0.ebuild b/dev-python/w3lib/w3lib-1.19.0.ebuild
new file mode 100644
index 000000000000..c9ba06661319
--- /dev/null
+++ b/dev-python/w3lib/w3lib-1.19.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library of web-related functions"
+HOMEPAGE="https://github.com/scrapy/w3lib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"