summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild')
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
index be8b8824c2f8..c4313c41c6fe 100644
--- a/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
+++ b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -24,13 +24,20 @@ RDEPEND="
distutils_enable_tests pytest
-DOCS=()
-
src_prepare() {
sed -e 's:--cov-append::' \
-e 's:--cov-report=html::' \
-e 's:--cov=wcwidth::' \
-i tox.ini || die
sed -i -e 's:test_package_version:_&:' tests/test_core.py || die
+
+ # causes pytest to fail, bug 775077
+ sed -i '/^looponfailroots =/d' tox.ini || die
distutils-r1_src_prepare
}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}