summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-0.59.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.59.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.59.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.59.0.ebuild b/dev-python/websocket-client/websocket-client-0.59.0.ebuild
deleted file mode 100644
index 2b3d19ca2df6..000000000000
--- a/dev-python/websocket-client/websocket-client-0.59.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="WebSocket client for python with hybi13 support"
-HOMEPAGE="https://github.com/websocket-client/websocket-client"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
-IUSE="examples"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- sed -i -e '1i#!/usr/bin/env python' bin/wsdump.py || die
- # Internet
- sed -i -e 's:testConnect:_&:' websocket/tests/test_http.py || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}