summaryrefslogtreecommitdiff
path: root/dev-python/wstools/wstools-0.4.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wstools/wstools-0.4.5-r1.ebuild')
-rw-r--r--dev-python/wstools/wstools-0.4.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/wstools/wstools-0.4.5-r1.ebuild b/dev-python/wstools/wstools-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..9cd40cc8a03a
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.org/project/wstools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_test() {
+ esetup.py test
+}