summaryrefslogtreecommitdiff
path: root/dev-python/wstools/wstools-0.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wstools/wstools-0.4.5.ebuild')
-rw-r--r--dev-python/wstools/wstools-0.4.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wstools/wstools-0.4.5.ebuild b/dev-python/wstools/wstools-0.4.5.ebuild
new file mode 100644
index 000000000000..50f2db48e105
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"