summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-0.10.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xarray/xarray-0.10.8.ebuild')
-rw-r--r--dev-python/xarray/xarray-0.10.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-0.10.8.ebuild b/dev-python/xarray/xarray-0.10.8.ebuild
new file mode 100644
index 000000000000..f2e42e221e95
--- /dev/null
+++ b/dev-python/xarray/xarray-0.10.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="http://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die
+}