summaryrefslogtreecommitdiff
path: root/dev-python/xcffib/xcffib-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xcffib/xcffib-0.8.1.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.8.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/xcffib/xcffib-0.8.1.ebuild b/dev-python/xcffib/xcffib-0.8.1.ebuild
deleted file mode 100644
index f823f88b30d4..000000000000
--- a/dev-python/xcffib/xcffib-0.8.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
-HOMEPAGE="https://github.com/tych0/xcffib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="x11-libs/libxcb"
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
- dev-python/six[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]
- x11-apps/xeyes
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
-
-python_test() {
- virtx nosetests -d -v
-}