summaryrefslogtreecommitdiff
path: root/dev-python/xkbcommon
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest2
-rw-r--r--dev-python/xkbcommon/xkbcommon-1.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index 1f7514582082..9d95a02d8e1b 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST python-xkbcommon-0.8.gh.tar.gz 26951 BLAKE2B 0d2a649e3fee8baa9345ddca97dc7c77b5d9e10d7ca90cbb29bcc3531f4bba3deee39e610e147054e956310506fb79ebb43c85955b787e55046d67c12b851026 SHA512 ae2640ef89e7ace0468e970762c7be4d3f608701f1abea10174f274c622db28a6e6323cdc5bbbbaaa1065d4c4ddf9f67b75d4c34bb2e9a0bb6260778b15a330a
+DIST python-xkbcommon-1.0.gh.tar.gz 27258 BLAKE2B 3106877f8e87f50453a358eec4e6431642b00a6a2bc23d3088ef22379984869ec84cd042a1ac53dd72783f3005dad1efddf3f87410204b88bfde4f9da0044c97 SHA512 c7793d6f5517771006ff5a9c01deb9a37717157d7171af49ff459dc96b3b16a1d2d4c0f1272b5a8f683390de1e8e6a6ff92472f18828c7e38e0f2a1ee6f34f07
EBUILD xkbcommon-0.8.ebuild 851 BLAKE2B cf745a664f1e2d5014756a4ab73543b6794f1213604fdb42bbda19e89b25238824e45c30f0c9cc5051374d89945c8d21bee60abba4367d42ff24cd69b67b4b36 SHA512 f323e00d95332806214b370feb075dc40a6471b757a6902e977e32b44cb3e58700de6be52b191163bef0e74750424cf69dc4639fd25cd8f25689f72e6f5ebcfd
+EBUILD xkbcommon-1.0.ebuild 857 BLAKE2B f643dd6f7e458dc8b3bd2c86bd2121b9f742fa22dbdc3a97453e8441b4c98b27f1d7155d353e5830b7eacedd5560b4367c43e643bf32034f36cf13acaf9b1f7d SHA512 e884e729ebf9c66fd512052efd8386ddc002f53ce7fcbc7b5447fd067bf3aa20235c10a4ba4f3f366412553d62d655dea52f5c02d7aed3c289c993d4473e5171
MISC metadata.xml 355 BLAKE2B fef5c9392775c817ce5754bc6c70a30048e0aa252593229667b515d27421e95377f2199c121f43b112ef957a4172440417221fecf30ce9d068b23278bc2e2e4a SHA512 21fd7e00d1b727d6b281977fa4659c620259577dc346213437af17742ee4ceff367e0ccd45c8bb03f15afe6c0a1c885e1b3f9ebbd47b50518ec2953580b17df4
diff --git a/dev-python/xkbcommon/xkbcommon-1.0.ebuild b/dev-python/xkbcommon/xkbcommon-1.0.ebuild
new file mode 100644
index 000000000000..be6fb2d9ee7f
--- /dev/null
+++ b/dev-python/xkbcommon/xkbcommon-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-xkbcommon-${PV}
+DESCRIPTION="Python bindings for libxkbcommon using cffi"
+HOMEPAGE="
+ https://github.com/sde1000/python-xkbcommon/
+ https://pypi.org/project/xkbcommon/
+"
+SRC_URI="
+ https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# x11-libs/libxkbcommon dep per README
+RDEPEND="
+ >=x11-libs/libxkbcommon-${PV}
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf xkbcommon || die
+
+ epytest
+}