summaryrefslogtreecommitdiff
path: root/dev-python/xlrd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/Manifest3
-rw-r--r--dev-python/xlrd/xlrd-2.0.1-r1.ebuild25
-rw-r--r--dev-python/xlrd/xlrd-2.0.1.ebuild4
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/xlrd/Manifest b/dev-python/xlrd/Manifest
index 6cf22f6fca99..3f24cc5274b7 100644
--- a/dev-python/xlrd/Manifest
+++ b/dev-python/xlrd/Manifest
@@ -1,3 +1,4 @@
DIST xlrd-2.0.1.gh.tar.gz 368304 BLAKE2B eaf6dbefde00954452a96214c6a48e5d35526168445d15d721851da690bd99e53bd765a73495b00c8ee7ce243c487da0afbc6d6217abd7a5956820357dc97104 SHA512 b3e2efa216fc73bf55bb0b165ef63e797d16a00c62f0f2f2a2114d2db7204208f2623835697a045abe185f52c426ed5e9ef38a4f5f8e1880f0cfdf642af3c57e
-EBUILD xlrd-2.0.1.ebuild 594 BLAKE2B aedaf27c22ff4b0847497bd9fb7950128a6efd0a8757a2d91a26d4718749922d2e62ea93e15d1a5415dcce1404e5be76547240af9eb53ba03f91f441c9495e75 SHA512 7e84df768f5de780e6e67a93e9c0186a04567c4dbf924d61e58f69cc8b5d1acf44fcebaf4c97200cbee5fe72aceb6381a67192f8d36d901eb9792399b3fb6960
+EBUILD xlrd-2.0.1-r1.ebuild 641 BLAKE2B 9b3c9de52dd7998c3b7da255bcf602ff6cd70ff2b39b7ec5c1060c8d4f0e518fa1df60cebde75ae9afc50fa964183dba54e2469aeeba7ff30bceb91edd9da17c SHA512 8af28af3a8bd13722fb75b094d0cd1fd83638151ac84380c15595a3fb5432dc169bdde61c576af6f9c873dc9de3e12dcc3d4ed5340cab636fc45af5b52779b90
+EBUILD xlrd-2.0.1.ebuild 601 BLAKE2B 66cd8f6aa1f76971c4204299106b5362ac1136a376a0aaecf9b87c1950256378a40143818362d22888b445e8351c0846162aa59e101c999d8180cd28944c9428 SHA512 daf9a3075b267e2abcbd3443f1c6b6eb58e023def414aed68ab39cbd9bce1a236aa5cdcb4eedb8ee8234518ab792694dbb3985d600cf2c57db0d2897bcb9f963
MISC metadata.xml 576 BLAKE2B 7146486fa8a2bab5361906374c81a7557837ba2408b34178f1c30c48dcb09a696151b9a4a14c98ae80108bab329215d13fd57695cbe710cf4da0d9fc10fb3030 SHA512 db59cf6c70ffb69390c0f9a7b9682c48ea3b786aa53e7fdd92343efee0c2aaf8791529237fa826cc041eeecf290d95fe69b6ff099b304da945cb62b4e3452832
diff --git a/dev-python/xlrd/xlrd-2.0.1-r1.ebuild b/dev-python/xlrd/xlrd-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..33f76f0072a9
--- /dev/null
+++ b/dev-python/xlrd/xlrd-2.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to extract data from Microsoft Excel spreadsheets"
+HOMEPAGE="
+ https://www.python-excel.org/
+ https://github.com/python-excel/xlrd/
+"
+SRC_URI="
+ https://github.com/python-excel/xlrd/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+distutils_enable_tests pytest
diff --git a/dev-python/xlrd/xlrd-2.0.1.ebuild b/dev-python/xlrd/xlrd-2.0.1.ebuild
index e0f28bdfc20d..fb3c6883e7b4 100644
--- a/dev-python/xlrd/xlrd-2.0.1.ebuild
+++ b/dev-python/xlrd/xlrd-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,6 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
distutils_enable_tests pytest