summaryrefslogtreecommitdiff
path: root/dev-python/yarl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest4
-rw-r--r--dev-python/yarl/yarl-1.19.0.ebuild66
-rw-r--r--dev-python/yarl/yarl-1.20.0.ebuild67
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index c8897f1df6c6..e4454973f1be 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,3 +1,7 @@
DIST yarl-1.18.3.tar.gz 181062 BLAKE2B 41e0e6173bb257b643d7678e3011af7ea7f6ac8100bd68aae6e5a9af95e36ae95f83c516a11169fd1d1d669742b3a8878267533c81289ec56a66bb0d53b2db25 SHA512 1686c5ef1b5f3e1cebd121abb7916e45f4a9b08d941a80c34861e87f6121187ee7a553a373405a9fef2332177adf55ffe89bc9a3cabbf24e31905357fdeceba3
+DIST yarl-1.19.0.tar.gz 184396 BLAKE2B 08e1e1d3aac39a1bace97f3d38f33dfa335309a6a809227d830497fb6fff6c506ff8457ec68de5cfc57f3661e190ecd78fbe2481af7e419d5d889d8f496852e0 SHA512 95cf1f26be8497e39ce150672ac95ff36a4a695b8fbb902edb4811b601cc3f73cf8b72b45625afe957649b7a49d08588db0a7b91b46c449c64c9e55fcbda8e23
+DIST yarl-1.20.0.tar.gz 185258 BLAKE2B 9ffe4d715bcadfa061e4fae7de7c5124c3442abc659cc112b19e02da89691ce13ee434cec1b96be139aca9abbe45afe13d8931a03cea7b41857d43f38cf5f62c SHA512 826bd2d95a8de05630a597b2427a3c37e50b6d44a73d7003ffb20add68abed4742fb5102c7bdfdb69509b39e7e63bf506ffa0f22138715bf9c8c1a3836bb7607
EBUILD yarl-1.18.3.ebuild 1482 BLAKE2B 61a0d48398938a32654e6956dbd589ed4a1ce9d038e6803269b63c70f5cc2e7846f7b9e2bbe9f5cef6fcc62e1989f3f0e13bfaf5d4622e9f760c5701924e54ef SHA512 42ee1c3a5f3887095fe61456e0c7f2fc9bb7b5c874864675f98b43708102279a66d8c1eafd1113bfa3346c7868d8db25e894742281ea5e6df638b1203ee3b7fd
+EBUILD yarl-1.19.0.ebuild 1490 BLAKE2B bd9ebbe676b70089daef358f4224b532c0d6fecc506a93b2a1c9f8c6da08a4c03f59b7841201779879fe944f5f544876b6b85144df4c46102d5907f021dba5b2 SHA512 ca38402e797e157003a1ea7fa607490891334b24dec75e152c0dc5099ad38792421f02e1de9636a637824453e31f45e60d8b613ec02a66e6d0c221ff3918f039
+EBUILD yarl-1.20.0.ebuild 1534 BLAKE2B a675d56b9770bd1ab2b3fd398c4c3bbf23d5e79eb2bc6c4eb074df2c78864f5fb9b1ae17ca361cb82ed3aa3bf32d5810177daa04503eeba8026e62a49d11c43f SHA512 8722ccab009de84fcf304a4bb02388ab2adadffcc8a7a2db62cc74edbb22328831b74bf8c52fc0edb106c9b32630e3950bd27a9fc913874723960f8bd9f3e800
MISC metadata.xml 361 BLAKE2B cd963daea78f2c4d229f0309ff843264e2bd8e9dd85bfe326a366371c6a1b520b8755b07a3da4e180ee6cd5566ab777574d1bd7fd5cf550ca73f50fe4ab14bcb SHA512 af9ecdf852203e4a7613f95baedd3a0899a0a17d3e761caa1f25fd17a56eaff3de303485b4509039ac155cd4d6ade7a2b8b729d4af166bff638daa48cfc3b31c
diff --git a/dev-python/yarl/yarl-1.19.0.ebuild b/dev-python/yarl/yarl-1.19.0.ebuild
new file mode 100644
index 000000000000..44a020ca0521
--- /dev/null
+++ b/dev-python/yarl/yarl-1.19.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/propcache-0.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x YARL_NO_EXTENSIONS=0
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # benchmarks
+ tests/test_quoting_benchmarks.py
+ tests/test_url_benchmarks.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local opts=()
+ # note different boolean logic than for backend (sigh)
+ local -x YARL_NO_EXTENSIONS=
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+
+ rm -rf yarl || die
+ epytest -o addopts= "${opts[@]}"
+}
diff --git a/dev-python/yarl/yarl-1.20.0.ebuild b/dev-python/yarl/yarl-1.20.0.ebuild
new file mode 100644
index 000000000000..bdb9fedd44c5
--- /dev/null
+++ b/dev-python/yarl/yarl-1.20.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+# note: python3_13t is officially supported
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/propcache-0.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x YARL_NO_EXTENSIONS=0
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # benchmarks
+ tests/test_quoting_benchmarks.py
+ tests/test_url_benchmarks.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local opts=()
+ # note different boolean logic than for backend (sigh)
+ local -x YARL_NO_EXTENSIONS=
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+
+ rm -rf yarl || die
+ epytest -o addopts= "${opts[@]}"
+}