summaryrefslogtreecommitdiff
path: root/dev-python/yarl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest2
-rw-r--r--dev-python/yarl/yarl-1.9.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index 987014602a95..7d0b58dc9ab5 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,3 +1,5 @@
DIST yarl-1.8.2.gh.tar.gz 109938 BLAKE2B 1f2cec38bb681f6a59f10253c75e74912d482cdbe0e639e3ba0a43b9d6ab7b7edc1558c9fffaffd7aad9fa905d884e856ff7f7b69dd103800ef62f7f05de90b5 SHA512 d5dcebcec06d520b48a1d879671a92371bd89eabb7be700c129fcc45e763ecc0370cbb5e88c7b9be05ecb3317370231293a8c076ed68d71a36fe953219dd27ea
+DIST yarl-1.9.1.tar.gz 184455 BLAKE2B 0d4127129832493e4ffa8e2389048d77c7df222809a551bb4ab8583e26b2a4db8876bf62bee7079bd4d1f1b9b55b4875678db84fca38c30b3453bd4117bd461c SHA512 a583bea632b96ef1448a5f28a03c139e822ddc7f5ee8c545994c2746b92022b9ea4d3d8c7ded374a9f3aca1ee22eacd1a31bf96d690eae1775954175393679d0
EBUILD yarl-1.8.2.ebuild 910 BLAKE2B eb6b6d1b490406656d73a6d687370c4e5454a399e82a405de264724161fd46a0f5707ce3442943f3f37957b316b1036a07f91b6046213913cda64d7f0852b558 SHA512 4ba30aac419138b2bdfd6d2945b772a1b59927d11d5fb347018dfd7ed9a7dd6fa2ebfc533e861b440fb886835d6a25044e2efa9842fa29e5d1b586f624c95511
+EBUILD yarl-1.9.1.ebuild 857 BLAKE2B e60732429881eb3eb56e66ec7ea0d323100a161472fc3670be090f00cef7a160ebed615587eb0ab5d7a582568f3b65d2716343a96c710bc072473808efb5ca38 SHA512 45229167fb397c15b48e1f17f108b24dc23d57e35443af799fdd0559b5aa829a41f6e33b0f20bc98cb2c52f0243fa2eb7cb5d6d877651a885871cf39bd900ac3
MISC metadata.xml 440 BLAKE2B 10fd0e37c9be76c5d1dd90b9fd1cb1e5161fc5a7d2b51bcb5658a8c187a67d5f9573241733c3f9570e9fb7767bf84b38a6f8b2c212596627bea4e1686b7eb41e SHA512 c9e340124ed93cb0d52a0ae5abd43c10528197893c3d5ab57a0eb7046ebae5b80119f7b033d6697110c4bc064c0a8581d904788f6969cb52a433064067898cbe
diff --git a/dev-python/yarl/yarl-1.9.1.ebuild b/dev-python/yarl/yarl-1.9.1.ebuild
new file mode 100644
index 000000000000..8cc9f27c1914
--- /dev/null
+++ b/dev-python/yarl/yarl-1.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+src_configure() {
+ set -- cython -3 yarl/_quoting_c.pyx
+ echo "${*}" >&2
+ "${@}" || die
+}
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}