summaryrefslogtreecommitdiff
path: root/dev-python/zstandard
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zstandard')
-rw-r--r--dev-python/zstandard/Manifest1
-rw-r--r--dev-python/zstandard/zstandard-0.23.0-r1.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/zstandard/Manifest b/dev-python/zstandard/Manifest
index d407e293da1e..6da06a94be6a 100644
--- a/dev-python/zstandard/Manifest
+++ b/dev-python/zstandard/Manifest
@@ -1,5 +1,4 @@
AUX zstandard-0.23.0-zstd-1.5.7.patch 6515 BLAKE2B 9e8b8e16405f7ef75f9bf122e51c5ac9a40ca4868346d9586278c55befe0da70dc51c816328667a82306447732d35a1deac0df5acba66aadeaaf5df19aef4f73 SHA512 1bd96eea464ad8fb469abd0bedfc9247053c3baa48654e34df4676222be61b7d99a87184b99c5bd3418e15c2ec088f83d71b7ad9a0323b7f9a6972a29c733abb
DIST python-zstandard-0.23.0.gh.tar.gz 732448 BLAKE2B 920b53dc4a221059411062229ddf0ff51c478c2212e5599dec21298fef8e30b7a160c2f7d958ef95251ce5fb1357eaf4a8c3e4eca37304ef7a43176f723f3394 SHA512 06d799f8c5e89e5cc2f5b8ff100aeb3c3ff938757ce39852affb075487f65406d7d3f6d611b1864ec025fff86a51bf15b80c8af6260beda050b4fef5b7edd206
-EBUILD zstandard-0.23.0-r1.ebuild 1895 BLAKE2B b902b5ef065c4232d2ebc8fa3714b42ef6b136051f0086907043f68087bd28586aeac36e69158fbfb4102c56a8f1daf9f00b525fc4bbc13133c38810e9223317 SHA512 ecda9eb4ca319f254559c2b40b1cb79a05e7ac847d4ef7528c779c1750cbc3ce48063e779a0cff47fb50bfa538800caa8dadbe5b382eee1cb3ae56990f13a53e
EBUILD zstandard-0.23.0-r2.ebuild 1942 BLAKE2B ad39d8c43515b65a2ee646e7547a15c4fb0cf4c98389edab0a643a4949b35cb3caacf8d06f659bb173fd43a5600337e779886f1bcfc670cf6bf0fb66f183c36a SHA512 e52e0d49273f003b9be9d477b83112c13114bf567ddedf84843134a9410223809ee576e21f337a84c25cd6fbb64e37e09b78451cbce96ce2c7226791b473ce54
MISC metadata.xml 378 BLAKE2B dd5834c84bb375812b3a3cfcc00d29aa43ac8954b044e188e8f38bdca93fdf1ce98fe78b78dbeccd935c83ca10f3ce18f893e5720dd8991118b6c69149a4ac61 SHA512 06554d973b525d53c680c3e43041f33125dad222339e645294fbc22670a7eadb0e9bf8a3b0771d2b2fb8f136d958eadb32c295179d1547c50ae26754360609f3
diff --git a/dev-python/zstandard/zstandard-0.23.0-r1.ebuild b/dev-python/zstandard/zstandard-0.23.0-r1.ebuild
deleted file mode 100644
index ea508a41132d..000000000000
--- a/dev-python/zstandard/zstandard-0.23.0-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
-
-inherit distutils-r1
-
-MY_P=python-zstandard-${PV}
-DESCRIPTION="Zstandard Bindings for Python"
-HOMEPAGE="
- https://github.com/indygreg/python-zstandard/
- https://pypi.org/project/zstandard/
-"
-SRC_URI="
- https://github.com/indygreg/python-zstandard/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# TODO: figure out why zstd-1.5.7 breaks their hacky awful CFFI thingy
-DEPEND="
- <app-arch/zstd-1.5.7:=
-"
-RDEPEND="
- ${DEPEND}
- $(python_gen_cond_dep '
- >=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]
- ' 'python*')
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # the C backend is repeatedly broken, so force CFFI instead
- sed -e '/PYTHON_ZSTANDARD_IMPORT_POLICY/s:default:cffi:' \
- -i zstandard/__init__.py || die
- # unbundle zstd
- rm zstd/* || die
- > zstd/zstd.c || die
- # it does random preprocessing on that, so we can't use #include
- local f
- for f in zdict.h zstd.h; do
- cp "${ESYSROOT}/usr/include/${f}" "zstd/${f}" || die
- done
- sed -i -e '/include_dirs/a libraries=["zstd"],' make_cffi.py || die
-
- distutils-r1_src_prepare
-
- DISTUTILS_ARGS=(
- --no-c-backend
- )
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # unreliable, fails on x86
- tests/test_data_structures.py::TestCompressionParameters::test_estimated_compression_context_size
- # check for bundled zstd version, fails on other system zstd
- tests/test_module_attributes.py::TestModuleAttributes::test_version
- )
-
- rm -rf zstandard || die
- epytest
-}