summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261389 -> 261387 bytes
-rw-r--r--dev-python/pyside2-tools/Manifest2
-rw-r--r--dev-python/pyside2-tools/pyside2-tools-5.15.2.ebuild77
-rw-r--r--dev-python/pyside2/Manifest2
-rw-r--r--dev-python/pyside2/pyside2-5.15.2-r2.ebuild216
-rw-r--r--dev-python/shiboken2/Manifest2
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild172
7 files changed, 0 insertions, 471 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index b4136e32d5fb..767b83013e80 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pyside2-tools/Manifest b/dev-python/pyside2-tools/Manifest
index 579f91f90d87..d3a9e2336d1f 100644
--- a/dev-python/pyside2-tools/Manifest
+++ b/dev-python/pyside2-tools/Manifest
@@ -1,6 +1,4 @@
AUX pyside2-tools-5.15.1-dont-install-tools.patch 1782 BLAKE2B a9a1c3cb8d1e6feabbc752bb4bf0af30b645736b9895fe96063dc4a9d5668866523e567f723693b17c6da4101d28713cfa6ad8adadb78e6bb99756d7c69244a2 SHA512 c8b17db89f42a52f4191dda953d7228eafcafd6afb6d7b70527cef090ffd1f073970010a817bede941de10b4e40e41d35fb99b74091baeea6d237c08eb7f225f
-DIST pyside-setup-opensource-src-5.15.2.tar.xz 3472624 BLAKE2B 099abeaf25059a88f299f90b18cf79aa45acd86580c0873767b09f76268d6746cc3576743a19493a605de59b520471ddee6bba0e5340801ef44a21f2a9d41507 SHA512 5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62
DIST pyside-setup-opensource-src-5.15.5.tar.xz 3577972 BLAKE2B ee16ce18ec4103add41ad89b658012cb2e8695bda51269d3cd1614c2b6d029c0eaba5e592d5e58b6267e1ddc020a938d3ccd2fbc9461cc5bf202f3bdbf6b5d62 SHA512 61b987ec823e9a89f2a07a1991d47f36eb45e3ce416aa6e0032a58ba3d623ac26224cb0f43a2db76850bce7290d12fae610de06405350362caac7860ba99f0c3
-EBUILD pyside2-tools-5.15.2.ebuild 1654 BLAKE2B 5f08539ae1da3dfcc0b3c923b6457cce03f26aa3889bc72461432b820d0d9d313439e48dc6186bd1c94915b233a97e1a55994e0662cedffb56592bcdd07433cf SHA512 0886f8591d9a725a75d78513f757537abdf072bc4e9e2d9d8a882ca32ce3e5841f01056bfb661c7406cf2ee88aac2664428cf9dfe0e43e2339c61140baa7cc5e
EBUILD pyside2-tools-5.15.5.ebuild 1654 BLAKE2B a995039b5d9df220c7a2b26d555d5ef0895f934ec47a86f05b6e1d5a20889c5621973289ec2318630f89d1af83b52d197ed96e32d911360837ff44c179224cf6 SHA512 aa5d0e12a94a9a11c87afdc582540bbd61ed821beaebdee89eb83ad33a4a1a420b4169806ea27584e0f74f638c49be45b61f7d2cff7161ee0d0498b62fef45aa
MISC metadata.xml 512 BLAKE2B e06bacf79750f6cc22b41ade8840a01636793100a85cc469c19af1b4273ef33adb3dec755947057a892e88de4ac68e665fa0ccb265457dd09a502964bd991749 SHA512 d201e34b2d73fb308c6b5f14b2d0d292b453b5ef05c820efe429fcfa7259b23f17bc015c08b8f938a2df75f5b654cc1357632a786abfb555479e3f172feee3fd
diff --git a/dev-python/pyside2-tools/pyside2-tools-5.15.2.ebuild b/dev-python/pyside2-tools/pyside2-tools-5.15.2.ebuild
deleted file mode 100644
index 10f20428593a..000000000000
--- a/dev-python/pyside2-tools/pyside2-tools-5.15.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{8..10} )
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake python-r1
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="PySide development tools (pyside2-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide2"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/${PN}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-python/pyside2-${PV}[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-# the tools conflict with tools from QT
-PATCHES=(
- "${FILESDIR}/${PN}-5.15.1-dont-install-tools.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- # The tests are only related to the tools that we don't install
- local mycmakeargs=(
- -DBUILD_TESTS=OFF
- )
-
- pyside-tools_configure() {
- local mycmakeargs=(
- "${mycmakeargs[@]}"
- -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
- )
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- python_doexe "${BUILD_DIR}/pylupdate/pyside2-lupdate"
- }
-
- python_foreach_impl pyside-tools_install
-
- doman pylupdate/pyside2-lupdate.1
- einstalldocs
-}
diff --git a/dev-python/pyside2/Manifest b/dev-python/pyside2/Manifest
index f7cc6dfc7638..6fcb9e7aeb3c 100644
--- a/dev-python/pyside2/Manifest
+++ b/dev-python/pyside2/Manifest
@@ -1,8 +1,6 @@
AUX pyside2-5.15.2-python310.patch 508 BLAKE2B bdfc33975d1dd0c9eb73d1bae3ec2aff8c1ab1eace10dbde18b467c451605ef5e8c278965043d3cf19dfa8dc80f3fe4bdc1caadd15119303c3e134e364ed5098 SHA512 69a8691d452472f3ae8a58eadd1c1d69cef186192f9fe8311ae65419c94a9efc0331e9446b97f688777f3d5c7ef5a0100bed2e4ce3956b2a4aacfad0b95c1c75
AUX pyside2-5.15.2-python311-fixups.patch 1962 BLAKE2B 37d91352ea09eaef6d36c600165e4fea74145b0fa05620e739254d3983acc501455154fc51ce3448aa4f60a00cd377f0896cb3dc14f1a921d6948dc53c500784 SHA512 39e999c80ed2717eaf59b47c12e64208d1b54d3d61daacf7a8ebeb4586f3b7312dd5db3fc53d4d2f3c426d80729e5d655e9b612153c704b40b7d261ddd57e580
AUX pyside2-5.15.2-python311.patch 1777 BLAKE2B 1afa7c39755c4f91b4b4c951f59e1a3190f924d8b20cf2140ad5342c2fa046ff7e6bec540bea9d7652116894e0cb7f5fa5ea73067212ca5b631382e7139d7786 SHA512 b88f300e4944cbb9adc8ac887e263e74e088a1b291000c86f6677a01241939e612fa5eebba3807fb2318477e68de241914832cc92ed0470726804d3098486120
-DIST pyside-setup-opensource-src-5.15.2.tar.xz 3472624 BLAKE2B 099abeaf25059a88f299f90b18cf79aa45acd86580c0873767b09f76268d6746cc3576743a19493a605de59b520471ddee6bba0e5340801ef44a21f2a9d41507 SHA512 5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62
DIST pyside-setup-opensource-src-5.15.5.tar.xz 3577972 BLAKE2B ee16ce18ec4103add41ad89b658012cb2e8695bda51269d3cd1614c2b6d029c0eaba5e592d5e58b6267e1ddc020a938d3ccd2fbc9461cc5bf202f3bdbf6b5d62 SHA512 61b987ec823e9a89f2a07a1991d47f36eb45e3ce416aa6e0032a58ba3d623ac26224cb0f43a2db76850bce7290d12fae610de06405350362caac7860ba99f0c3
-EBUILD pyside2-5.15.2-r2.ebuild 8669 BLAKE2B bffd6ee4d015761d13684a328dcd5a2c623646cd6ba3dee968941ac438b20d64cc8164ea61462a3c540e0b836a5f093883135e7c69b66a195c18d19403788e00 SHA512 4bc858eb5d75cfdc36e077064175efdf3d36980948546aad775561d1c25e90ad01be93035d2bf1713f687e1b86efe099f67fe17492a27fe16fa8a2153786651a
EBUILD pyside2-5.15.5.ebuild 9114 BLAKE2B acf0acd94e58949465895e7771fc771aed19dcb3dd4d319e575c8c2edf3820a7aea4b1793fb3627e26593e27a7d36ebe571d372f6e5e78670f49aac9fd609180 SHA512 ecb43e1bd5b621c3fe4d2db0b21b7ff7650bea5cc38e579527eda8ce3a59dffabb25e56a2424c0d0e3533d6e501c9f7af48aed7f15977abf179856445e4bb6b8
MISC metadata.xml 2255 BLAKE2B 00982d17109b327ce063f5ba53474603cc73ffb013268ec9f6b751a73792a790f56de285291e70ad12147c27ba97b516be1318df312483d67d72509f8e8d8655 SHA512 830f9510f5e141422cbbab356d34a34b631f948eea14bcc96badbef65ce10f56c648748edc4ddf06be77b1c597a7d12d4552bde122937eb4cda01b304a3193c7
diff --git a/dev-python/pyside2/pyside2-5.15.2-r2.ebuild b/dev-python/pyside2/pyside2-5.15.2-r2.ebuild
deleted file mode 100644
index c18757c9ac57..000000000000
--- a/dev-python/pyside2/pyside2-5.15.2-r2.ebuild
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit cmake python-r1 virtualx
-
-# TODO: Add conditional support for "QtRemoteObjects" via a new "remoteobjects"
-# USE flag after an external "dev-qt/qtremoteobjects" package has been created.
-# TODO: Add conditional support for apidoc generation via a new "doc" USE flag.
-# Note that doing so requires the Qt source tree, sphinx, and graphviz. Once
-# ready, pass the ${QT_SRC_DIR} variable to cmake to enable this support.
-# TODO: Disable GLES support if the "gles2-only" USE flag is disabled. Note
-# that the "PySide2/QtGui/CMakeLists.txt" and
-# "PySide2/QtOpenGLFunctions/CMakeLists.txt" files test for GLES support by
-# testing whether the "Qt5::Gui" list property defined by
-# "/usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake" at "dev-qt/qtgui" installation
-# time contains the substring "opengles2". Since cmake does not permit
-# properties to be overridden from the command line, these files must instead
-# be conditionally patched to avoid these tests. An issue should be filed with
-# upstream requesting a CLI-settable variable to control this.
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://wiki.qt.io/PySide2"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/pyside2"
-
-# See "sources/pyside2/PySide2/licensecomment.txt" for licensing details.
-LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="
- 3d charts concurrent datavis designer gles2-only +gui help location
- multimedia +network positioning printsupport qml quick script scripttools
- scxml sensors speech sql svg test testlib webchannel webengine websockets
- +widgets x11extras xml xmlpatterns
-"
-
-# Manually reextract these requirements on version bumps by running the
-# following one-liner from within "${S}":
-# $ grep 'set.*_deps' PySide2/Qt*/CMakeLists.txt
-# Note that the "designer" USE flag corresponds to the "Qt5UiTools" module.
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- 3d? ( gui network )
- charts? ( widgets )
- datavis? ( gui )
- designer? ( widgets xml )
- gles2-only? ( gui )
- help? ( widgets )
- location? ( positioning )
- multimedia? ( gui network )
- printsupport? ( widgets )
- qml? ( gui network )
- quick? ( qml )
- scripttools? ( gui script widgets )
- speech? ( multimedia )
- sql? ( widgets )
- svg? ( widgets )
- testlib? ( widgets )
- webengine? (
- location quick
- widgets? ( gui network printsupport webchannel )
- )
- websockets? ( network )
- widgets? ( gui )
- x11extras? ( gui )
-"
-
-# Tests fail pretty bad and I'm not fixing them right now
-RESTRICT="test"
-
-# Minimal supported version of Qt.
-QT_PV="$(ver_cut 1-2):5"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-python/shiboken2-${PV}[${PYTHON_USEDEP}]
- dev-qt/qtcore:5=
- dev-qt/qtopengl:5=
- dev-qt/qtserialport:5=
- 3d? ( >=dev-qt/qt3d-${QT_PV}[qml?] )
- charts? ( >=dev-qt/qtcharts-${QT_PV}[qml?] )
- concurrent? ( >=dev-qt/qtconcurrent-${QT_PV} )
- datavis? ( >=dev-qt/qtdatavis3d-${QT_PV}[qml?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[jpeg,gles2-only?] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- location? ( >=dev-qt/qtlocation-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[qml?,widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV}[qml?] )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- script? ( >=dev-qt/qtscript-${QT_PV} )
- scxml? ( >=dev-qt/qtscxml-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV}[qml?] )
- speech? ( >=dev-qt/qtspeech-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV}[qml?] )
- webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV}[qml?] )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xml? ( >=dev-qt/qtxml-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV}[qml?] )
-"
-DEPEND="${RDEPEND}
- test? ( x11-misc/xvfb-run )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-python310.patch"
- "${FILESDIR}/${P}-python311.patch"
- "${FILESDIR}"/${PN}-5.15.2-python311-fixups.patch
-)
-
-src_configure() {
- # See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DAnimation=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DCore=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DExtras=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DInput=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DLogic=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DRender=$(usex !3d)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Charts=$(usex !charts)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Concurrent=$(usex !concurrent)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DataVisualization=$(usex !datavis)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Designer=$(usex !designer)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Gui=$(usex !gui)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Help=$(usex !help)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Location=$(usex !location)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Multimedia=$(usex !multimedia)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5MultimediaWidgets=$(usex !multimedia yes $(usex !widgets))
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Network=$(usex !network)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Positioning=$(usex !positioning)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5PrintSupport=$(usex !printsupport)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Qml=$(usex !qml)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Quick=$(usex !quick)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5QuickWidgets=$(usex !quick yes $(usex !widgets))
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=$(usex !script)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=$(usex !scripttools)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Scxml=$(usex !scxml)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sensors=$(usex !sensors)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5TextToSpeech=$(usex !speech)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sql=$(usex !sql)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Svg=$(usex !svg)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=$(usex !testlib)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5UiTools=$(usex !designer)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebChannel=$(usex !webchannel)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine=$(usex !webengine)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineCore=$(usex !webengine)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets=$(usex !webengine yes $(usex !widgets))
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebSockets=$(usex !websockets)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=$(usex !widgets)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5X11Extras=$(usex !x11extras)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Xml=$(usex !xml)
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5XmlPatterns=$(usex !xmlpatterns)
- )
-
- pyside2_configure() {
- local mycmakeargs=(
- "${mycmakeargs[@]}"
- -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
- -DSHIBOKEN_PYTHON_SHARED_LIBRARY_SUFFIX="-${EPYTHON}"
- )
- cmake_src_configure
- }
- python_foreach_impl pyside2_configure
-}
-
-src_compile() {
- python_foreach_impl cmake_src_compile
-}
-
-src_test() {
- local -x PYTHONDONTWRITEBYTECODE
- python_foreach_impl virtx cmake_src_test
-}
-
-src_install() {
- pyside2_install() {
- cmake_src_install
- python_optimize
-
- # Uniquify the shiboken2 pkgconfig dependency in the PySide2 pkgconfig
- # file for the current Python target. See also:
- # https://github.com/leycec/raiagent/issues/73
- sed -i -e 's~^Requires: shiboken2$~&-'${EPYTHON}'~' \
- "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}.pc || die
-
- # Uniquify the PySide2 pkgconfig file for the current Python target,
- # preserving an unversioned "pyside2.pc" file arbitrarily associated
- # with the last Python target. (See the previously linked issue.)
- cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
- }
- python_foreach_impl pyside2_install
-
- # CMakeLists.txt installs a "PySide2Targets-gentoo.cmake" file forcing
- # downstream consumers (e.g., pyside2-tools) to target one
- # "libpyside2-*.so" library linked to one Python interpreter. See also:
- # https://bugreports.qt.io/browse/PYSIDE-1053
- # https://github.com/leycec/raiagent/issues/74
- sed -i -e 's~pyside2-python[[:digit:]]\+\.[[:digit:]]\+~pyside2${PYTHON_CONFIG_SUFFIX}~g' \
- "${ED}/usr/$(get_libdir)/cmake/PySide2-${PV}/PySide2Targets-${CMAKE_BUILD_TYPE,,}.cmake" || die
-}
diff --git a/dev-python/shiboken2/Manifest b/dev-python/shiboken2/Manifest
index 49b504ef7a3d..51cc47ec06d4 100644
--- a/dev-python/shiboken2/Manifest
+++ b/dev-python/shiboken2/Manifest
@@ -6,8 +6,6 @@ AUX shiboken2-5.15.5-add-numpy-1.23-compatibility.patch 1095 BLAKE2B 8266da9d94c
AUX shiboken2-5.15.5-python311-1.patch 3124 BLAKE2B 97e51ae8cc6866da7ac9cced4f1988eeb00c8bbf1e033766b6f926ec16ad1dab171f15060ddaaf541f1eadfcc0fb9251df2ea613c3c16a51467d0870b378dda1 SHA512 8d11c6cc737ac99aa748e9e100a8b559aa315142f587d77f4ecae8f5ac74e65ddfb3348631203a781d445177d423f0a83307d8121b5d35ba6065e0cbb52673a8
AUX shiboken2-5.15.5-python311-2.patch 2056 BLAKE2B c93be29e31b0fa6ce28a29de0dc4dba9635e86ba0103d77334e324a0d26f4c81c9ee6583bef146eb908fe290426eb462dd0a0f68e917ca5f3c4505742d673a0f SHA512 df6f185546180b3d27d8ed1ec1ccf90cdf3813f8928894717ad02e97f0c404b8dc00aed330e8b51aa7e04d5b3e621a15981fc911b2371542f9266c147fdf3828
AUX shiboken2-5.15.5-python311-3.patch 2363 BLAKE2B 84521be2008dda0fc9398dac2c6e235d0d976c3219f7ecf50f28938a7cce6952ec41795c2c86d0f71ccd94210661dc22a471adb2f879a133e11a3148923fd708 SHA512 540ff5afbfebcc00f20c43993f67458013f4655c06505fdf23bc26085bd2c621863dd9c28be1a20dca299113aee828974f853b145818fdb11d59fc12d0bb8c14
-DIST pyside-setup-opensource-src-5.15.2.tar.xz 3472624 BLAKE2B 099abeaf25059a88f299f90b18cf79aa45acd86580c0873767b09f76268d6746cc3576743a19493a605de59b520471ddee6bba0e5340801ef44a21f2a9d41507 SHA512 5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62
DIST pyside-setup-opensource-src-5.15.5.tar.xz 3577972 BLAKE2B ee16ce18ec4103add41ad89b658012cb2e8695bda51269d3cd1614c2b6d029c0eaba5e592d5e58b6267e1ddc020a938d3ccd2fbc9461cc5bf202f3bdbf6b5d62 SHA512 61b987ec823e9a89f2a07a1991d47f36eb45e3ce416aa6e0032a58ba3d623ac26224cb0f43a2db76850bce7290d12fae610de06405350362caac7860ba99f0c3
-EBUILD shiboken2-5.15.2-r2.ebuild 6554 BLAKE2B a4d2ba9ae4ff29d9b974b26a5c5c0c7db66790bab3433dab0b84e2c0465b08bd6c8a15df78ef342a8942472978c031cba809625286d619a0e3119e20e17bb27d SHA512 e0287e12b01024290b3b97103244bfcfb1e3385bc4e2d1fa4465894d6afc30dcaad50bd335bee4d26536d48db742c6aa0d924dce59d696721fedae747b09d01c
EBUILD shiboken2-5.15.5.ebuild 6563 BLAKE2B 455dc6f82e4269b6cf3f22574fe0a11c67caaa053ecff26b6b3ab2d1288f578fdca91e2d7ddedcdce0182bf3efd637f6514fb991fcd8b6abc4d40df76b5bba56 SHA512 850fdf59276270cb14fba754c9b405d1c4e2615970b9826ed4542822dc80e0a711efa8728f87dbfac5b3a3855a204be1af31c8ad0dce8083bc680cfb15e0f12e
MISC metadata.xml 730 BLAKE2B 803b825adb9fcd4379b1e3fba57d6b1916a81ced12f3b3c7d3ddcd68a0c03e85fcf31d5b07a70deebe073f267fe93a0529f7ffb4b1a9508a2223894883044f3b SHA512 5a462077fee2bd3ac87ab79274be0a718fd9b273fca4946d2d2734cefdf5817e6b4dc478a828b3bc783c63e64a62a6662b482d61eefe57386c15f9703a57fb24
diff --git a/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild b/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild
deleted file mode 100644
index b022d8ba5b8c..000000000000
--- a/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Split the "/usr/bin/shiboken2" binding generator from the
-# "/usr/lib64/libshiboken2-*.so" family of shared libraries. The former
-# requires everything (including Clang) at runtime; the latter only requires
-# Qt and Python at runtime. Note that "pip" separates these two as well. See:
-# https://doc.qt.io/qtforpython/shiboken2/faq.html#is-there-any-runtime-dependency-on-the-generated-binding
-# Once split, the PySide2 ebuild should be revised to require
-# "/usr/bin/shiboken2" at build time and "libshiboken2-*.so" at runtime.
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit cmake llvm python-r1 toolchain-funcs
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="Python binding generator for C++ libraries"
-HOMEPAGE="https://wiki.qt.io/PySide2"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/shiboken2"
-
-# The "sources/shiboken2/libshiboken" directory is triple-licensed under the
-# GPL v2, v3+, and LGPL v3. All remaining files are licensed under the GPL v3
-# with version 1.0 of a Qt-specific exception enabling shiboken2 output to be
-# arbitrarily relicensed. (TODO)
-LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="+docstrings numpy test vulkan"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Tests fail pretty bad and I'm not fixing them right now
-RESTRICT="test"
-
-# Minimal supported version of Qt.
-QT_PV="$(ver_cut 1-2):5"
-
-# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
-RDEPEND="${PYTHON_DEPS}
- >=dev-qt/qtcore-${QT_PV}
- sys-devel/clang:=
- sys-devel/clang-runtime:=
- docstrings? (
- >=dev-libs/libxml2-2.6.32
- >=dev-libs/libxslt-1.1.19
- >=dev-qt/qtxml-${QT_PV}
- >=dev-qt/qtxmlpatterns-${QT_PV}
- )
- numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
- vulkan? ( dev-util/vulkan-headers )
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-qt/qttest-${QT_PV} )
-"
-
-DOCS=( AUTHORS )
-
-PATCHES=(
- "${FILESDIR}/${P}-python310.patch"
- "${FILESDIR}/${P}-numpy-1.23.patch"
- "${FILESDIR}/${P}-python311.patch"
- "${FILESDIR}"/${PN}-5.15.2-python311-fixups.patch
-)
-
-# Ensure the path returned by get_llvm_prefix() contains clang as well.
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-src_prepare() {
- # TODO: File upstream issue requesting a sane way to disable NumPy support.
- if ! use numpy; then
- sed -i -e '/\bprint(os\.path\.realpath(numpy))/d' \
- libshiboken/CMakeLists.txt || die
- fi
-
- # Shiboken2 assumes Vulkan headers live under either "$VULKAN_SDK/include"
- # or "$VK_SDK_PATH/include" rather than "${EPREFIX}/usr/include/vulkan".
- if use vulkan; then
- sed -i -e "s~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral(\"${EPREFIX}/usr/include/vulkan\"), HeaderType::System});~" \
- ApiExtractor/clangparser/compilersupport.cpp || die
- fi
-
- # Shiboken2 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
- # subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
- # currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
- # the largest version specifier that exists under the "/usr/lib/clang/"
- # subdirectory. This assumption is false in edge cases, including when
- # users downgrade from newer Clang versions but fail to remove those
- # versions with "emerge --depclean". See also:
- # https://github.com/leycec/raiagent/issues/85
- #
- # Sadly, the clang-* family of functions exported by the "toolchain-funcs"
- # eclass are defective, returning nonsensical placeholder strings if the
- # end user has *NOT* explicitly configured their C++ compiler to be Clang.
- # PySide2 does *NOT* care whether the end user has done so or not, as
- # PySide2 unconditionally requires Clang in either case. See also:
- # https://bugs.gentoo.org/619490
- sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
- ApiExtractor/clangparser/compilersupport.cpp || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Minimal tests for now, 2 failing with the extended version
- # FIXME Subscripted generics cannot be used with class and instance checks
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- -DDISABLE_DOCSTRINGS=$(usex !docstrings)
- )
-
- shiboken2_configure() {
- local mycmakeargs=(
- "${mycmakeargs[@]}"
- -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DUSE_PYTHON_VERSION="${EPYTHON#python}"
- )
- # CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
- local -x LLVM_INSTALL_DIR="$(get_llvm_prefix)"
- cmake_src_configure
- }
- python_foreach_impl shiboken2_configure
-}
-
-src_compile() {
- python_foreach_impl cmake_src_compile
-}
-
-src_test() {
- python_foreach_impl cmake_src_test
-}
-
-src_install() {
- shiboken2_install() {
- cmake_src_install
- python_optimize
-
- # Uniquify the "shiboken2" executable for the current Python target,
- # preserving an unversioned "shiboken2" file arbitrarily associated
- # with the last Python target.
- cp "${ED}"/usr/bin/${PN}{,-${EPYTHON}} || die
-
- # Uniquify the Shiboken2 pkgconfig file for the current Python target,
- # preserving an unversioned "shiboken2.pc" file arbitrarily associated
- # with the last Python target. See also:
- # https://github.com/leycec/raiagent/issues/73
- cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
- }
- python_foreach_impl shiboken2_install
-
- # CMakeLists.txt installs a "Shiboken2Targets-gentoo.cmake" file forcing
- # downstream consumers (e.g., PySide2) to target one "libshiboken2-*.so"
- # library and one "shiboken2" executable linked to one Python interpreter.
- # See also:
- # https://bugreports.qt.io/browse/PYSIDE-1053
- # https://github.com/leycec/raiagent/issues/74
- sed -i \
- -e 's~shiboken2-python[[:digit:]]\+\.[[:digit:]]\+~shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
- -e 's~/bin/shiboken2~/bin/shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
- "${ED}/usr/$(get_libdir)"/cmake/Shiboken2-${PV}/Shiboken2Targets-${CMAKE_BUILD_TYPE,,}.cmake || die
-
- # Remove the broken "shiboken_tool.py" script. By inspection, this script
- # reduces to a noop. Moreover, this script raises the following exception:
- # FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/../shiboken_tool.py': '/usr/bin/../shiboken_tool.py'
- rm "${ED}"/usr/bin/shiboken_tool.py || die
-}