summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269040 -> 269041 bytes
-rw-r--r--dev-python/google-auth-oauthlib/Manifest3
-rw-r--r--dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch25
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild (renamed from dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild)7
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild48
-rw-r--r--dev-python/pythran/Manifest2
-rw-r--r--dev-python/pythran/pythran-0.15.0.ebuild72
8 files changed, 107 insertions, 52 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 0e96891a3091..380792e350b9 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index a8983c6b8e65..6fc3e956c968 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,4 @@
+AUX google-auth-oauthlib-1.2.0-setup-exclude.patch 863 BLAKE2B 9ac621f5693a52627bdcda558a6b260ddb4c48f98d518f69285923ddbf74179a55fe825e984363d69f5d561b6fe886721f442b7b1a1defa92330e83efc9257cc SHA512 f5f1c138c94855f2a93ac61e5379d8dea971db6d245b99daab4325a2c8604123c2a8895d46f5f31618143f5920cf2ca175955ec6249287470b787f46cad31bbb
DIST google-auth-library-python-oauthlib-1.2.0.gh.tar.gz 72990 BLAKE2B 28b828a2a6b4de9deda8eef08f6780cd6f8d3a4df2f63d31c76b72afca12233d79edae46300d773301f7e9d6374e9dbcb5a89b59049a5c01ea5a84ac92285b82 SHA512 2f77d35f76ec12bfdc72dafe9cb33d23c2713985140930766a75377231dc94c32ffa84161251b23244dcf76fe71384421a5d6d8ae11a84b3876d35b5ba393f5a
-EBUILD google-auth-oauthlib-1.2.0.ebuild 885 BLAKE2B ce605b4ae5936cdfe7f178c1d54e0b595592fdf47c4fb46eb710c3e6c400fce3a2c39edadb2258314b24061001f2e5f2e7ee56e9c0c3d50ff655903c383bf88d SHA512 a1174f6d676071a198cc6b108fb4bd91923baba044a754b77853d776a091c3917bd06afd59c3d3337f805acd2bd6bd6c52396547f8b39915c67c5b195daec7d9
+EBUILD google-auth-oauthlib-1.2.0-r1.ebuild 1016 BLAKE2B 3f775e49f6605b3437456cfe3f8b412f278dde391759e7e9ef848979dc0b5e82812897117687a8755a813a33aee24f73eca1e87349c1a4d985d4cb7b3af5e0aa SHA512 d8c1906e90b2994352b260a6602c68ab32000970a75ec8e83b253610d41e3b9cadfa9b3010cd8880f4005b561a5ff8f4b1ab583da6ae5a9f644d1bb93f53222e
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
new file mode 100644
index 000000000000..61349d1cce43
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
@@ -0,0 +1,25 @@
+From dffa74bf7cb25d4e7759b4d0cded68eabfaaf33b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 8 Jan 2024 15:58:00 +0100
+Subject: [PATCH] fix: do not include docs/conf.py & scripts in wheel
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index ea9796a..430db0c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -37,7 +37,7 @@ setup(
+ description="Google Authentication Library",
+ long_description=long_description,
+ url="https://github.com/GoogleCloudPlatform/google-auth-library-python-oauthlib",
+- packages=find_namespace_packages(exclude=("tests*",)),
++ packages=find_namespace_packages(exclude=("docs*", "scripts*", "tests*",)),
+ install_requires=DEPENDENCIES,
+ extras_require={"tool": TOOL_DEPENDENCIES},
+ entry_points={
+--
+2.43.0
+
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
index 395c2d95e16a..04dbde55c9ab 100644
--- a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -37,3 +37,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/googleapis/google-auth-library-python-oauthlib/pull/328
+ "${FILESDIR}/${P}-setup-exclude.patch"
+)
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 5efdb2653b76..095e0f9dff4f 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-7.0.0.gh.tar.gz 80196 BLAKE2B cb34f5439959e93ccb68c566e284d1789a183dd85c1c3088d0c929373e88bd994de2ac159ea942119183976e64903cf7ca8f2b2137aad749f8b67728c541ee89 SHA512 0f95334a56ff7ccc774e5b94b91d232b829fb308a21ce975c88720493abbefa9e76fcd35cc2ca9bbbf0fd2e38b6f20f5be6cf59368aab4cf70abdaf24c7fd5ed
DIST pytest-bdd-7.0.1.gh.tar.gz 80315 BLAKE2B 7838a71fc6f0e7a86337d3b4d4fb9e0e7a3a0149c4271ecd75b5c9b40a28ad6bf3d6ccbc90d4a49a5472ae158f7710d98f91be340e67995ba47ea729584d16e5 SHA512 60d9713485a4719c6589e6641b45045e79c063278359c14ccbd016a6b0a8c8eebbf93e61d59e037988247c0116023910aa5e6776896b64dc96dcc23d0dbf6e3b
-EBUILD pytest-bdd-7.0.0.ebuild 1111 BLAKE2B f43979c6d9965cb62c3f9ca0ebb458c39a5ebede55e4cde4d6bc6e851645266ce65f1701eb1bec8c9bd2bdbf63928d34b011f100adb392da4de767f4bc1cfc6c SHA512 a770fd47d7a0da66271cf3838edf9e960901b460fb6d40ccd1d0312fa53efd646af010eb60202792fcd7fcb8d77cf8a0175bc506c6f7b58ec688a6b855ff4b99
EBUILD pytest-bdd-7.0.1.ebuild 1111 BLAKE2B f43979c6d9965cb62c3f9ca0ebb458c39a5ebede55e4cde4d6bc6e851645266ce65f1701eb1bec8c9bd2bdbf63928d34b011f100adb392da4de767f4bc1cfc6c SHA512 a770fd47d7a0da66271cf3838edf9e960901b460fb6d40ccd1d0312fa53efd646af010eb60202792fcd7fcb8d77cf8a0175bc506c6f7b58ec688a6b855ff4b99
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild
deleted file mode 100644
index bc6223fab65a..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 6ca5cc25ee3c..ce5cf4fd97ce 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1,5 +1,7 @@
DIST pythran-0.13.1.gh.tar.gz 3639196 BLAKE2B 8aba73c68542d69dd2287d7081226161ecade9e49fe6ea69d034f9116becbc148614212cbcff0056291809d2994caf43ee374393939e44635c6bed69220b29b8 SHA512 2497fa49d78ff64e577816f4b48bd424c03f04b7605c92d359f0f8514aaa67b30b7e68248db475c215deafaf7e55f7b4b74ab37c9dbef2a27e813878bf350e77
DIST pythran-0.14.0.gh.tar.gz 3642431 BLAKE2B cd5eeca0c52b0c3d17862b38c176b435a63a1f399e66979b8ac2682625cd0b0e074265e79bfdb6e57db989633954266132752e9b50c601ff43ae5c17c3e34bf5 SHA512 2a485c00b015abafc9ded28bfea8d8a7ae3ce87b5b654c318d5514fe12fd9374b599c05e3c4a2ff911fbae84df2efaa3cec2019c91e82ac1f36e0cc5ddeb2d8e
+DIST pythran-0.15.0.gh.tar.gz 3676474 BLAKE2B 2b9c08d773f7848cf43c804ffa9a84eb19d20dbc40668657daea9698fb468e62ec86226f39aa3b8ff07b48a3120604b44a9d6a6c9e7f2b5f0f41ba2e9a201231 SHA512 2abba0ab5328e60d622512aa6c5442fcc28edb4da4209db50ede64961b58c91c2109b7bb90e5872c5c0d487542f669dc2ca3e721c28229e283f6e0130f95aee0
EBUILD pythran-0.13.1.ebuild 1710 BLAKE2B 8c6bafdd9cf45c2952e5f4ca7b5d6d1362350dbdefa46d4c8ac1dacbe3ace1c6890b27c741250765690a15cd90f639fc9bbb3ef7047d963f40be091f403a5795 SHA512 4e404e3068c6d57cf6c5e7167eb6402e41d2fac8ac5429ff03a260bafc99dafe406635f8bfad9210f1a9ceb1aacccf17e2f06ebb18f2be77ac01c743b6080c4e
EBUILD pythran-0.14.0.ebuild 2087 BLAKE2B 6c477a732d93f18084d131cc20076d60733d5ce609ac0dd46a274da01546ef6045e1a89e2ccb092d72e1d2cb5a1a195a2cca99c4bbf432098219da3bb93329b1 SHA512 7075a10ea5c65ee9e3b9d932a40bba7a0ea74e6c870216c4dd459a0e6666fd9f3184a00a02a0a579f31725e36de2b92c5e4b21ca12b8f28d9cfd378189132db5
+EBUILD pythran-0.15.0.ebuild 1554 BLAKE2B e700d37523964c86d395a96d91c568b7bceca7ca780eafe9998346f1ee871e4f78dd849e21c74bca3f62c729015d30d2caa7de65290c88c42e01811435899864 SHA512 a3f3d7acbfd7fb209109a6b9704ac841fb4542b85bddde895c77fba4b15d4f9e2902ea0c5c5e05edbe249fe347a773d80383b3e82aad33586a0ef502d6ff2f4f
MISC metadata.xml 354 BLAKE2B e7ec71fae294f6f697b0fd99b0ccef24049af7999866344e8da2ebc40bc2988a21f2cb0374b52b781a5f8b55f26ebca364dc93f4e69d957a3ff6bd3c32cd988d SHA512 9008d270ea6757557482edb55c5848aea9a29abfbbad65d93000660a1e51ad2456a2b7ccfcacb80da23b3dd38cee2c4da9645aed48a35edb4a497bbe3a80dd7f
diff --git a/dev-python/pythran/pythran-0.15.0.ebuild b/dev-python/pythran/pythran-0.15.0.ebuild
new file mode 100644
index 000000000000..fcab910cab02
--- /dev/null
+++ b/dev-python/pythran/pythran-0.15.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/
+"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/boost
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-libs/boost
+ dev-cpp/xsimd
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ !!dev-python/setuptools-declarative-requirements
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_configure() {
+ # sigh
+ rm -r pythran/{boost,xsimd} || die
+
+ if use test ; then
+ sed -i \
+ -e 's|blas=blas|blas=cblas|' \
+ -e 's|libs=|libs=cblas|' \
+ pythran/pythran-*.cfg || die
+ fi
+}
+
+python_test() {
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}