summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260825 -> 260812 bytes
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild36
-rw-r--r--dev-python/nbsphinx/Manifest2
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.9.0.ebuild28
-rw-r--r--dev-python/pyproject-api/Manifest2
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.1.ebuild41
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild45
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-4.4.7.ebuild90
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.21.0.ebuild102
13 files changed, 354 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 5e7d2ab0ff60..d192e4da82aa 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index d265b783b5b7..ceaa47e3ed1a 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,5 @@
DIST exceptiongroup-1.1.0.gh.tar.gz 22724 BLAKE2B 2de748494fe1356353b7f70d3afc7be7ecb8df4166f57461459c7f463bc5c22340c9073b0b0e032a52680560e37e4004c754fb4ddcc1a5a70f8dd0e973b1d8a9 SHA512 588b4ec3cae01a64140aac191cbdf8d0631eb614d430bbdbd02d17d8ff43aad9d233c3545694c6fffb622a2b3c38a289e20f1b8db6bf0e9b8819d668e38a87e3
+DIST exceptiongroup-1.1.1.gh.tar.gz 23107 BLAKE2B d68778e4a4d14add65ee2300fd15308c17b2cae1733bf4e8938e88b5cf76b9f19d8f9c102c06298769ff9541ded02868763d9c4aac776d22f78c250ea2d942ce SHA512 eb072fef6160cc6d332ae6e08ee7a34ce478188d143f97daae3f8251a8253a7b460249a121af27d66953ff8000ea5ef43a6dee145b14ba7b2968790132a766bf
EBUILD exceptiongroup-1.1.0.ebuild 774 BLAKE2B 019d538b5f362ad08c5238307b73e34cc93462c5d93a6144ef1b57531981be679b141517db504efa3d33ea617146cf981369473d2812e5867e79fd92d7f21ae5 SHA512 005f29aefc604aba23037b06737135bc8f3193f305eff7ab363b9e10e7c2fe6bb2b95f22fa29b3726bc3e29aa0ae6c898a6f3f3f0a0467516c1af30e503ce8ee
+EBUILD exceptiongroup-1.1.1.ebuild 884 BLAKE2B 61a4aa61bd45474809f18a9954dc7fbc121a1fb6754cfd217b80bde94fcf9ec75ff993e7342ddfe22b16df7dda9d2a77cb43a4039e7e7c04c4b02d1d4f0adadc SHA512 2ce5a6f151f30087f08b45edb61063fdee84a0af2a04625bcb2271c290868520792e44cffea44389107970630a6c3e78146c43999e42107f249844c72bb7e9a7
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
new file mode 100644
index 000000000000..3091487c0fe0
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index ac4ff401999c..cf5c6d1147a0 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1,3 +1,5 @@
DIST nbsphinx-0.8.12.tar.gz 178986 BLAKE2B 5f79e20be5ceb3c9458530c19f453599cff8c278d5ad56faec952cc191336469cee3ecc130bbca8cae5d14447abf544a6b127251f3ee2a26e63c94a1326b707c SHA512 fd18cde3b7034bbd0f0f5ec7addd8925e867dbe0cfe810310240e5748014f2cc6bf275ff24d070d0c8748e7d144bf3dc2e9a26ede3a50e880f3db27d1a0d0575
+DIST nbsphinx-0.9.0.tar.gz 171588 BLAKE2B e5273c9fa04b05335703a1a9c80b77c1d282aa7515379b5c3faa3f561996441a78202b8671b114fc858e064716bb167b6e19e5184167eea2fcac0c44c31c8f04 SHA512 a6a2a15190edb04ec1c953b8c9ad43c289c42896627d7eaeeb8711593ef33e164c1a6083009a91d663e5a2a150a3471e554117dee94c01d91742b8516a324759
EBUILD nbsphinx-0.8.12.ebuild 707 BLAKE2B 6f0375f513da4974df0f281a2dc29c2d55fbb28bcaac2fd53408c15c6d39a79f3293aab2789a5925b415dd0c5c8af50f9a91b421f49ce92d56ccb5b60f67391e SHA512 8b2db9a47d7c62b09850ea30e4aa5b350b4de98f15aff15a39674ad80f00fd154e9dbb9c4f9d6a17307dc21b5f333e01053e45d0a0ead8c713870dc3a0a22460
+EBUILD nbsphinx-0.9.0.ebuild 662 BLAKE2B e4a6df09f2083f80445ccb516377379e7a2c0731200c1dc4fccbec9d25daa87da9c3de4116673dee92c369cf4a67e21f35c63fedde52408be20948f3e17b6fd3 SHA512 9cdb0d894598bc54949e21ef4bf35c2c07ee9722e0d585c1acb1077917c8bac15d450a25aeff9050f16b8e97c18ecad474d3c548117d328ed521878dec7ef0c3
MISC metadata.xml 835 BLAKE2B a3a10c9fb26688d90ad6f4e2ddb8b174eae9fdc2637d4aabdb86f63093982c7c9a42c4eaa3b2adee6ddb12ba2d537aec79d324c0a3c7355424a4255cea90eda6 SHA512 9ac5cebe164b19f80e0eb07f7c4fb5cb2cf5251af1f81290931f8fd01223261cb6224500387c131c7bc8738d7bb07eb790fd9ea426a295d0688489510e58d55c
diff --git a/dev-python/nbsphinx/nbsphinx-0.9.0.ebuild b/dev-python/nbsphinx/nbsphinx-0.9.0.ebuild
new file mode 100644
index 000000000000..a8ca5203141c
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index 96b9fe911322..ed5906dadbbf 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1,3 +1,5 @@
DIST pyproject-api-1.5.0.gh.tar.gz 22032 BLAKE2B 7e90bacffee70d2a2343f2360f5d0e6794a04a8b8b9be672150e5ac49e1dfabb0673b4c661ddc27f3fffa7bb3d04644e2b1809555987fc0d914a798fac667c8c SHA512 7a68df007e52c685f512fca26d371d1790f2fb9ced381025fe27462088cd4f1488b7edf4de94f6c1df989c4430336789b94d0b3bd634a2f6ec52f14f292b4474
+DIST pyproject_api-1.5.1.tar.gz 22081 BLAKE2B 53ee778b4e04cac2f16ecd054adc7fd86373d6402f80d485fe22457252684f774b6a5df23d08cf6c6b1f96964d6dc1b1cc9014415f3d9105ffbb09421f69a11e SHA512 31936d242861027ea892e86219f430371aae18631c92893cefc8fb8fc02315906857ee57e5412eed62bf584e0bd24cca7ba82471c0ac6a72c71e8e93b8285a3e
EBUILD pyproject-api-1.5.0.ebuild 1114 BLAKE2B d4337b00092e130acb7cc9a62e21c5a88ad9297706692f5fac64e5eccc97aeb9f55c90e65d402ff905b7faec26ebd816dc98c50a13405475e9dc8108339f9f54 SHA512 fb91c43e333fe1ba42efa7e1dc7671f20730eff3db3a71efa276cc36f4c3dada8df151a1ec42fed78f10c2fa41989289e94e0b4573f31883baac1648173760e6
+EBUILD pyproject-api-1.5.1.ebuild 986 BLAKE2B 53fe914909d6d4d7cb58304531e9860a8e4cd08049f835bd732a0e88fd6ff508f34b0f3b3b88304ceeb4d69b39b9411c75032b3891ad4f4ceebb023f234f7952 SHA512 8b76dd4df08121adeaf7f149f95d71317f6e5ea3176fa7cba906a647555e78c5a2f45d29888c599c38964e4a9565e896430c2158790f4eb220aa3e88f2fb2b05
MISC metadata.xml 378 BLAKE2B f7bb92a50d3be540f9ef686045a6950a6bd26679df183dcce4af9ddd4f203090023309ad4e5e43a9f769ed40ef6269f64fb628ed0acfef9fe9fc36b9f67704b7 SHA512 f3840464571b9893548e778d5eef88c64b614ec8994b1ff1348aed1795cce740b2a32b46df1e654e0a9072e8e059214ca1487421fb1316b4160a1bff4202d475
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
new file mode 100644
index 000000000000..a161dd7f0dd8
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Python 2 installed
+ tests/test_frontend.py::test_can_build_on_python_2
+)
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 95d456b92e61..12128354553a 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,5 +1,7 @@
DIST pytest-xdist-3.1.0.tar.gz 71977 BLAKE2B c29622377743aec0a90f0e92af866a63106b9c37abee379222fd2b5c40f0607c33010bb5d2cb5212fc90a438d787ecb435f07c31e0db7a10599696c33b309a32 SHA512 884cdd85754b36338666cbdd71575ef18465730cfc4ab7333b93aa46823c1dc33e8055117241f4c87e1b8c82492881cc0f91ef1bb2ddc164aa00bfa1e5e2d245
DIST pytest-xdist-3.2.0.tar.gz 76199 BLAKE2B 462d6af54ba599f506a51ae2e91ab0c08fdb8a6b3e47ba4541c0fe2c19a9aa8a38dee0621e130d23a2daecdc9509b1020eb05d550a50d6de233e185a8108872c SHA512 dd22c2e525681ddabc1df75e8eadcf0d3c52936cefafb7308771e37cfe9023cb4ecbbaf4e437668666f5319e379e7b6c5c7665912b59c5d10890c32da7546433
+DIST pytest-xdist-3.2.1.tar.gz 76362 BLAKE2B a5cea5bab1176554bd0d1ebfff5400f60bd43964ae13c7f77ad77fc257db32ba0a0d6f2f3ec16211e48852a6bfd02a0949d618c7f2f6a8da11dd2843d88565a4 SHA512 ea42bea8b4df3d77ef680cba81f76f9f79d0ffcaad6f5f879cc82c53203d36ffe26f233dd6c5d1cbea22b43d257f0f4e6be793116bb281956316c44fc412f9b7
EBUILD pytest-xdist-3.1.0.ebuild 1123 BLAKE2B 7b511dc74ad8af94061a987c7b890c9804a2a962394138679f674be6213922d3a5f31be4230f4dbc1c617f8b8b1538e1edb30fbd2b57a21ce7ff12b77cc16974 SHA512 8a7129d190b1cfa8447f1c9e5fce9536d87385e75828333e00330a698eea98f22f96424268f96a9eddbe3d8e5aadfeb03f7f1de2782a271f607c4d1eee849c95
EBUILD pytest-xdist-3.2.0.ebuild 1104 BLAKE2B 18604032d8eeb812e4a005794eaeed43a3ac6433df75f877cae01929306eeed51abb17f55dbfa079c759f34463cbcbcb43fb0851328e1c24136594c314d0aa8e SHA512 22094bc669a552acd1677e16e398db1d64bb57f6b82a826b3ddff86edeaeebdd9de53ec787baeaf8d1125d676e53c4d98fc6b5c083b3e327aa41171a5738dc62
+EBUILD pytest-xdist-3.2.1.ebuild 1104 BLAKE2B 18604032d8eeb812e4a005794eaeed43a3ac6433df75f877cae01929306eeed51abb17f55dbfa079c759f34463cbcbcb43fb0851328e1c24136594c314d0aa8e SHA512 22094bc669a552acd1677e16e398db1d64bb57f6b82a826b3ddff86edeaeebdd9de53ec787baeaf8d1125d676e53c4d98fc6b5c083b3e327aa41171a5738dc62
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild
new file mode 100644
index 000000000000..c3bc7d37a95e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index c562ca606742..9f3761b0c2d8 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,5 +1,7 @@
DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3e67825672d0efc74c1b1468bc8b8d9c14b6177c181750ba4b9a5e77d616068dd83e21f5641acfc8e2a271cc1f SHA512 64816754e6800661bb564c5c7d21c4139522d540a04fafe3c4591d596072d48d1cbe0ee2abee9c8faf3d5007774f5371431b5a7a8f49912bc879c7b168aab2ca
DIST tox-4.4.6.gh.tar.gz 304337 BLAKE2B 2c157fe5febf1eb131d767ade87484880201bb37fa65a579abb9780d755d570f216b8f865dd2dd8dbb3a3af01be78133f9ac0b73a3166dfc2b9cd99f6547498a SHA512 403bca89228d665182bfbb61550dfd9e9fb4ce4a5592472d50cd38e3f264c806fa15bbdccc020a720ad69885d9be54a1f074f6d87549cbe2b523e53d870358dc
+DIST tox-4.4.7.tar.gz 168261 BLAKE2B 276842bb82d01c9e3b66f633e79974790b7d1852f831ab954172ddc1d3c50c861a39e959fb0a990a7102a1cc0840238ef3ac84c7b41f9f45ce502b1245e21988 SHA512 58989ecc0a555ee225614d9b7a718b22f6dd1555a0209a0c1428259fbfc7d336a58753fbfa85f1b9aa160c8489587999425437e71f9d4728631d5cd5b50ca159
EBUILD tox-3.28.0.ebuild 1916 BLAKE2B ff8aa55245a3f654897ad4c8f5861a55410b2b9442bf3f85aaa0ee236f576efcea1a2ed697c715c7182679b62a4781c5a0f6236eb92a1b12d6ddc73154612a67 SHA512 2f5999d0263da9efb00216600f8b98fb3c204e11640049d92c6106279baeff452468d2bb78236839bc8bd5540d6f9d01338af26315148d81a788d476ec5dbed5
EBUILD tox-4.4.6.ebuild 3029 BLAKE2B 3a3dd193f9eaed38066e520aecda87b81745ec4a175b9a6f6e65a701c85db0c46d2b9c8c3d5b9cac29ef1cf91d21f313d79e673b1e31587e502d7886960e398d SHA512 2ff026c0923e832e3af257fcffbdb5b7722a50d010205723983a6f866b36f63e5665b4466f7cceeb6b04db8bbc99b3e585bd94094b6a7afca2a079a9ce0c3c47
+EBUILD tox-4.4.7.ebuild 3009 BLAKE2B c9f8e6c1cd6260a8a6cefc8045bfb24910e893fd1dad27f30ce52242f24f6528b428f812d47ce75359d32265e29ad7372ec7462fbf506089769899df2bd7a96f SHA512 d8df48dd80e192e69a9f8d9d7b9ff8f19e3efde8acf531eb697e48e81603e765919199d0ac6c812ccbaf72e02649c88830cc2cc6e0c98119d1bb1d52647bce34
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-4.4.7.ebuild b/dev-python/tox/tox-4.4.7.ebuild
new file mode 100644
index 000000000000..2248781df596
--- /dev/null
+++ b/dev-python/tox/tox-4.4.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.10[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # the minimal bounds in tox are entirely meaningless and new packaging
+ # breaks setuptools
+ sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
+ # workaround https://github.com/agronholm/exceptiongroup/pull/59
+ [[ -f tox.ini ]] && die "Remove the hack, please"
+ > tox.ini || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ epytest
+}
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 73b108261e3e..92cc9216a4f2 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -2,8 +2,10 @@ DIST virtualenv-20.17.1.tar.gz 12269737 BLAKE2B 5caa223d549ecb69de3a17dec84a608f
DIST virtualenv-20.18.0.tar.gz 12063086 BLAKE2B 272957077dd0a5868e8979c7c34bda1ae28af857d1d5bbafeef6955bcf44a7c5d38f4f131b57a2593180ffdc5a034b18998ba3e4307b7191ebafccc80ef46278 SHA512 b02533878b8d8859f10b51dbdb9fecddf9b49aa2cf1437ddc10cadba82e5361fdeb8b8c94efcc3c8268ddecef31651c28c213e87588aa917479e8d0e2e823493
DIST virtualenv-20.19.0.tar.gz 12063084 BLAKE2B 6a6d94c7099aa841523909173b04821697c7fc8b284325dbf191f6b2184bce19802924e0a001267448a785c35f8bbd7cee74f7514a375e4e47a9d3275404f756 SHA512 75c63fea11ad070985cb2ba17adfcb7e1739e8798b80919cc17a527d7180f68a04197436b44146cd07423d8d2e4982d1716b0e18159add5ce6a748b31f6b2776
DIST virtualenv-20.20.0.tar.gz 12069625 BLAKE2B 3db53d2859c542953be233af0d195d992eecef345700ad7c229b88519f7042189907263d312d3613b45c5c069bec2440a8639bcc58b2c6894ed79301735e65b2 SHA512 6710efcbead1358479961c84ec3f6b9c3a1fc59c2f6b33fa13e2609554f7072aee7ef8cc07b4aa2fbc27ac950a78e447529fb8ceb2e4ee0881a4356a67d26641
+DIST virtualenv-20.21.0.tar.gz 12070063 BLAKE2B f69d5934191ccd8e9420c37e51b53df7876961d6f13d0f75845530893fd91df29a512e64eaa27135535816250a3149087029e6fe1b15317b8079af9cee2832ea SHA512 77aae5ebc5007093953c30da1eed996e851a65c7dd1f7a3a85961a1bb251b3d7970936eea1efe8babb216d2024072bdbf1c1a97ba8760a04a0abf6e7c3a27d09
EBUILD virtualenv-20.17.1.ebuild 4921 BLAKE2B 0a9fecb5aa534e8dc12e1bac8b6b9fe7cbe10ca06406c7e2c1cc0ca8e0b5d464954829b0c7fef275370a31ae0c9dd7e8f9257d2b311d5d8238689c81c7999970 SHA512 68c7673a1e9843be546199feab56e112e37b09f601d6e07490a470eb4e1ccc34248c1901895c81ad749d8d1023a9c8377cc47615dbf131eb44865083a9beab66
EBUILD virtualenv-20.18.0.ebuild 5012 BLAKE2B 9254d23d00755994534a17315ac32795634bc2f29a65cca17c59ce5c9f9d3bb3bbfaca59afdce96daea7bb773640135827d5a78caceefe5a60dce13e13bc7a6b SHA512 95bafcdf488a146aea8d3aea945466ede8f7e98c364c43973dda5130560dc9f927751b742ef4ea37a8e4129a907bcc86b49485a64a7e2b8c06d9a45bdfbe5e5c
EBUILD virtualenv-20.19.0.ebuild 4956 BLAKE2B 519d903e8449c44867db84ad230e14bc90317f6088ec65a5f5aeb82c069e3b597582c22b26cfc27f04eb0894a8b154e3ac0d0f32203f8ed5754e4eed7e59dc4b SHA512 bac83db65b2f129cdc1b3dfae131a79b4f1c7d5435d07baf11fe4714c186034b944546654b70ad58e6c295d2c0146daa210e33e8d067910d37e53739b8753933
EBUILD virtualenv-20.20.0.ebuild 4769 BLAKE2B b2641b3d910b24c0d5b52ef5a3a4d79b8b7256b2a86cb17994d6ce64f79a4c14103f75ae76d8f4f1426defa853ca884c5da1983685bf2e22cca553408a54e472 SHA512 49ee545c8b6898126d138665f88b3018ebdb6c7f2580b7e8be13626103680f051a61017038f53429f0caf7913265e0092076619c50fd5b12bb593a8e36ab7e9a
+EBUILD virtualenv-20.21.0.ebuild 4769 BLAKE2B b2641b3d910b24c0d5b52ef5a3a4d79b8b7256b2a86cb17994d6ce64f79a4c14103f75ae76d8f4f1426defa853ca884c5da1983685bf2e22cca553408a54e472 SHA512 49ee545c8b6898126d138665f88b3018ebdb6c7f2580b7e8be13626103680f051a61017038f53429f0caf7913265e0092076619c50fd5b12bb593a8e36ab7e9a
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.21.0.ebuild b/dev-python/virtualenv/virtualenv-20.21.0.ebuild
new file mode 100644
index 000000000000..d32afc1e8df6
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.21.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/distlib-1[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ <dev-python/filelock-4[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.1[${PYTHON_USEDEP}]
+ <dev-python/platformdirs-4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.4[${PYTHON_USEDEP}]
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+
+# (unpackaged deps)
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-argparse \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/activation/test_xonsh.py
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ tests/unit/create/test_creator.py::test_cross_major
+ # tests failing without python2 installed
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
+ tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+
+ epytest
+}