summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269306 -> 269307 bytes
-rw-r--r--dev-python/ensurepip-pip/Manifest2
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-24.0.ebuild24
-rw-r--r--dev-python/mysqlclient/Manifest2
-rw-r--r--dev-python/mysqlclient/mysqlclient-2.2.3.ebuild93
-rw-r--r--dev-python/pip/Manifest2
-rw-r--r--dev-python/pip/pip-24.0.ebuild136
-rw-r--r--dev-python/twisted/Manifest2
-rw-r--r--dev-python/twisted/metadata.xml1
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/metadata.xml3
11 files changed, 261 insertions, 6 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 2baf68128d57..724431b1a874 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
index fd6ad488a839..9315cf144eaf 100644
--- a/dev-python/ensurepip-pip/Manifest
+++ b/dev-python/ensurepip-pip/Manifest
@@ -1,3 +1,5 @@
DIST pip-23.3.2-py3-none-any.whl 2109393 BLAKE2B 278b9941f93951508ae2f508b1b5a9fddd4ca11fac1d5b0c2ac994f8e8457226a4e8c4501078776476e0bae56fd82b989ebaf4f5f484ffe7b0ee79789e34aca8 SHA512 a1449fe400787f73ac26cb48acaae71208a2e696f9ce4992b44e11da29646b018c2f6c27a95b12e42531236fe658e0605e20d5dfa740c43e005c01da3db802da
+DIST pip-24.0-py3-none-any.whl 2110226 BLAKE2B 6a0c8c9796cd574ef1d709de40a8530a15e50158143e332b79e5ad3edceda6ce93c5ef4df49b169062598618dcc6967c2115ac2c10b05abf345318204f1eeffc SHA512 5d7462a584105bccaa9cf376f5a8c5827ead099c813c8af7392d478a4398f373d9e8cac7bbad2db51b335411ab966b21e119b1b1234c9a7ab70c6ddfc9306da6
EBUILD ensurepip-pip-23.3.2.ebuild 645 BLAKE2B d761664589da3ba0fb44ca1b2561916feb7a8b9b29478eff1f5fd2b0eaef46e1543f5bb9d11b56d8eb6a9a01a3bbbe0b51020e9adc6fd0a0149a9e249b4cf87a SHA512 84d9e6a945940cd614b9a458555f55e5fefafdb746587a33161359e4cf72813bb23885069745196fc6476b0331c7c5e1280f5979f985790dedb71bab2139f9d7
+EBUILD ensurepip-pip-24.0.ebuild 653 BLAKE2B 480b6e624b9f00f1863dba43ff47a53d454b570b2715301c560e66380b658129a5bd630a40746aca173f4813b4227eac96f1076c3fc6e5fdcad8aacd6bc39f86 SHA512 168c500efb22504acbae0923000e822a4ae5bcf10157b60088649e952838017050e452b784d97f774b3e7c739d5c8a30c23593f8e8519500878af069b6ffd7b7
MISC metadata.xml 309 BLAKE2B 197e5620aab85ff590270ae6838c9188cd699943af4c9c3eeb7de92c2e9390c082eec603e63bc2bba39477586f19e58da2e5fe2d5ffe9b59b87ae5386c939df1 SHA512 c678bc8fb62f6e6850939ebff56962503bb03393572cfff7e5f7d38e8cf5ca71d8e38e402355c5f963fb718eed24bca463d7c63fede5cbb550f6f32a9c06af9e
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-24.0.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-24.0.ebuild
new file mode 100644
index 000000000000..85e9351f85b0
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-24.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}
diff --git a/dev-python/mysqlclient/Manifest b/dev-python/mysqlclient/Manifest
index d7b22d0a98e7..f143c8921495 100644
--- a/dev-python/mysqlclient/Manifest
+++ b/dev-python/mysqlclient/Manifest
@@ -1,3 +1,5 @@
DIST mysqlclient-2.2.1.tar.gz 89966 BLAKE2B b5098ea4afe8ba720c40eda2f0f5da043622bed51a123e225530d505edfef2f02efba477238d73f343a6cc4969bf021156e15528f05a12d905ea6231e47d65bd SHA512 3ff3823cef4662268387e5c13d006595219c5a3371201eb251d84db5eec028b32fd7b672dbdac9f4dffa906fddcfc9a5ee130e3b03e4dc0cfb060411ad75eea8
+DIST mysqlclient-2.2.3.tar.gz 90174 BLAKE2B 11626ac7cc93d70667cd105f77df5666f605fb16290f77ef485666e1f74b3aa47fdddaa2ea9f6b6196682f0c9772abe6c8557e01836362cc97ca6f0459716ae0 SHA512 72dd6fc351642adfa8148ff76da352233d83f8c11d8f8ad925b4a6e5d4c3dbe12e6a78d5cc1cd430b37d81d2a306c83bc5f262282f74a6c13e22cd09eeeeeaf3
EBUILD mysqlclient-2.2.1.ebuild 1912 BLAKE2B fefcb981eb79dc1eb4d308245e715e0d2edc4eb5e62a8c445f2f27744f35398ea9021d4e2c49e282665b7ca1062562461637208eb3861e48fa886a09f39e18b6 SHA512 bbbb3b3e1059a08c5ee70e5432f7989650042196f11a4549f6879c5e85e5f037357a441ddfe726d08ce79b7feea19d8a068b8a233680d38f9e129612665be2f3
+EBUILD mysqlclient-2.2.3.ebuild 1917 BLAKE2B 69b65dc2d2e8462f559caf68f19be538440eb2d72c26826e8dbe4add617b7c854e3c727de42606182a5c587b9bef3011ff375a76b41f920e95cb64940435a87e SHA512 bbdc7a1fe0f73fc44d96caa88a9929c6cccc5224cb88f545fc70f7949214797d88dbd99e0b39859f2b200dbe670811c15d48c0c79256052b59058940b88f0cb1
MISC metadata.xml 507 BLAKE2B 3c274117dde5aed93bb78488b1c106ea9b18243725d88867e6b568a09229d97bc35a1116d8a529c5c72cabcb9feb33de8157448cf3d339dbf1861d8a9ff2c1d6 SHA512 4304ae4addf93365b2acfd493a27a0144bfe0dd2d559a3fce73f52d0d1683c84b1597c9d11f36b332b6428523fd8082297ab39ce000d961ccdf39d92833828ac
diff --git a/dev-python/mysqlclient/mysqlclient-2.2.3.ebuild b/dev-python/mysqlclient/mysqlclient-2.2.3.ebuild
new file mode 100644
index 000000000000..ab4bb8e39c0e
--- /dev/null
+++ b/dev-python/mysqlclient/mysqlclient-2.2.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to MySQL"
+HOMEPAGE="
+ https://pypi.org/project/mysqlclient/
+ https://github.com/PyMySQL/mysqlclient/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-db/mysql-connector-c:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-db/mariadb[server]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ rm -r src || die
+
+ local datadir="${T}/mysql" \
+ install_log="${T}/mysqld_install.log" \
+ pidfile="${T}/mysqld.pid" \
+ socket="${T}/mysqld.sock" \
+ log="${T}/mysqld.log"
+ einfo "Creating test MySQL instance ..."
+ if ! mysql_install_db \
+ --no-defaults \
+ --auth-root-authentication-method=normal \
+ --basedir="${EPREFIX}/usr" \
+ --datadir="${datadir}" >& "${install_log}"
+ then
+ cat "${install_log}"
+ die "Failed to create database"
+ fi
+
+ einfo "Starting test MySQL instance ..."
+ mysqld \
+ --no-defaults \
+ --character-set-server=utf8 \
+ --pid-file="${pidfile}" \
+ --socket="${socket}" \
+ --skip-networking \
+ --datadir="${datadir}" >& "${log}" &
+
+ local i timeout=10
+ einfo "Waiting for MySQL to start for up to ${timeout} seconds ..."
+ for i in seq 1 ${timeout}; do
+ [[ -S "${socket}" ]] && break
+ sleep 1
+ done
+ if [[ ! -S "${socket}" ]]; then
+ cat "${log}"
+ die "MySQL failed to start in ${timeout} seconds"
+ fi
+
+ cat > "${T}/mysql.cnf" <<- EOF
+ [MySQLdb-tests]
+ socket = ${socket}
+ user = root
+ database = test
+ EOF
+
+ distutils-r1_src_test
+
+ einfo "Stopping test MySQL instance ..."
+ pkill -F "${pidfile}" &>/dev/null
+}
+
+python_test() {
+ local -x TESTDB="${T}/mysql.cnf"
+ epytest
+}
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 4dbfa06e57e3..cb3dc70daf1b 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -2,5 +2,7 @@ AUX pip-23.1-no-coverage.patch 1836 BLAKE2B f8c95ed26d5a7cba2a516b8d134ddd9901fd
AUX pip-23.3.1-no-color.patch 1767 BLAKE2B b81a4b814e2e84e7c0424870d1a86ba7fde91400bfad127c696112544b294623ba9d580f503f01a8399a569a9a5880d38d1d09c98b9364c9b59915adb3a9b453 SHA512 c89be77fbd8049a1e6fd12ef4227926ff641c1797f91bbe91b6152016a1e7dff5e323d8ff0961948225ef854d52de972f74c8e37f48e8aee78e529f9ec8b3b3f
AUX pip-23.3.2-setuptools-69.0.3.patch 15433 BLAKE2B 9240c660580d595a182e6082446b7275c7f7b918589f731215a30b326a962668710a4aaa57877ccbeb48912a76182df9b2eb44e0868cff41e83326bd30273263 SHA512 952c30c62517eb0e60c7798d5a18fb20fe91e92816b552772a9334ed6f55d53b08f68c29c9eed30f59ce8265ce01eba8b28ea1f94c329c912f61f7afbaa2bff7
DIST pip-23.3.2.gh.tar.gz 9397451 BLAKE2B 65e656cf3e7c3ab48b5cfa48f105cae158068f3daee497edfb93e34887afa134b2cfea73574947ca22ec2664dd814034166301fb0f70322ca92852a68052be40 SHA512 976c6ab9959805f4d20d4bdedb4dabc95dd55f1ec78773f63f738599bbe44e766ad3a1394bee052a2c2386826d67686ad456726373345ba9e0d555fd251dff09
+DIST pip-24.0.gh.tar.gz 9398156 BLAKE2B 17a7ed9e15e9b8efa0d3e3c5586dc446958b62cf9ba52155a0d1ad97a3e212ee7a08a0e88a592718fc3d542eb8f434155a75cb98d90c008904bd8f59bd2b40b6 SHA512 0c2ecb2ecde4f155c83468d35bc4f52f37efffc16821ae7c706d035e1e8cc3709b41cb10f8140ff09205e8bbdba2c76128ad76d1cbd18401328b619228e834df
EBUILD pip-23.3.2-r1.ebuild 4330 BLAKE2B 5cc4dfd26bb1df712b6099df54e9871c0b3e65c4ca57b2c864d1fb18821d0a69de4a53335cbbf8938f8cd5d4a587471bf1ac1d52276940e4189eb51ae18ba651 SHA512 6c75f4c7190ad43571250300782da6e1835f37841ba47d1510daf5e213670ff7e9c97f5377384d04603e2d44ccba1d29fc7c86269e6b353e2e3899614a493e68
+EBUILD pip-24.0.ebuild 4203 BLAKE2B bb84d8f0a94a87a7001ae5c5adb81ce6bf1ae95fa7d2d2627050b9e8d7cb67151e633a10f3832a6a0f6d5c6c1810b3a140f9820a6e61d23f9ae2068afe683441 SHA512 38eb925c55dfb942beeb7faf262a43d32d17c0ca5c730e9fe09086641dbeae75363f4137fc412f4f065e3fb5172def55024dfe33c8007647ddff1c3a98a9cd6e
MISC metadata.xml 392 BLAKE2B 94ea3de1220cb9ca64ae1186597789cc83a54adfe44695932c07dd5065df0e5f9ee5078a495e3a12563b36809d781d8ab86bb6c92c485c023199d92547b74f27 SHA512 603199f6547105f3bb64f4fcaf004e9ef62fa2e0f8ec6eab56078119684b0f5119161e0f164fe02b2cf6dd6b115588c9ef77d727eeb6d138e281f1cb0bcb5de9
diff --git a/dev-python/pip/pip-24.0.ebuild b/dev-python/pip/pip-24.0.ebuild
new file mode 100644
index 000000000000..b4f8836682f0
--- /dev/null
+++ b/dev-python/pip/pip-24.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# please bump dev-python/ensurepip-pip along with this package!
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="The PyPA recommended tool for installing Python packages"
+HOMEPAGE="
+ https://pip.pypa.io/en/stable/
+ https://pypi.org/project/pip/
+ https://github.com/pypa/pip/
+"
+SRC_URI="
+ https://github.com/pypa/pip/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+# bundled deps
+LICENSE+=" Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MPL-2.0 PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scripttest[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/pip-23.1-no-coverage.patch"
+ # https://github.com/pypa/pip/pull/12415
+ "${FILESDIR}/pip-23.3.1-no-color.patch"
+ )
+
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ local wheels=(
+ "${BROOT}"/usr/lib/python/ensurepip/{setuptools,wheel}-*.whl
+ )
+ mkdir tests/data/common_wheels/ || die
+ cp "${wheels[@]}" tests/data/common_wheels/ || die
+ fi
+}
+
+python_compile_all() {
+ # 'pip completion' command embeds full $0 into completion script, which confuses
+ # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
+ # This trick sets correct $0 while still calling just installed pip.
+ local pipcmd='import sys; sys.argv[0] = "pip"; __file__ = ""; from pip._internal.cli.main import main; sys.exit(main())'
+ "${EPYTHON}" -c "${pipcmd}" completion --bash > completion.bash || die
+ "${EPYTHON}" -c "${pipcmd}" completion --zsh > completion.zsh || die
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return 0
+ fi
+
+ local EPYTEST_DESELECT=(
+ tests/functional/test_inspect.py::test_inspect_basic
+ # Internet
+ tests/functional/test_config_settings.py::test_backend_sees_config_via_sdist
+ tests/functional/test_config_settings.py::test_config_settings_implies_pep517
+ tests/functional/test_install.py::test_double_install_fail
+ tests/functional/test_install.py::test_editable_install__local_dir_setup_requires_with_pyproject
+ tests/functional/test_install.py::test_link_hash_in_dep_fails_require_hashes
+ tests/functional/test_install_config.py::test_prompt_for_keyring_if_needed
+ )
+
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/functional/test_install.py::test_install_sends_client_cert
+ tests/functional/test_install_config.py::test_do_not_prompt_for_authentication
+ tests/functional/test_install_config.py::test_prompt_for_authentication
+ tests/functional/test_install_config.py::test_prompt_for_keyring_if_needed
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.10)
+ EPYTEST_DESELECT+=(
+ # no clue why they fail
+ tests/unit/test_base_command.py::test_base_command_global_tempdir_cleanup
+ tests/unit/test_base_command.py::test_base_command_local_tempdir_cleanup
+ tests/unit/test_base_command.py::test_base_command_provides_tempdir_helpers
+ )
+ ;;
+ esac
+
+ local -x PIP_DISABLE_PIP_VERSION_CHECK=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_XDIST=1
+ epytest -m "not network"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/html/**/*.rst )
+ distutils-r1_python_install_all
+
+ newbashcomp completion.bash pip
+
+ insinto /usr/share/zsh/site-functions
+ newins completion.zsh _pip
+}
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index de851282a16d..785c800f0279 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -3,4 +3,4 @@ AUX twistd.init 563 BLAKE2B 24488118b025bf2068bbf07af900064ff6a7ee99106c3da30f15
DIST twisted-23.10.0.tar.gz 3495627 BLAKE2B 3b5c2dc56686203cfe7c863211f0be34f49b26273af7b0f54a891851cf5f32096da880f35dd549b8ff82c6885fda2f644ef747fc9574e830da4fe2ddb588e70f SHA512 da6cc663005776fca716503ec53ae367576e9c89ec2b90a367e73afb1e63c51a24dfad39b9ed1edb597e77e1d805dcbd179cefc1685faddd4044efc8f6c82d5f
DIST twisted-regen-cache.gz 911 BLAKE2B ffd3fcda6c67ffe6fd3ef581c8d507548396b66ed0708e9a5c790095e579c0d5f0f71596acf05712989da2ddef2b8d437eca973bc4d80ef8a9fa852915f38305 SHA512 95a9b931c73017d16d1b5e6b41345dddffe62b6af1a8e93b5e40d06d3d15be17b0dd0181c767ffeeb791534d463764ef9e066fa6c2ee2ac4b53c86d1da8fce03
EBUILD twisted-23.10.0.ebuild 4134 BLAKE2B 48ad17b240e917bf0302c7e70a72fec9225108f07065110951685331bb3464588a0503c387efad0a16e3a1391cb8af1fe0b7461247b4462391adad25bb4d2076 SHA512 5619ee1cfb20422b6c3e2df29eb20d2d2c01748c2ef1201c009cd856e3f07f4811c703eb570429ac4de4bc051c532d32a8ee51f3f2c336a11ebe34380ec256a5
-MISC metadata.xml 1281 BLAKE2B 06f3bba5716e641cfb848eaf212fcd5a18d89caeefe1b0ec2fc6e0799ded9ded5c54dc04d239b6e7c427a23c0300caecc67cbb2a292a745dba5cddbf02fe4330 SHA512 e78734d016205a2bd850ddf68bfefce024a95efc4d4a42af52314aa363d6c654dada671b98a1b02642e7abe2f9a48c0454949b4bf07e88776924c63175b24227
+MISC metadata.xml 1231 BLAKE2B 60cd09e34c32152e6f08727c1281c65e871a51e64310a62a3104342fcb0e87e96b10cd4c7601668f054f9a2cb01fdf8ebeca3ed86b61ae2496a4d941897aa296 SHA512 800d9cd783d95cecb268362619deb346783149fa9226df714f9ce990da2d45edd3c8e5669e24ad15dfdf986a5816a5361c00f13719bb0dee3e6ae1578a889339
diff --git a/dev-python/twisted/metadata.xml b/dev-python/twisted/metadata.xml
index 3d0719337243..5fb905aee3f7 100644
--- a/dev-python/twisted/metadata.xml
+++ b/dev-python/twisted/metadata.xml
@@ -11,7 +11,6 @@
</upstream>
<use>
<flag name="conch">include Twisted SSHv2 implementation</flag>
- <flag name="http2">include http2 support</flag>
<flag name="serial">include serial port support</flag>
</use>
<longdescription>Twisted is an event-based framework for internet
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index b757c395ecef..58ab6295c1bb 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -7,4 +7,4 @@ EBUILD urllib3-1.26.18.ebuild 2312 BLAKE2B 9c1155aa93102ea0b118b2980142c07b9bb98
EBUILD urllib3-2.0.7.ebuild 3297 BLAKE2B aa93e50875380bda0b91543451be2d3425d0ab8c77650a9c84fff90c889ddf812ae66b78fed95ef820a68a510eb952716fea459f7dcef8b41db8156e0b5d3cb0 SHA512 790d5c7d1fb6838be75ecb3802cda5975ffe5a45c57cd67d6fe264de4bf47b9511b897233f8057298721665366f1da5bb89fbb58bf255b4659b8afc4f95224d4
EBUILD urllib3-2.1.0.ebuild 3297 BLAKE2B aa93e50875380bda0b91543451be2d3425d0ab8c77650a9c84fff90c889ddf812ae66b78fed95ef820a68a510eb952716fea459f7dcef8b41db8156e0b5d3cb0 SHA512 790d5c7d1fb6838be75ecb3802cda5975ffe5a45c57cd67d6fe264de4bf47b9511b897233f8057298721665366f1da5bb89fbb58bf255b4659b8afc4f95224d4
EBUILD urllib3-2.2.0.ebuild 2836 BLAKE2B 456c952b401df22899f4dc3c602be5e819057f6c4eae76a215316e5854afd599f23b8dd1837a69c92ee9d5ed3a1dfc1c608b66a80609c1c54f929ff9dc9631dd SHA512 62db40b3929fa0b47744854b9226d818929c741a12a62c63ad622f994eb12512a17972d3bdae79a26d6639afee47850479c74f7653a25fa7e9ffb5fd43804fd5
-MISC metadata.xml 517 BLAKE2B dc83f0a8a82237c4b4627060b12b2e39dd1ed3550b0b76b5b2d8a91be9fed2e9a5af48ec0b9a981a04ed6ec83b3f9a3cc0a0fb333fcd5f6e01e66b1b325daef5 SHA512 f8235269abc564086f2ba87cbeb45c3dceaa7bedc68e298830bb1ca4de5f570697c634a042c054bb433993b501b3809a223d2ccc39fa9a14c5fe8c2d14938d81
+MISC metadata.xml 449 BLAKE2B 45df5a0e80d7b229058be52fd8feb3ba2efe8d981b5b34216e4b9cb35d332588c4b3efade8e8d06bdf1f13159dfcd937458e5cf4d0cea5e07b6c1011cc8592cb SHA512 312b41031a9cbf6341f537fef94137420ca49ab609e7d4c325a998e328be415b381aa50e7b5600483d1a7583b72675a044b5dd80cb84a52539ab23271f1b096c
diff --git a/dev-python/urllib3/metadata.xml b/dev-python/urllib3/metadata.xml
index fb30a3f274c4..e27c6550e713 100644
--- a/dev-python/urllib3/metadata.xml
+++ b/dev-python/urllib3/metadata.xml
@@ -11,7 +11,4 @@
<remote-id type="cpe">cpe:/a:urllib3:urllib3</remote-id>
<remote-id type="github">urllib3/urllib3</remote-id>
</upstream>
- <use>
- <flag name="http2">Enable HTTP/2.0 support.</flag>
- </use>
</pkgmetadata>