summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin268924 -> 268924 bytes
-rw-r--r--dev-python/cloudpickle/Manifest2
-rw-r--r--dev-python/cloudpickle/cloudpickle-3.0.0.ebuild3
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild49
-rw-r--r--dev-python/pydata-sphinx-theme/Manifest3
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.15.1.ebuild54
-rw-r--r--dev-python/pytest-skip-markers/Manifest2
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild47
-rw-r--r--dev-python/wxpython/Manifest2
-rw-r--r--dev-python/wxpython/wxpython-4.2.1.ebuild3
11 files changed, 163 insertions, 4 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 9fa72d79d604..aeaed37450ce 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/cloudpickle/Manifest b/dev-python/cloudpickle/Manifest
index 664f132970f5..09a530592acc 100644
--- a/dev-python/cloudpickle/Manifest
+++ b/dev-python/cloudpickle/Manifest
@@ -1,3 +1,3 @@
DIST cloudpickle-3.0.0.gh.tar.gz 59519 BLAKE2B 6d5c7b98990bb4d59ffc4e75efe109814430c8b73753d630b169ce0c455e5d5105782a314d4921b5051d458758980c954b8a84cf79a9534c9a382a8066d03c27 SHA512 e091cc0de2489c06e020fac2852d25f7fd832036a2b2c4c34f0cda0c642a1c65413fc0f21dc51fec75803e7c7da37f26f613620150acd9ab4aa2bb7b1eaabb79
-EBUILD cloudpickle-3.0.0.ebuild 889 BLAKE2B 609625c6a518bf6f2c489902b9a81747e15c415a714d4662061803acb46eaee36554d63ed1b6c5dd2f99f12429681ff2471ffd79afc9f5481c6503f1ee2adca7 SHA512 87a6be7f7edf8c099860e4b9fed4b61e0670a18391584e08c070588e4efb0cc5ba5148b6be9ad3347f97ef62886b26807a072edc22a5f49aac4cd0637be5275d
+EBUILD cloudpickle-3.0.0.ebuild 932 BLAKE2B f2e73834c4b248509d8f90fb997870d3aaea7d6c8a300e7b028ccfe4fe0b9f178684d2987d24b685f2ad21f8c8cfcb5f845535ad99da5e191f9477eefee5ca47 SHA512 959488099b6788c2ce33d7b5de4f44d99c96ae86197d7420492e1b696d1bd3321849d821277526518785b3d75f2f2549c434efc4ab4e7be9064f3db031352395
MISC metadata.xml 400 BLAKE2B 6b8036e6fee459cd45ff48884ade7ba9471d948ff06e46062584e5953fdaea8197525ec02e2dc44d4daa6326c7a1859680340e616f27d72ea1d98fe5c011a5cd SHA512 70c88c748d18923d3205c9f2ebc683e6b73240d4f8215f1bf3c3c91bb5eaac259066dc735f10806c43375432df581545831c616ab3aa7218981193956e6c0450
diff --git a/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
index ef1658bb7c89..f840b4424579 100644
--- a/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
+++ b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,7 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTHONPATH=${PYTHONPATH}:tests/cloudpickle_testpkg
# -s unbreaks some tests
# https://github.com/cloudpipe/cloudpickle/issues/252
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 125fceb9cb7d..7dd3b5fb1ff4 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,5 @@
DIST google-api-python-client-2.111.0.tar.gz 12461105 BLAKE2B 3aa1de35867fbf2287fc4f0aadf4dc77aeb62bc0d894bcaf546ca00e062de289c83a732298ad6b09927d60bb1e3ea47e0a20fb108e23cb7af222e67a6e45d464 SHA512 3eb9a4580c6b59dbd7dff1f0ca9f309e92d7f75ce6d3085833d96c72751212a47073ef2b322ad85bc2795e82c85b9b80593f18a7335cc7438b0acaa94cbf04f5
+DIST google-api-python-client-2.112.0.tar.gz 12465562 BLAKE2B d29c22176fb3467c7df0d937baa954973437fc03862b56a370888fe014b24e3ec1b8b1c00b80251bcd039711340aea13bd21618f782ee4bd7c975c0820271630 SHA512 e9bbec1c27105cb772c1f059b5cf2f83cf44f1aa003149a509cac15c46d68c80edd2705aad597f31d98e31cb61396f0516ddc69b5041237d96246898c31329b4
EBUILD google-api-python-client-2.111.0.ebuild 1313 BLAKE2B 93f5dbf9054531a2a9275f71bd7732e16cc9b510302c00677a8b1d1092ec8d4f81cf119e67cf4b2f623763e722f36038cf28f373fe1990d635e38f17e87c1b54 SHA512 6316da593c211dae45147c5ba1cb6a65898da75668978dfe13fb6eaa9d3ff7bf6e35d01aa1cf0c3249b5e6c240cf5f23252223feefe40ec3e2d650103e340248
+EBUILD google-api-python-client-2.112.0.ebuild 1316 BLAKE2B 437ad4346d43d1a71c6ca6537c57e42b7b50fc5bd71d69157abad0e24bda38d6f07ff192b146304a689a8040392a4ee5c50ad11da5b7f512cde4675502aea379 SHA512 4e68eed9dbadc5b5298b8d883d98ffd290fdbf96a0ed0ad8064751fe2823fc7c49117fb4676f09bbb9a1ebb72af43876023ec8b01729962256b477c0db839d0f
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild
new file mode 100644
index 000000000000..c041dee86d3c
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.112.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}
diff --git a/dev-python/pydata-sphinx-theme/Manifest b/dev-python/pydata-sphinx-theme/Manifest
index 0495f3cef145..2b582f59332b 100644
--- a/dev-python/pydata-sphinx-theme/Manifest
+++ b/dev-python/pydata-sphinx-theme/Manifest
@@ -1,4 +1,7 @@
DIST pydata-sphinx-theme-0.14.4.gh.tar.gz 2404916 BLAKE2B fda8fbcecdc5e8b315383134b3cf95753fae5cb93abe57fa032e231f3143a774bd8b8fb7a98ff8cba6384660c4df328f83d234a0e2f8b25e13cce22d0b38f219 SHA512 348a7b30065baa1bced2118060412c08471faa8b3d31b610dde6eb5e00210f8527cee7cee173e909259af1a4c9e3704316924ab282a599c805ee54078d2030a7
+DIST pydata-sphinx-theme-0.15.1.gh.tar.gz 2408417 BLAKE2B ce5f21c2f9f2b94a7fc7d907c44527459e46c735e3c7bf39966b2402acf94948d9f91941962598d61b992f33b8fde2381e8c5649e9593386572ee79712160f4f SHA512 34eccf49c69e55999e6af2797c0c861f49c43c0d014f05b200ee40cfd703abaecd90be9aaf52409556b9d5acff6238ce09040959a7a07f4dc285a6d40ecfc912
DIST pydata_sphinx_theme-0.14.4-py3-none-any.whl 4682140 BLAKE2B 29db5217021e4f240174269fe9baa0d0f0b1e1b04213a6639d5491a002bff65e4db1468bed1de850fe0f4a8549e564db91f098fb41c4d2981b88a2fed373659c SHA512 962756e901e90f7c490905dd94703a172fb4de2628f7dc38731de75299e77a5915e93103219562a4291ad37942eee48c888faa523409e149ea31fc10dbcfdf2c
+DIST pydata_sphinx_theme-0.15.1-py3-none-any.whl 4521543 BLAKE2B c5e20e42ce2fd32a46b39037fe680c2ec6a420cc76a02dc1c391f633e3a164de28d107834add9b427e5f27afde0a86e8d32287084c10959cf444f5580a3fb231 SHA512 13ebf72548c963fa850aa2da9d73863cc4c771c7db5a5d90a18af3408f2cf3d75d908aa40c16dfe098941ec5128a0117e5c29aab3e3119715207af28e3a6f8d5
EBUILD pydata-sphinx-theme-0.14.4.ebuild 1217 BLAKE2B 4a23a59ffc8d0bd696fb381caf876e35ce6008e9a452567458de5e5e5218c5d202618c84a42051141b4e018ef965c1da2f89aaed018c888012f4c38b3c0183bc SHA512 6cf09f418f8b6e6c8d014973e354f32d4e00c9c87c670179cba4b9c9accc230b66977b78e2d9ccf6d6c217c84981b348bc54f5f2070d85325d31374131df595d
+EBUILD pydata-sphinx-theme-0.15.1.ebuild 1357 BLAKE2B 938a198ea87323de092db882cf7df174c594aa7a6d3165740359d99c66402f88b99e18814c4349a8e8e18d20358127d15957dfec24e4bd10beff0a87ad3055cf SHA512 f1c1418a88c535c6e7e4e19971294c6531401c2fcf5ee71823f7b2e026e969a80da9f22a95262bd395a1a367bf1819ebd5f235f73be835ab64b244f939a6ccaa
MISC metadata.xml 532 BLAKE2B 397b44fab769346cc170d5627dc663adbe29b780cbabc3d7643d5bda6ff89d6fbe6e6f55da69e93b8b20ddee16856612063b442125a16e035803e50f5aae924f SHA512 9de912fb51a153d508f3a12a3eb7ef3cd926089452bd6bfb822ae4a797d8aeb9ac68973ea7bebf3095f546dd288fdf651710ca8536f19907ac69f622ca3b0550
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.15.1.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.15.1.ebuild
new file mode 100644
index 000000000000..5436ae77e57a
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.15.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bootstrap-based Sphinx theme from the PyData community"
+HOMEPAGE="
+ https://github.com/pydata/pydata-sphinx-theme/
+ https://pypi.org/project/pydata-sphinx-theme/
+"
+SRC_URI="
+ https://github.com/pydata/pydata-sphinx-theme/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ $(pypi_wheel_url)
+"
+
+LICENSE="BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/accessible-pygments[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/$(pypi_wheel_name)"
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/pydata_sphinx_theme" || die
+ epytest "${S}"/tests
+}
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
index e1e8140a78b7..4ff4f9fc0b38 100644
--- a/dev-python/pytest-skip-markers/Manifest
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -1,3 +1,5 @@
DIST pytest-skip-markers-1.5.0.gh.tar.gz 73142 BLAKE2B 26575a1a7880714b3af4fd7b02b5c5d56b99e0ad0947012823e6c917afe7ca134e930f2bf75b3504fe3fd1516d39e82acd7dae799255b30c370ae085d0cff402 SHA512 217fae64013a0d0f4b91d33a22576df9dece1bdda28beda0919e3638ed6cddcf24715971fb1da8e8c62df50510c969ce24716044d6aa05f8a0b4891082e83584
+DIST pytest-skip-markers-1.5.1.gh.tar.gz 73219 BLAKE2B f8f23bf64dfc23263ee58397fa8571bf76a77820230f8f27003f72f0a26cbb19ae76185ed203e5b516326a40a355c2d006101f2eb7cd4df40f4a4d80e8e7c629 SHA512 4221e39ab472a88c4f6d0cf2fbf0de1568f99f5ca9962e4afab060b6cfd8365d106583cf818a98bbc7f8f4d5192c7fc9678e4e0da2b6c1082c26ee2e049b0004
EBUILD pytest-skip-markers-1.5.0.ebuild 1109 BLAKE2B 92f12b21e50af4875f3423fdd5d415fc9defafc56bbaf66fff584c77849c93a8348fca8abd1c22a1813ad27a25f978aed490255b17f1884f189d5a714b97edaf SHA512 75d510c5b9fad0f3dddde3d33a1c254ed451ffcc5046841f67290d62c518dd0d806b3e9879d6ef29ecbc117035e46805296c6d890551334f8aa02f27e421da16
+EBUILD pytest-skip-markers-1.5.1.ebuild 1112 BLAKE2B a8788c596c6341c5463197ec844d5d8e3f860cd6615fff697ae919e1a9ab3c51afb90c3a83441d7b8b60b1fd6266c3a59977d750d50e22c577db9a8efdc3e381 SHA512 279eb20d105bc1675dddab5f88f9b4748be22691c80db4d10b0e6e27fdf2b33b59f8cc988581ae914ac8bc9e98d98939ae4fd6263927ca4a2fbbaf1b90667faa
MISC metadata.xml 502 BLAKE2B 7bdc44ea13e9ebfa8d021af8a1dc4d83d391d4e5432ca0c953fef593861cea852b76817214ccf80a8bef9fd481641b1eaecccabe839c6378d84d198d172754da SHA512 439a3664c428abd1796d33f15c7791ceb33ba65428b7bde27a42c181bbfda099d7a8c28e723fceb9bc5caa094072c77d6b84831b152d50653f4ef3d4dd54e412
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild
new file mode 100644
index 000000000000..d88624574191
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
+ epytest
+}
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index c926a2add94d..cb90a32eb997 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -5,5 +5,5 @@ AUX wxpython-4.2.0-no-webkit.patch 1285 BLAKE2B 19fdee2293da214b8ae318b2670298b3
DIST wxPython-4.2.0.tar.gz 70958238 BLAKE2B 2e8e34c4f5d1992983bfe4e09bb56ee5619b139b9b3b5f05dee48ecdf6971cf9fe1b0fb22aec685904eb44db6f50a4ba132a08aa91930d809040da828efa097e SHA512 9ec937a024efb2916403c84382a66004f0c2bb07471246b7de517778309ce459e929eeb59e261f538d3fa077c950628de62e49a3760fbd03ab9ff2114c6f354f
DIST wxPython-4.2.1.tar.gz 73724359 BLAKE2B d9569ea172c7279e0b2cfcb3cdcd5d1faab5324e2648c9b0f8c8b838fb2355dc6af28c4593e5dd0cfa02573133bf15a58a6ffa9711d854925a9cada0985dc7f8 SHA512 ee9ab8effb3c71de004c3d61ec583b9980c6b75fe9bb04cf2c76025ea70afc206bc3073c44d1c83c7ba604afed9fd38c01b9ef506617ba279a4ac58e3cf34438
EBUILD wxpython-4.2.0.ebuild 3923 BLAKE2B 4594f53e557dca2d0d6d81ac86f28aed740993388e5db2047fd90c0093429ae1411e8053f0667a7df927cc87a70137622ee3cf388cc640af190b73de92eac88f SHA512 6795d83346946781a351adf25c21aef438e01d207a4eb97ea513545ebe8ac11cc6720e6d2b203ca9c1a1faf48a31da8363ffb748c8bcd0283f79e8343273dc96
-EBUILD wxpython-4.2.1.ebuild 3485 BLAKE2B f64bc579753d692f9e240a586c403143cf40440c512e64ae3bbc4f9dfda41f52825b5f8e04155f0802c70e13f300e3979fd03059e1301b7a58766daccea8ce6f SHA512 8ca410da5c2f21335ec5aa882e3341077ef377956497ecbcf687c50774aea3e432307aef3c934c25f7110f127abba05ea0ab68cb6c397ccb7f26f04c80cf73fd
+EBUILD wxpython-4.2.1.ebuild 3530 BLAKE2B 6b4c682043ee8b013afdc863cbb83e2f21644de40dc4f1f7cf7444f83f43f1b5489aab0f8287c844ffb930c20199900539b8c0844afc1b537be39d9b0121070f SHA512 d813a387ca30fd4c993ddc64b46fa58d10537097b513a71c5f207fccf4d033a0a0f717f2cc9383b7571383054dde7d8f2f892ad0d94dd7065b9a8e9cd62d0e25
MISC metadata.xml 491 BLAKE2B ffa0cccf66f484c856fb30249bd0ccc3b0da2f3ee8e3c3a0df1782bc58e4867ff99d9711f1784b44b439f2a8bcf297c1082b49a941823f046c7f2c7977a77629 SHA512 a2f5908a276a8f9c512cb59c8d17873398c91b21977371ab724e669f3b6c032d53510fbcd183a5dc340279fc522289e617b8c313c0d825ca70d0d2a5d74f8cfa
diff --git a/dev-python/wxpython/wxpython-4.2.1.ebuild b/dev-python/wxpython/wxpython-4.2.1.ebuild
index db600927b5be..dabd9c7f5208 100644
--- a/dev-python/wxpython/wxpython-4.2.1.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -49,6 +49,7 @@ BDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"