summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin259041 -> 259046 bytes
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2022.1.6.ebuild25
-rw-r--r--dev-python/pytest-markdown/Manifest2
-rw-r--r--dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild (renamed from dev-python/pytest-markdown/pytest-markdown-1.0.2.ebuild)6
5 files changed, 21 insertions, 14 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 835c0ca53158..6ed9cc0edb76 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 680bb81f324c..9ffadcbfc244 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,5 +1,5 @@
DIST pyopencl-2022.1.5.tar.gz 454129 BLAKE2B 266bc327c9af5654287fc47cdf4e6002c7cddcd6f5e55bb70bb62aaee666dc5c102f78d4e946f010c1e109390c1d2e981e7ca6ca002d10f66248cb008b308734 SHA512 e6eb3e6d886d8ca1d94867a398b286556fd2d93535bb8481c7603cd521cd47606ce3d9cd6422830c6404305a4a1293234d8774fdda6923bdd2b4fc21fb39d377
DIST pyopencl-2022.1.6.tar.gz 455424 BLAKE2B 03c46bebc4d6093489b0a1501267d5d67b73e9e7fe50f73cec3dd752fbb699adab63e08d60f3a54c8fd215cbb82c81353d28e875b953686b05e188df78cfe237 SHA512 a1e404c4c5f95d111690c969ae5c5d34f0deca2c8b93a5ce4d90e003031af7eb94a7708f878170a9b6e001b899d321f7dfdaa6f7545af3237d30d237d44bb45f
EBUILD pyopencl-2022.1.5.ebuild 1572 BLAKE2B aaed0c92df6a752644454b17cdddb25f9c77179404a02b76ad3860d862faa9ff8b108b7f3330e385ab22360a41a25fbb6a4378fa4eee683d20955d71ac15d481 SHA512 60867d0d0708fdf047d72d8fd80a49c2b0b88abecb45a859f5690d9ceb07bb171e8789c9e7239d3f2c428ac2d4fb96fdbbab13d94a034e5c600e7caa196251c8
-EBUILD pyopencl-2022.1.6.ebuild 1599 BLAKE2B addd81de214a3c33e515e7716eb07ce1be83f487470a811e6df4de207bb315501f928290ce831c79f792ea7d67761725f656e8a71916393bcd48e9010a8e358f SHA512 36dccf1dd5cd846a64d6eeeb5fbc8fde0aaeacf7fd178531aa039341d69255a09a6745440980ada2983a0d4a59efef87edf21e358aa0ed34a7d7c9976a5fda84
+EBUILD pyopencl-2022.1.6.ebuild 1820 BLAKE2B 4771789e3bcf994856411c9c0f41f1d7c79c3fa1cf8d0dd5ef149cac0a3ad2277031ed97d8f6c17362cfc269cd31d5c1a9e05546b38194e89646e648e12a677a SHA512 2a6b2abd6ffcc6646599064ce4b34d26eea8b3407ea21ba46818efe19c7c203bc95eca0429adcb4d464c4be8e658693dc9577eb1f5acf94697792661da3fc96f
MISC metadata.xml 317 BLAKE2B ba532c522d5fd599dfd41180c9813f8124dc64cd3bc7a3a7b1ecdc121b216db4b43f6cae9c32c52a430fbf6e9a22c0cf27ffaf0041ca372d81666991bcf0e979 SHA512 845a8b83a5d7729ea0fca8b704de297b8b8c0d8f315fad0bea7c0c645bc79dd993209e9ca5e89ec9c8ddbe6db2b1f142c3e1f7e5b8e4b6259fe927527ce6a919
diff --git a/dev-python/pyopencl/pyopencl-2022.1.6.ebuild b/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
index 19e2c5a987c8..a1d774b5553c 100644
--- a/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
+++ b/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Python wrapper for OpenCL"
HOMEPAGE="https://mathema.tician.de/software/pyopencl/
@@ -29,15 +29,10 @@ RDEPEND="${COMMON}
>=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- <dev-python/pybind11-2.10.0[${PYTHON_USEDEP}]"
+ <dev-python/pybind11-2.10.0[${PYTHON_USEDEP}]
+ test? ( dev-libs/pocl )"
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
+distutils_enable_tests pytest
python_configure_all() {
local myconf=()
@@ -49,6 +44,18 @@ python_configure_all() {
"${myconf[@]}"
}
+python_test() {
+ # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
+ local -x PYOPENCL_TEST="portable:pthread"
+ # Set the number of threads to match MAKEOPTS
+ local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
+ # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
+ # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
+ pushd test >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}
+
python_install_all() {
if use examples; then
dodoc -r examples
diff --git a/dev-python/pytest-markdown/Manifest b/dev-python/pytest-markdown/Manifest
index 8d571380a692..18110cba4b7b 100644
--- a/dev-python/pytest-markdown/Manifest
+++ b/dev-python/pytest-markdown/Manifest
@@ -1,3 +1,3 @@
DIST pytest-markdown-1.0.2.tar.gz 2991 BLAKE2B 489bd1ccd6060b9588515772ff1f269dc57c328b3695405d0dd755340968899a2b912644e325ce5792528da90e5eac828314dbb9d1396eb34dffe0da04261848 SHA512 a2d5b38982f004a362ec2bda7aec45a6fb9e0b33dfd212647d8eab38fdadf6501b7fec8ad8838b286d81a156429aeb0ad3aa63361a580c2c7528fe19e474a7f6
-EBUILD pytest-markdown-1.0.2.ebuild 642 BLAKE2B 9efb5b62998f05e99ae581db0894849bf96a1bdc034d07d36336f294438a27ee6d80fc78102054922fed4393736c7a45f88b2b14a143af594971ee9fe09b2ea0 SHA512 e1891dd14a72843038f7d420f69e4cf6ac387a0e845e371eccf4b1bef391c1381cc3c4fa5b7f9f64f9d96c8f0a1a1cf8d117c3d809f57adef158528f67c8be85
+EBUILD pytest-markdown-1.0.2-r1.ebuild 593 BLAKE2B ec52d010b7e43cae77ac3544c12a2960efa02f58bf972a27f6c3f8a3c845686b3b3badc02af43756a8f69a3b7083d795f26579e2e74100fc31d6249da6f84bd0 SHA512 bf1a4dd0d1e7ffabebdedb732e58fa792dd9dc7edd0f3302344dd2097a8cdce45109670d7bb5086f6e6d181f169fd641ce31d6ff5f29d63de05a3cda377694ad
MISC metadata.xml 408 BLAKE2B 5bf707e04d11ff64f66112fb2a097ff7791ba883fd96492ccf59856d7840e2de34e6945f04943effa82b4f60b6b48c29b75de310c395da989bd82dbc7088154b SHA512 4c381e16ede235dff63ab6b5525900b66ad160c3e5fd3dfd013358c55266a799c2e10a310ca673ea4a931d671908f28e3e284a44b2fe3f9fbfaabb162ff39ea1
diff --git a/dev-python/pytest-markdown/pytest-markdown-1.0.2.ebuild b/dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild
index 47c5476a6d1a..6fe08a1956af 100644
--- a/dev-python/pytest-markdown/pytest-markdown-1.0.2.ebuild
+++ b/dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild
@@ -3,15 +3,15 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517="poetry"
inherit distutils-r1
MY_PN="${PN/-/_}"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+DESCRIPTION="Run tests in your markdown"
HOMEPAGE="https://github.com/Jc2k/pytest-markdown"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"