summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin258571 -> 258903 bytes
-rw-r--r--dev-python/pyupgrade/Manifest3
-rw-r--r--dev-python/pyupgrade/metadata.xml21
-rw-r--r--dev-python/pyupgrade/pyupgrade-2.37.3.ebuild20
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-23.2.0.ebuild77
-rw-r--r--dev-python/tokenize-rt/Manifest3
-rw-r--r--dev-python/tokenize-rt/metadata.xml21
-rw-r--r--dev-python/tokenize-rt/tokenize-rt-4.2.1.ebuild18
9 files changed, 86 insertions, 78 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 867881518e4c..d6da527d6afb 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
new file mode 100644
index 000000000000..4de5f58c22cc
--- /dev/null
+++ b/dev-python/pyupgrade/Manifest
@@ -0,0 +1,3 @@
+DIST pyupgrade-2.37.3.gh.tar.gz 64041 BLAKE2B 531ac8038c7084a4e46bac15d8da056d04496d979beb1fa98ab0832fab50425f412e3b17de3a52a24264acf489af9a9dde6094dd8a5939877269b38d1997d9ad SHA512 dd7e31c2e586d412902d25f30102dc7d229f76f4735e61ad9c77ad59642c2c2ed65d937cc5c6cde9bd50a1a2dad99d06a97c88fb6b0bd034cbc139685045f738
+EBUILD pyupgrade-2.37.3.ebuild 579 BLAKE2B 23b27bcceeed4c3a8d94bdeb3eb5ad97bed4d02e2c0bfb2b5c0811e72d3d5085eb35fef8adb6cfee14e8528479935898d36612e23ff1e7b13ac41b6d45aec32e SHA512 cba4069b225a210287bd79ade8bf89836a95d85a94c9dc1dffdcbf18f1573eab55f3d4bead5ec90b0c0448e9718f41a7c596b26d4a2d8a34faf3ad8fb449ca1e
+MISC metadata.xml 598 BLAKE2B 0efa6bc0c32378e116c4c1a37458be82add617d76b8b11e41947d26fc6eaa08c7c0069e05f2fc67f7903f580d6915d7b973657ed5bc186ef08533da958cc0070 SHA512 c220e724cf228be4ffad4c5f20d2cd58a084dc0d1483111a4250ddd3798b19b6074a829e8cd75cdc8b82e97b8b7e1cf02c7ba19da133c507953dc5f7166a267a
diff --git a/dev-python/pyupgrade/metadata.xml b/dev-python/pyupgrade/metadata.xml
new file mode 100644
index 000000000000..f072f4d85273
--- /dev/null
+++ b/dev-python/pyupgrade/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pypi</remote-id>
+ <remote-id type="github">asottile/pyupgrade</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild b/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild
new file mode 100644
index 000000000000..568af18a9d08
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A tool (and pre-commit hook) to automatically upgrade syntax for newer versions of the language."
+HOMEPAGE="https://github.com/asottile/pyupgrade"
+SRC_URI="https://github.com/asottile/pyupgrade/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/tokenize-rt[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index ea2dc67b923d..6ec30732ff86 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -2,6 +2,5 @@ AUX pyzmq-23.2.0-libdir.patch 510 BLAKE2B cb7884416d3e15f735412d69a7ae0decbbf8ec
DIST pyzmq-23.2.0.gh.tar.gz 402085 BLAKE2B 4ab26af04c76205d0770163e248e28a22aa8f710a66c9dc96e18c772338c434ad06227d57edd5aa3476fad68fa7320e9216a102b2cb19649393f1e9ef5d9599c SHA512 348482f4b6fd4ebeae8e4720a7005ed35eccee2bf26b0128115b756ee560156b34e6f043c96b71a84d47b1313bd2d8e0ed0f74c7768e23cbf65bd906036800c5
DIST pyzmq-23.2.1.gh.tar.gz 402170 BLAKE2B 4cedd065cecbabc0e18928423e853a38953cd1f360fc326573c60bf69ffefadf3bed556d9d71eedf824e646ae23640d14b6aa8938c397c367be32cc36d300e38 SHA512 4ba236b87db062b245a04530de5b1e8385491107ae8de465f6f664c75ab8a929d57491eb3f8dddf31ff1db7b1eee89a6892a9a844bc285096cc9960704b36c9c
EBUILD pyzmq-23.2.0-r1.ebuild 1936 BLAKE2B 73091e45f9a8b0090c00f6fe67b5779c6085bf7e8a47dba327584a7027d0052c7f0caf5730bb9d02baf23342982dce233af994b54025acb1d00f49374abcfdc2 SHA512 b1b142edae52437d730f143c8ef6078574ea566d489cd1a4f74206fe700699ced1edbc3cb6f96a8829fd68fb2fd084d0f0d5ab61069f65e1b814688936d2b1d9
-EBUILD pyzmq-23.2.0.ebuild 1882 BLAKE2B 64244a051abb1d374d87d202887385482730156a21141bcbf0075358d378345e46e0c93acdb4e62866f0c529a4309a32a8671fd95d6e20f075f6d3bb17c9ac3f SHA512 03625c285825f06e5fc2fb80f442eb8ef1ff8cbaaadf1a231eda52f7c0fcff540147c056cfa2fecbdd9f995b0ff48a0c6f808c607539d49200e7a907824ff42c
EBUILD pyzmq-23.2.1.ebuild 1944 BLAKE2B ddb71887234f1d8fc509f8b100aa33a80e929ccdafb3e4c7513886dde4f04dfafe1ab6be0891cd8c3408e9a1dd53f3cda23f0ede3a2f077f5e7c0f655b1dc7cc SHA512 bc9c1f1366d4744cd953cb50de3184f8e8b2e8a45137870d39e297e1fbb8defc2c12d03ff746568b8ef17d247997246556b8a05b509157ac1cd5c7f9bcac2344
MISC metadata.xml 548 BLAKE2B 0120b82c6a48537f80d08237f4184ff855c109a0a461adfe7921e25468928ea053cc7727c7b00ff96ea556d719e453ee27cf534b285f24f62f7d1ca4ab326770 SHA512 124145f71518d39daa57522eadc27ab4782c3fc1794543396a6b6c91dda29175c4c097d6be90d7d405823621ce66f62e169b97e086c983d7f08178e6d85cee40
diff --git a/dev-python/pyzmq/pyzmq-23.2.0.ebuild b/dev-python/pyzmq/pyzmq-23.2.0.ebuild
deleted file mode 100644
index cdb941627bc5..000000000000
--- a/dev-python/pyzmq/pyzmq-23.2.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-# TODO: Find out exactly where this error comes from
-# error: '<' not supported between instances of 'str' and 'int'
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="
- https://zeromq.org/languages/python/
- https://pypi.org/project/pyzmq/
- https://github.com/zeromq/pyzmq/"
-SRC_URI="
- https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+draft"
-
-DEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
-"
-# it uses cffi backend for pypy, cython backend for cpython
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- test? (
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- "dev-python/numpydoc"
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
-}
-
-python_compile() {
- esetup.py cython --force
- ZMQ_PREFIX="${EPREFIX}/usr" distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- zmq/tests/test_constants.py::TestConstants::test_draft
- zmq/tests/test_cython.py::test_cython
-
- # hangs often
- zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
- )
- local EPYTEST_IGNORE=(
- zmq/tests/test_mypy.py
- )
-
- cd "${BUILD_DIR}/lib" || die
- epytest -p no:flaky
-}
diff --git a/dev-python/tokenize-rt/Manifest b/dev-python/tokenize-rt/Manifest
new file mode 100644
index 000000000000..7145be36a41e
--- /dev/null
+++ b/dev-python/tokenize-rt/Manifest
@@ -0,0 +1,3 @@
+DIST tokenize-rt-4.2.1.gh.tar.gz 7712 BLAKE2B b8cee02bbb9bb559a92645d8230abc29a58f100b9d03a496106bf9301ff2fa6b47e472970dc71203c61a7d1d3b95f6bb88ef8da15641c509efd10a7711e85d2b SHA512 e45d0da12962d67ebf6afe165750dbc6ddf41305154b1c01e99c1172aca27ccdd4da7c9338b84c74bb7e30192b6fc496cbda75a652304c7da6e2bfa63a513631
+EBUILD tokenize-rt-4.2.1.ebuild 490 BLAKE2B c9210237010e515bfc9a4e06e3abf6ee75033bc5324de3f724c0cd13016284f9d17c21bcaad6224fad0898ec41a6fad3ea55133f2271a0f4899d80aefdfbef32 SHA512 0d433cf876be7f904c7f30662f4ed144903ab691f11959f7183b6b6de75f51f4de69da87e48a10909b31419b687096b91bdbbc9633b04f5f1c2e2263bcdc7200
+MISC metadata.xml 607 BLAKE2B 02d39c8bd53de671b05e0ee930401b6fa9f87a00716cc33e6f171b4275081cb6eb86fb2979c9962a0ae733f3d33a3e93178ddd531c75443cc82ae86d0960fcc4 SHA512 de7f21ed5f4e2849883014fdc2a1711e7b23bf15ed0c7246f53d826ba83eac978b8b92e336beecc3c869598a47c9b89b23803ad7f616aa4d1edf880559bde4d9
diff --git a/dev-python/tokenize-rt/metadata.xml b/dev-python/tokenize-rt/metadata.xml
new file mode 100644
index 000000000000..4bd5a6fb82c6
--- /dev/null
+++ b/dev-python/tokenize-rt/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">tokenize-rt</remote-id>
+ <remote-id type="github">asottile/tokenize-rt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tokenize-rt/tokenize-rt-4.2.1.ebuild b/dev-python/tokenize-rt/tokenize-rt-4.2.1.ebuild
new file mode 100644
index 000000000000..78d51660fef3
--- /dev/null
+++ b/dev-python/tokenize-rt/tokenize-rt-4.2.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the stdlib 'tokenize' which roundtrips"
+HOMEPAGE="https://github.com/asottile/tokenize-rt"
+SRC_URI="https://github.com/asottile/tokenize-rt/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest