summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin262614 -> 262609 bytes
-rw-r--r--dev-python/graph-tool/Manifest2
-rw-r--r--dev-python/graph-tool/graph-tool-2.46.ebuild84
-rw-r--r--dev-python/pychm/Manifest2
-rw-r--r--dev-python/pychm/pychm-0.8.6-r1.ebuild2
-rw-r--r--dev-python/scikit-build-core/Manifest2
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild48
7 files changed, 52 insertions, 88 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 6a8c8761141f..10756e068c3c 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index 482c7afc15e0..b1a6507ed879 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1,6 +1,4 @@
-DIST graph-tool-2.46.tar.bz2 15189665 BLAKE2B 85b80feb7019cbd37b4440f6caa97eee4b27e439b2dc865742849e1f4cba9f9090d193fba7de87c84062da4b3f60887e19ee5f33b127373151b7767dacfdd4ae SHA512 a06c2d9acd23a11ea1faf2507222c3c4bfc8973e4fd7185a407d785a43f7409e77ace7af02030106a1bd13ffd719c6c10f7ebb76579448fa9bddd38b9ff7fb2a
DIST graph-tool-2.56.tar.bz2 15194737 BLAKE2B d28c2056eeeedf37480c042f9b5bfc2fe1f7df35c8f7c69b7431afde9b22fa4b5a79f6e8c8a8d8e9cf48f6607d34472d57c757c32e2c6b8a6c5f7ced79349579 SHA512 4db3711a87067e98095cb2cf49a5a7edb45723ecd238de8b4ff4ca13c34133c5552a29f6b5100e5b8b10a15ec1cac4d0e31578374ed73261d1e18b90980eef1c
-EBUILD graph-tool-2.46.ebuild 1778 BLAKE2B f802f81f4c1c935b5f83d0c9dd7df567fc81b0e797363f001d42a1aab4d8822cac5304aad4775a49ee04a13341ed50b9522415759df6e84f22b374d930802483 SHA512 6e2a1aa0f3b347f405768c9c1e2b5080c255a9f626e7910e5eee04556001c39e08fc705a4ae0b25c4c621698e8e94610cb22a7aeeb5677d49994df0e5ad4d5c2
EBUILD graph-tool-2.56.ebuild 1779 BLAKE2B 315840f08af610ca504f6991bde321c330d6ccd33dfca56a75cf4a48b262054a2ed61260bf28b2b0e45211d943afd915a3cbeb3ac5725dfd9b77858e60681943 SHA512 146a006f916be5f9f234bb8e26fdca55df73d89956462d43f7afae45801bf99763915a1c9d89ca8164c20ed8ed770797029ec243994f24ce852ae20290550208
EBUILD graph-tool-9999.ebuild 1779 BLAKE2B 315840f08af610ca504f6991bde321c330d6ccd33dfca56a75cf4a48b262054a2ed61260bf28b2b0e45211d943afd915a3cbeb3ac5725dfd9b77858e60681943 SHA512 146a006f916be5f9f234bb8e26fdca55df73d89956462d43f7afae45801bf99763915a1c9d89ca8164c20ed8ed770797029ec243994f24ce852ae20290550208
MISC metadata.xml 318 BLAKE2B f5a87067223b56a1c2f2a89278b2b7b8ab612a1575264999e40a3bb34853cf603a7a11546c7ff9aa4f253beeb09c2fd26abc8fda1c6f2de5bda35069e9f932bc SHA512 b3bf8fc36dd5ae8e8b773cf9a0670fa1c6a2ee3730c9f2980abf5823f52879c5ef87a357c25d025896bd75ced32ffcec82ecdb1f080babc4fe13d2a2b70624b1
diff --git a/dev-python/graph-tool/graph-tool-2.46.ebuild b/dev-python/graph-tool/graph-tool-2.46.ebuild
deleted file mode 100644
index 8908fe7983be..000000000000
--- a/dev-python/graph-tool/graph-tool-2.46.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit check-reqs python-r1 toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://git.skewed.de/count0/graph-tool.git"
- inherit autotools git-r3
-else
- SRC_URI="https://downloads.skewed.de/${PN}/${P}.tar.bz2"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
-HOMEPAGE="https://graph-tool.skewed.de/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+cairo openmp"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-libs/boost:=[context,python,${PYTHON_USEDEP}]
- dev-libs/expat
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- sci-mathematics/cgal:=
- dev-python/matplotlib[${PYTHON_USEDEP}]
- cairo? (
- dev-cpp/cairomm:0
- dev-python/pycairo[${PYTHON_USEDEP}]
- x11-libs/cairo[X]
- )"
-DEPEND="${RDEPEND}
- dev-cpp/sparsehash"
-BDEPEND="virtual/pkgconfig"
-
-# bug 453544
-CHECKREQS_DISK_BUILD="6G"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
- python_copy_sources
-}
-
-src_configure() {
- my_configure() {
- econf \
- --disable-static \
- $(use_enable openmp) \
- $(use_enable cairo) \
- --with-boost-python="boost_${EPYTHON/./}"
- }
- python_foreach_impl run_in_build_dir my_configure
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir emake
-}
-
-src_install() {
- my_python_install() {
- default
- python_optimize
- }
- python_foreach_impl run_in_build_dir my_python_install
-
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/dev-python/pychm/Manifest b/dev-python/pychm/Manifest
index fec960eed356..30df53053cb3 100644
--- a/dev-python/pychm/Manifest
+++ b/dev-python/pychm/Manifest
@@ -1,3 +1,3 @@
DIST pychm-0.8.6.gh.tar.gz 23803 BLAKE2B fdf3c37eead60455fd5bde1638a010f2788074752f98c32cf4b3431b4a87b8893c23a9fa29995352b35b41f628b7026fdbfa6ff20b75e8a6efdf75fc2da3f67d SHA512 cc1b254b6c58aba038171ad9db1eea3212094d7fb9386b22ada67381d702b388e6a1dde0317b5724587ee135d2695c546a7c2d65af7091dafeb394647597b0ae
-EBUILD pychm-0.8.6-r1.ebuild 772 BLAKE2B 2d22e7e189af66322e65af3737d19f384de2140fc9ac69c0306149e92afeb5b8f18e072e4020998e8a6ebb85ae3f2b60fa5c724b09e5483feacde2417b9ff01c SHA512 efcf6dbcd034babfd84f8e49c78ff46dac4872f892ae74401f30eb976d4c1e9e66d658517ee393d23952c047dbd985da04bc99c5cb4e7d20313ac5b422fbf392
+EBUILD pychm-0.8.6-r1.ebuild 779 BLAKE2B af82dff08d84781b15f204e870dd2a63c84971191a990d6e3c3e8a6188931ea7d9cf16f129980bc1cac4dcb8005645d9000253d9295ab2fbf9990f1ff612c9dc SHA512 d6f67e12a49cf610e90a8e8c73c6f8e774081d7cf8f1472521a21b3c82dade1a37bd9019cad6336327ec3ad8625f2e553ac127caaa6b078bd001c9277be39ac7
MISC metadata.xml 1082 BLAKE2B 3513fa3e80fea67043d8af525f9d7e13342f48b16270c079d9619749694d3e128445063ffb7c21b039429613ca4fdf68380bd22d606b43e0142603067a38cf08 SHA512 86204ef8edaca962e7b1509c0d78f01db1027a9903222746894d1d8395c183128b24c953d746a14bf6f74c9608140a9c6f4e74bed36c7363b0f465395d276895
diff --git a/dev-python/pychm/pychm-0.8.6-r1.ebuild b/dev-python/pychm/pychm-0.8.6-r1.ebuild
index 5cd27a7443bd..f61fdac61dbc 100644
--- a/dev-python/pychm/pychm-0.8.6-r1.ebuild
+++ b/dev-python/pychm/pychm-0.8.6-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
DEPEND="
dev-libs/chmlib
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index c32fb950f645..fa6d5d488854 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,3 +1,5 @@
DIST scikit_build_core-0.4.6.tar.gz 160670 BLAKE2B 8efa818ed17d898818c7fd1f56ed36369b25fcba62fdc4172e147db9a70a9a468e8472b8cca599c7afd32fe5ef3fdfce30d173359ddc4ff7ea7db6c257f63f9a SHA512 24f5ebfd855677c6f7af8f5098c257326cffc5de5cd0d04b4dc51f40c78784c7dc49ccbc97d43460f5091478b0b9bb09c4d3c93178699ec1938521688fc48bd8
+DIST scikit_build_core-0.4.7.tar.gz 161024 BLAKE2B a06136ca6144305290dcebacd33690556ce30c28793572adfd7b42b043d4bb7f2e6e8000fcb543608d33a130f7094683a31870aa40067fb24fbb453fed884ccf SHA512 39f99facc920e3a46a3592d15ce9f3ceb90cf92dca8a010546a9cc15d50ea7737951286b6474f2f3f68f206f4fa7d157931fcfa831e122f51266df56ec5f043e
EBUILD scikit-build-core-0.4.6.ebuild 1196 BLAKE2B cc7aa554ac04d64b84c59c81f11aa07c503a740e57955adb142b79efca1797ccecab104af2a9664f368cea60512e9c26815637b7fe16a4367453c15b457fd3e4 SHA512 3f2a3d7ff1df60b2214a88e54820f7da0a7fcfef4f75514d9c14e206c2fa3fce6100ba17e06aae1aa5449f2b9884ce98bd69ef9db13f2896cc75014081c479d3
+EBUILD scikit-build-core-0.4.7.ebuild 1196 BLAKE2B cc7aa554ac04d64b84c59c81f11aa07c503a740e57955adb142b79efca1797ccecab104af2a9664f368cea60512e9c26815637b7fe16a4367453c15b457fd3e4 SHA512 3f2a3d7ff1df60b2214a88e54820f7da0a7fcfef4f75514d9c14e206c2fa3fce6100ba17e06aae1aa5449f2b9884ce98bd69ef9db13f2896cc75014081c479d3
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
new file mode 100644
index 000000000000..9cf9fc3a704b
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m "not isolated and not network"
+}