summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin258512 -> 258685 bytes
-rw-r--r--dev-python/multiprocess/Manifest3
-rw-r--r--dev-python/multiprocess/metadata.xml12
-rw-r--r--dev-python/multiprocess/multiprocess-0.70.14.ebuild21
-rw-r--r--dev-python/numpy/Manifest2
-rw-r--r--dev-python/numpy/numpy-1.24.2.ebuild2
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.17.4.ebuild87
-rw-r--r--dev-python/ruamel-yaml/Manifest2
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.24.ebuild58
-rw-r--r--dev-python/tempest/Manifest2
-rw-r--r--dev-python/tempest/tempest-34.2.0.ebuild75
-rw-r--r--dev-python/whatthepatch/Manifest2
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.5.ebuild21
14 files changed, 287 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 386e26ec0110..724c47311ce1 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/multiprocess/Manifest b/dev-python/multiprocess/Manifest
new file mode 100644
index 000000000000..019ea43ed538
--- /dev/null
+++ b/dev-python/multiprocess/Manifest
@@ -0,0 +1,3 @@
+DIST multiprocess-0.70.14.tar.gz 1498053 BLAKE2B 0377d293b3e160f6a6c61c148ee0d852b39f859530ef738ae143312b62833779a7e0ea745d468628fbc96a22e97326ce886b46ef9a0791fd58d3682bdc54e6af SHA512 22202b81c33601d75ca3222a6485bae596d7807d54757280ac06f2fd7247c927f978b4f5c62bd81739b95462a96dc629e5559630d9310343f86b46ee37841b6b
+EBUILD multiprocess-0.70.14.ebuild 504 BLAKE2B 7b7e636dc24bffc553c021c23284665bb8a30c9e588b8ff751c931dea8d4033ddc8267d061ba2fb945f8ee05e3968e25ff16a871a5eb38117f5711fa25daa4b0 SHA512 b58378ce1511e33d5b3377d0af79c7bbb2aa17c059301b7b10a423dbc99246e91c2a0690183a2ce08582c4d8594849f2e26cbb10bb455d295b7209e5626f8584
+MISC metadata.xml 388 BLAKE2B 90682f15ba194a74837ddf6a209ded65ab8207870d2976c3569cf4f0c4405163cbe7b25b1e0a662963f4ca890c96f7f29a65922e6b7a1cfd06422e8b7a304cd9 SHA512 4b77d39c7ec184288ef0ba90dbc889d29a4ce0bd37c9f9e66a43b8baa3f3ecd56cf122653d8931c3203226a83b8f7d495cdd63923421941eba6bd7d1ce0dc3ff
diff --git a/dev-python/multiprocess/metadata.xml b/dev-python/multiprocess/metadata.xml
new file mode 100644
index 000000000000..9b4d7631549a
--- /dev/null
+++ b/dev-python/multiprocess/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">multiprocess</remote-id>
+ <remote-id type="github">uqfoundation/multiprocess</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/multiprocess/multiprocess-0.70.14.ebuild b/dev-python/multiprocess/multiprocess-0.70.14.ebuild
new file mode 100644
index 000000000000..77452a02ef21
--- /dev/null
+++ b/dev-python/multiprocess/multiprocess-0.70.14.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit pypi distutils-r1
+
+DESCRIPTION="better multiprocessing and multithreading in python"
+HOMEPAGE="https://github.com/uqfoundation/multiprocess"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/dill[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" py${EPYTHON#python}/multiprocess/tests/__main__.py -v || die
+}
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 1dc6d074af4c..29fda6325e6b 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -3,6 +3,6 @@ DIST numpy-1.24.0.tar.gz 10897101 BLAKE2B 59e2b913f90de76589d8fbb2f07e2d389012c7
DIST numpy-1.24.2.tar.gz 10906862 BLAKE2B e48f65eab709f0c57ec378d813a7b65bcaca6d5960b559d6db1c60726e5cf12517f4b2e1636b0ff815a2109925edccba200270db5170fd0aff5fd635919165ac SHA512 145fd7fb3919a185f75076d51b92c54a7fb1b776b637752ca15fdee15b239d6a517ef1bb8cded7c92e059cf6cda0146c24943c042d19b791e81125bc0ad4b820
DIST numpy-1.24.3.tar.gz 10909904 BLAKE2B 3b14f8b6a7bd484de43c3b0e57f161388d6226e05ed9bc3d1edfaafc713b9597c7574b9b9c20b4e3a6bd291d32a607d95c72d6e25fa346ffdaf97c94767bc315 SHA512 d4b5841cbe68ee6653f99018e4e0182f2e5519a1cd69c14e0a95aa180f878e6a6786ccf0a7c78bf0d511c53e7535d7144fee428572dec7a4b60b25c8a1c0c9e1
EBUILD numpy-1.24.0.ebuild 4274 BLAKE2B 57ebcd94b9c33477d87500f8b8e9c98faa5a3ec00e855a3215863249b2c7810eb7198e9aa13db0859abad4c4f6b4171419e62022c73144011bfd143bde054424 SHA512 84c221d759a2c80e9c27f34d10b17b82e845d40d0213a73a65957829e38f78b86fedaccbd28dc0d94474976363d5fc1e6b2faab0807fdcfeceb09efa1ce2ed58
-EBUILD numpy-1.24.2.ebuild 4396 BLAKE2B 10efeb00b8f685ee0b9a7afd88465b2812612698cbbb18b161405cb790f36019dfbac351738c4e4a286752310134f7f685e9eafc0b28ae5a50bcfbf4f38fb160 SHA512 be793b1b14c5eb2839fb40e5a890704b5b341320bee8869718f69dc1eb03bdaff67ebee700b9f1a90c99086498b7bb8e8dfbd2a6ac536bd065ba7fb6002aa39f
+EBUILD numpy-1.24.2.ebuild 4394 BLAKE2B 1758c449500cb32a84330cb76786c9c001a8964e34e0db8d246593aabfb66034c395bd17f7b2225f385c57e0afa99d026308e89e37d8ac676f78d72cf8602491 SHA512 85c6afde93b34ce58e90fb44963aac842505017da7fc29345595131fe7f7339015d14a4d3bfbb7a668f56984150dc767c4829c7764c4b6882d0c5ec36b84decb
EBUILD numpy-1.24.3.ebuild 4548 BLAKE2B 1eaa7f8c56213e8aa6a9c54b65f337752cc9643b1e0da99b8c6c38fdf5d94136c9c59bb26b8bdc21280df7961130762d08f4913e8395a1723c3985b124810c44 SHA512 0b3e10c3e8e9f756dd22808dda7ba91c27b33176bf833db30c191c31fad0ada5c04a904c682e96b12827af523b8d06ac9bfd98bda620ccb09461f2cd0fd66a38
MISC metadata.xml 932 BLAKE2B 7a4af31f613bab05ff542da48bf6ff1484d9df2459f559516e71329451dd739d3df0fead507c8033d94ab9ed516b68efe7f21819a8cd6ca303643d8c8bc34e86 SHA512 32cb8c1ab61521a02cbec38f6ea383f074e50d46aa3462ddcb85710f9d348e8e628cf2a5725e3cd921cc32f02885a1b5f02125639f0ec885384eeeff7f468a06
diff --git a/dev-python/numpy/numpy-1.24.2.ebuild b/dev-python/numpy/numpy-1.24.2.ebuild
index ee850ebab23d..ef356f693fda 100644
--- a/dev-python/numpy/numpy-1.24.2.ebuild
+++ b/dev-python/numpy/numpy-1.24.2.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="lapack"
RDEPEND="
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 4b1fe7cd983e..61c5c805cfd0 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,7 +1,9 @@
DIST pylint-2.17.1.gh.tar.gz 1408063 BLAKE2B 0d4ab42ea4465787ff0bb6768b20800797d76caeddda475a08372a6b174975fec36a48acecea80898b3ba1c36ad6eb6c540678338c84ce48b78e0f6f9553e190 SHA512 e467c48349f49c2a9ef68d6a70748bf9144ff589adc1d04eb1822b28511d5a1a0027536fc61a5d33955fb0e7ffbbdecea47e8196844f33985a43e8c1886af21e
DIST pylint-2.17.2.gh.tar.gz 1408818 BLAKE2B 678fc98ac583e86e98856713bbfbf975be9f3c51ec1516d2a2df54369af1bba76db6c53d43a09494d08409bb3829df958037ba716ed6880460c2cbbc2ca4b38b SHA512 9c3063332ffc102ba4a7177cca4c440ce89a8ba6fa4252eb1fa401a6e6c10e49afcbbe76127aedccc30dfe5f0dfe7b19cd9aadf4f5ffaa2494a4743d2e0d6a33
DIST pylint-2.17.3.gh.tar.gz 1410573 BLAKE2B c0180555a8789576db2174d99ccb6aca3977f0626228e14288de6d457f7b6bae2c84d25a4e61fe8ca4b2a6f16eeab60c36fe32466dac9e1f0d3be35b93a04b7e SHA512 8d4d0387a89c4aaa2ab7c2ba4c991d6ac7b90982afd292578bab567d556acd2476a22bfdac9a02021519e7a86f389d8991a9ce3405e57c61d6522dab59a19a16
+DIST pylint-2.17.4.gh.tar.gz 1411540 BLAKE2B ad8e5dfcd378e2c87f59fc7bad36c504296555ea0174d0f6fd3e59c04eb5610ee0a40257cd4d457418808b55efef8ffef7ca5d6e7da946323cb32e34cf5f0d67 SHA512 0232f0badf7124db549e768f5d158e7b7728fb34893726b5c3a0f599e201a18069118f0aab2aed0b0e1d47c0d4d37cec72d9c1c489ec5c3c316a53431ccf35a5
EBUILD pylint-2.17.1.ebuild 2561 BLAKE2B 46537da651e286bae948c29ea5aeaeacf0231f30a3df716824ba5c39131e596ea6fd9ddaa4350c48b2b37f8d568ecffd6ca2826e2a835833489d74b3e1ec273d SHA512 e5f43453c9054ec51281a4c8c882f4fa6a78518ec9890c09937fdb870f8daa39ebf8d0af40f0f0d38a78cf08687aab03184398eb49c87b4a310c809898a0107c
EBUILD pylint-2.17.2.ebuild 2576 BLAKE2B a65fe338671aeb2a800e4a8f30960d1c3256408041ab20bad5de0fe3a6dd93c388cf95be74b42ae851327049b94b5831e7023d66f81b6c7dedf95652f4725e31 SHA512 3cacb23f8294353b2de4efaac1776f2e25bd5d3055307651780005a1b2e0c84fb907b4d61cd4b5d2d36d15395c5ba6fc1a4f9bcbf16f3d032282b181b85df074
EBUILD pylint-2.17.3.ebuild 2576 BLAKE2B ee7d27e2329609ee1c06dc50bd3df6dad51eebd43153118eba2b8e23f4642b2b3764ed64cd09c1ad57849232e5eef61196b73724cdc44c2c9b5a791cbce00c57 SHA512 4d3625e2c65ad437f115d0e895426c2dc355e5ab6279317fe565ee3770b9e59f2573e81c67c1e9591d93f244b3406015bba59eaf7208d944df3f7be7436651f4
+EBUILD pylint-2.17.4.ebuild 2577 BLAKE2B c9e49c76f5ba90425c1b6bc0a6b63631a3aa4f549d27a78d2a665a43437d3c8489b9cdba2a6f845facc738a60bdf575dee026c46d9ba951c86e919fb23bfef66 SHA512 29b994e0123cbafb7991deff876e7adbf55112d17a38e9f2642fd0c1531777a1218a9d6ac694830a011f08984b6e6b0fb501434acaabc3fb5f8e8657505800d0
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-2.17.4.ebuild b/dev-python/pylint/pylint-2.17.4.ebuild
new file mode 100644
index 000000000000..fa4d4ca957f9
--- /dev/null
+++ b/dev-python/pylint/pylint-2.17.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.17[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.15.4[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 2fac699c1d82..0d5d6e95ac42 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,7 +1,9 @@
DIST ruamel.yaml-0.17.21.tar.xz 184612 BLAKE2B cc7e2a336d3c77a9f2d7e5d7233ceb4d15fddca3a97ec0e54427469fd24c7c63fc70b258adbad92a816d99a1f9839d41eccb9f3224e7a23884914755fa424bc9 SHA512 87f4723bfc76b1b21168852aabe4b49921f175294ac05b4e3f292f2bcf23fe6595df3e066843d193f881b274be2a7b358bd04625afef913bb0e5811efe98b761
DIST ruamel.yaml-0.17.22.tar.xz 185000 BLAKE2B dda8163bfa52b29801d115bc64ef52c35086f186b4795df9dfcd785584e2de338ca055dbf07f3eaac548b14d338ac89bbda4e95196fd113a8fda3ecacb30bc61 SHA512 ac1af1c829c0a5dc65a66926d03b50eede405c9dafd811eae1b9567c81b6bb86b7dd91f4b7c6bf84d7c4833f8b17860dcfddaf7992241ac6673d7ffecf15466f
DIST ruamel.yaml-0.17.23.tar.xz 185900 BLAKE2B ff283c979474f14e2f0231d64d0a609f262c4b87764eedb2b6060a66a09388670514f341809e6c5f36b0fbe15412209dbd5da9fc31fd8bda83a4d857beade48e SHA512 1a9c22357d61e31464cdead9d0c7715f156839861b8d93b94fa78f00b8d75e803d5bd74fc7d36e1d20f5927f807c3a9ed6af79746177a1d5da0622729597807e
+DIST ruamel.yaml-0.17.24.tar.xz 186504 BLAKE2B d5bd5240c3ad68309ad9382dd076111f554848a71697ac98015e34449a98c101f37cef0fdead279501976cceb235c8b055675eb63aab4c8121dd30ae5740dd90 SHA512 32fe95c4927197af4f30bc68d26bff956520d69471f802b58be6a07a0c4b2ed45673cd7890a2f49dc2a13791a2dac2fa66a7e6137f5afe813b6d8d56704d0c16
EBUILD ruamel-yaml-0.17.21-r2.ebuild 1416 BLAKE2B 7c5fec37a294037618a2f9d21788154fb806d6fc1575d622b7b8140f994395c4eb92be635f9f8ac11df318e37e72623ec68ecc6ac273e1961fcf99bfa88c95ba SHA512 2c2f983c303a954b217667a3c0034d14d422cb5e2473b79fe9ece4dc9e43a4f032dbeb74a6d78ef3c6d463f31f69e4ea63fd0679bfdecaf4a0c8e08267686ca2
EBUILD ruamel-yaml-0.17.22.ebuild 1423 BLAKE2B 5e168553d3cae61fe84f729c50a299633d9a56e476676c2c762f5776c95b5173743e2a554209c3309c6baefae8abf882197f71c4e6efaa4cc5a5970c5f462b91 SHA512 999fbcc45460816f74fa1aef11b09a52221ee49b5a661381dbbdf01e067da037060e5df91a2ca62415480754c57a3f13bd75f8019bd947e4bf69b90dc7d43943
EBUILD ruamel-yaml-0.17.23.ebuild 1423 BLAKE2B 5e168553d3cae61fe84f729c50a299633d9a56e476676c2c762f5776c95b5173743e2a554209c3309c6baefae8abf882197f71c4e6efaa4cc5a5970c5f462b91 SHA512 999fbcc45460816f74fa1aef11b09a52221ee49b5a661381dbbdf01e067da037060e5df91a2ca62415480754c57a3f13bd75f8019bd947e4bf69b90dc7d43943
+EBUILD ruamel-yaml-0.17.24.ebuild 1424 BLAKE2B 2eb712c34d3de058093abab29e683061e0d8c2fbd3e42e7b99acf2ff3d169bd5eb5fb8c579535f109c69f75d7b64f4f369859d01da85df7b3fb893d515977eac SHA512 ee4b07d307ca7fa0d0c984c0c26862529ef5a846b81ac01a143e40266df025b96faa64731470c93ccf1921e3b5e2c1faec7fb7c876a0580ada2af6ac7c07ae0c
MISC metadata.xml 759 BLAKE2B ce5ec2429c5fe84587d1b5e7744055e1e8e91eae8dec780a4654cab405df46350d1c8175827351948364255b8fcd62ea234239260c01b8ce23b8db182e6514e6 SHA512 faa587083ffa9af40108e2ca9cfb7a4e2c3e19a731b39241a7ec62d6fca051ace92bcff3fa9896a343fdc196a04fe1d132bcbb7bfa3fd96401ac996b76bba4ee
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.24.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.24.ebuild
new file mode 100644
index 000000000000..a57faa690df0
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.24.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 967d46345f9f..b636603aa3e4 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
DIST tempest-34.1.0.tar.gz 1139228 BLAKE2B 32fefb49ad5a341d297cf660387e66f69e0f3f81cba5f0530190bf5562c7a391359667390045fd746977020376e426aea351a2f50652d67693946bdb8dcfba18 SHA512 89cb682edb3d99c22e9c654a9e546e649837abf7e0b798d84c16d70bef4527d094dd6bbe1d11b8996412cd7e6f073fd1a3f80e5214d7d3a44965f3b542fa13e5
+DIST tempest-34.2.0.tar.gz 1141098 BLAKE2B 60d09fc0de49e63213bf23cc223cec92b53f887ff5677fd80cefac441166ef777bc8b96682847697702af26d8481192a2fe19ddbe42cd3b991cc0f16ed09176d SHA512 22cf6e5b6d60398a7a1698ad0bad02d8d16ffd815f573fb526becb9d1be64151bc6b33fb6b8b03f9c52f18565ca06cad1bf9725f2cff2c6116c88f85439b5d7e
EBUILD tempest-34.1.0.ebuild 2196 BLAKE2B 3cecc6aa4d890879813eb5d205c32a157ce4419fba6a136b141b7479ba5589d7b2b3ea45112b462754a79dc27665e21be32c82cbd940026b127881d5bdc5723a SHA512 dafd6586cec20fdf6c91011b1cfcff774bbbb85c221529c82dda8341b637ec81ba63f79fcc1e053148502d003caf09b99a33dde861c6b717056c44b1c7967c73
+EBUILD tempest-34.2.0.ebuild 2199 BLAKE2B 807c0e451c8c8b24dc94429e5451dec69642328e3751d97dc62f572f6fe474f76042c332212cfbb4b1243b0729d8ff21eb1fbd8795f00a4058835b58f44c3858 SHA512 0f45ab8a3b36314818963e09372288de07325a79d28c4cfae116250d1ae962bf37938deac4c280ad61100470c39f1886a10fc7ea8d72de8e5521a5fd0924c7c2
MISC metadata.xml 442 BLAKE2B 30b474d10a59f53672390e029ffaf894cfe52862af42814ca09500372d4c94afc596177100b9ba69cfd12965e98809de363527d9db345c3b4cf499eaab0375f9 SHA512 d84466ecac31486c92a6c5f87089616b65a1f3cbe9447c3382021af57bec3964a80d4d4421783560528e80e70afb4f4ba604bf2a4e23ac7fcbd873ef3d789859
diff --git a/dev-python/tempest/tempest-34.2.0.ebuild b/dev-python/tempest/tempest-34.2.0.ebuild
new file mode 100644
index 000000000000..9143d3959fb9
--- /dev/null
+++ b/dev-python/tempest/tempest-34.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
+ local -x OS_TEST_TIMEOUT=300
+ eunittest -b -s tempest/tests -t .
+}
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index 99ef278e88c4..6974d41d6197 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1,3 +1,5 @@
DIST whatthepatch-1.0.4.tar.gz 31063 BLAKE2B b3f66ca0783ae147ebf5d47aa155a23cfbc16fc19aaca9812b53b2a292543f64447e31b469645bfeffb8ab1b8a5ea7cebb9ebad5e9815d6a84a3b44068329448 SHA512 89705fa1ad4a797038b8c4cd30c7ca88b5b51474265bc157f45c244b258075cde587c6da16fabfaa2d6b90eee858ccf82c9f01ce8e44412a5eac504f95fb413b
+DIST whatthepatch-1.0.5.tar.gz 31850 BLAKE2B dfded6069aa70051fb5f399c9f4707969be4dfc1dee853cd8eb7f36e074c2b595eddbae3efd534321dbbcce7a6658ef9e9bc7675ef466e0a486d930d62761e1e SHA512 d87a36a608a15bcf6d28d26afee40161e26f17fa3b011056388f9850896577f913a91066de8b6071ea15b28fa05f8d00acb997b18483ea56218df4efb40109ab
EBUILD whatthepatch-1.0.4.ebuild 448 BLAKE2B 20c6fc44f243de1af65c82517ff33c979ea5bec2561fe218f49d11adc0989ab893176c362b92aca496bff71789126e2bcbe9ae5a577e6240b8d24268d80b92ef SHA512 de4849d5f73655ea75c3ac946cb942d7d7f2c43f5588400a9f4b33adfb3057c439c773b0adb151a0c8c5d25508c2fa49788dde1dca02c681fd4e2b65c042dacb
+EBUILD whatthepatch-1.0.5.ebuild 451 BLAKE2B f98901555d1a9513485f5da2f63ab17da3a320a719eb6b9c438002ca32e28d01a94010b649efb464fff0f6b11e62037fab2c3d6290e80e224142338708689b3f SHA512 4d401f5ecf1594d3faae38acf2ebd3645e115706501758fa910baf1a7057360fc35a925efb5a6afaa29a498c2dcd3d4c8b39b5bd391ace561f708429f673b456
MISC metadata.xml 401 BLAKE2B ee370b7f08a16ea4054d5192831a530a9bceac969b2832d6fe058e98dd7558498afbebf4c1f2102979b2f3c252de73c5b11aafcdfed7044a5218144def4f333a SHA512 2a5c7944923e59032c3e75a0a08339ab4b273a346ef855a8ff61c45cc52ecc847db314b0e733876e6d14c3ca42418d9573a26d7f47213958f44a47c6dcbb6c48
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
new file mode 100644
index 000000000000..28281938d7b7
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest