summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267469 -> 267463 bytes
-rw-r--r--dev-python/PySDL2/Manifest2
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.16.ebuild69
-rw-r--r--dev-python/pefile/Manifest2
-rw-r--r--dev-python/pefile/pefile-2023.2.7.ebuild2
5 files changed, 73 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 40f6df813e2e..76e861b54578 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/PySDL2/Manifest b/dev-python/PySDL2/Manifest
index 9d9318f7269c..40cfd1448bd0 100644
--- a/dev-python/PySDL2/Manifest
+++ b/dev-python/PySDL2/Manifest
@@ -1,3 +1,5 @@
DIST PySDL2-0.9.13.tar.gz 754811 BLAKE2B fe9d3fb32cac104303d67741c3b9e0d78d3d03198ed512464bbdf5bc487a5f4c9a92aafb100c53c02d8be87bb107034f67ebb72294ad67cc0a8b42ab7a678a31 SHA512 f866e7ed35e3ccfbb5b98f797e87d5b20c6f7dadbc3396b297cbb6c2d83a7f3290fde63940a4d8f190e40a4a9269d2df9efc1932d9578d3df1617e5fcbe6ecad
+DIST PySDL2-0.9.16.tar.gz 773537 BLAKE2B 5cfe4ab3981a665fc7f7606c07a3252e58c2706e45ab41d0d6444b4d3fb1c8805b5fd67e770a8a64538d305be0013a4d599ee81f5de0c5370146edc9d4d858df SHA512 ffe7abe8e828926934677c81a42c9af794c4817144eba50c40430c150d476dea40f0b36e639b2c270cbd8e00ab5bf5b032a4c0e514255cceef8161c8d76f8cb2
EBUILD PySDL2-0.9.13.ebuild 1648 BLAKE2B c2dc6b6b922fa4b206e8c2e3239c22daa3d534fad0e1a2d05ff115f53f2ea517a06bcfb3a4af2626306e2a801edaa47742072597b9540ddf1ae393f0a31e4251 SHA512 cf22ae9d778fa836477ba8d968a4599b05b99576aa892db1073881c079597e9aa901b29a660b45af9a9a3c34989c96cbebfd06b15592e61c8df2f54a1c7daf34
+EBUILD PySDL2-0.9.16.ebuild 1784 BLAKE2B 9f8c8d3a0f96e88b6d857f0cbe219204d9012143fb37bde2f45a4943e771ce13931988db2375c5619461977508e2e6de72e32e71af81f6ce98428507d8886738 SHA512 5329aae968144c9bc6c50e575c560be338c7d868f21506dfef753debe708f448635f9e8db8a4bcf4c832e666b31dc2b86293e7dac6cbc66e00517646f5aa125d
MISC metadata.xml 450 BLAKE2B f92f2f7529e3a09d18c88a51f78ed520d7b4756a99776d70bb7ad4e452ae6cd9a67560ebfaafcacbd73e945282fc28ecdb48d54b2c2eb5b18d3f944401650349 SHA512 de7f757b195170ee865e34dcc214d0a57912e50631291045c485f58ba05fa87b7fc57878333021c7b9d3f8609e9afa4190f4c4062fb7a8136498875aecee615c
diff --git a/dev-python/PySDL2/PySDL2-0.9.16.ebuild b/dev-python/PySDL2/PySDL2-0.9.16.ebuild
new file mode 100644
index 000000000000..539e04548bf8
--- /dev/null
+++ b/dev-python/PySDL2/PySDL2-0.9.16.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
+HOMEPAGE="
+ https://github.com/py-sdl/py-sdl2/
+ https://pypi.org/project/PySDL2/
+"
+
+LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Optional deps:
+# - dev-python/numpy,
+# - dev-python/pillow,
+# - media-libs/sdl2-* (loaded dynamically via ctypes).
+#
+# If a reverse dependency needs the specific module, it should
+# explicitly depend on the optional module in question. You also
+# probably need to explicitly require some media-libs/libsdl2 flags.
+RDEPEND="media-libs/libsdl2"
+
+# Require all of SDL2 libraries and at least the most common subsystems
+# for better test coverage.
+DEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
+ || (
+ media-libs/sdl2-mixer[flac]
+ media-libs/sdl2-mixer[midi]
+ media-libs/sdl2-mixer[mod]
+ media-libs/sdl2-mixer[mp3]
+ media-libs/sdl2-mixer[opus]
+ )
+ media-libs/sdl2-ttf
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # pysdl2 was misusing libsdl2's error API. Fixed upstream already
+ # but it didn't land in 0.9.16.
+ # https://bugs.gentoo.org/916120
+ # https://bugs.gentoo.org/916118
+ sdl2/test/gamecontroller_test.py
+ sdl2/test/hidapi_test.py::test_SDL_hid_enumerate
+ )
+
+ local -x SDL_VIDEODRIVER=dummy
+ local -x SDL_AUDIODRIVER=dummy
+ local -x SDL_RENDER_DRIVER=software
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -x
+}
diff --git a/dev-python/pefile/Manifest b/dev-python/pefile/Manifest
index c77f5fa2bdbf..ae011b1e7490 100644
--- a/dev-python/pefile/Manifest
+++ b/dev-python/pefile/Manifest
@@ -1,4 +1,4 @@
DIST pefile-2023.2.7.gh.tar.gz 74852 BLAKE2B ddca4b8ef37af829bb1757eb4c4ba9f46c3914e05e6c13e13a8e5a3c88a608aba486deec9338400fddae4591867c0c7dcf7325cee14d42b1bb724751a3a2a7f0 SHA512 241d9846954f094ed39e61d80e7d8c1612829ec909650175e75657f9cf69c9bef9e2a115d4106bb14757125c0ffaa3e93abfb2f078e80326e78ac5818c7c2fd3
-EBUILD pefile-2023.2.7.ebuild 836 BLAKE2B fd3f2ca2b6f9f5b42443c3a47b9ba64d26ab552602565cdf360094599ad02a74d1daa36dd2a9e88375e087ecf73430af8224b9ae5f14acd4e6047d32e78f0f0c SHA512 10b9f573116781d03d852744338872bd9e3bad1293c79539f84837791036acefb5e5bc805d414d4602171640438518756c9351f0f4c6395bd79c6feb1523cf51
+EBUILD pefile-2023.2.7.ebuild 834 BLAKE2B 230428ca8fcb78742d4f70bd071d695836b5d819c93dccff9a3bb29bd2fa8aba5893242a13bacaecbe204d6c2feaa8012a5f7eb602bdbdaa501ae85525cc9f35 SHA512 44a91eddb625a585e2997902804f9a50e5054babff4651e12de1cf6a3eceb4b9dc2ba35fb36e9ae63f5257d1a2b3ec6e345f96bf1f5121ec33011cee10c417e1
EBUILD pefile-9999.ebuild 836 BLAKE2B fd3f2ca2b6f9f5b42443c3a47b9ba64d26ab552602565cdf360094599ad02a74d1daa36dd2a9e88375e087ecf73430af8224b9ae5f14acd4e6047d32e78f0f0c SHA512 10b9f573116781d03d852744338872bd9e3bad1293c79539f84837791036acefb5e5bc805d414d4602171640438518756c9351f0f4c6395bd79c6feb1523cf51
MISC metadata.xml 766 BLAKE2B 8cd0206bb0cc7de9a76159851092c27b5e7c6d8294a136de2dd74e51da9062f6daa67c2421c173b6125758a9f350b84b03e2a85fa2029beb50032aa034f08c3a SHA512 7c3e9d6d89108b17a722c805353a9c457ccb5a5233bfca7145f82a37ab0337405c84a1e806d9fba77dbee779dd06cb18f7272399277d377aa84dcafc470156bf
diff --git a/dev-python/pefile/pefile-2023.2.7.ebuild b/dev-python/pefile/pefile-2023.2.7.ebuild
index 7f530f4c4bec..ee4f6b91abe1 100644
--- a/dev-python/pefile/pefile-2023.2.7.ebuild
+++ b/dev-python/pefile/pefile-2023.2.7.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
+ KEYWORDS="amd64 arm arm64 ~loong ~riscv x86"
fi
LICENSE="MIT"