summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest3
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.3.ebuild49
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 2f006e2812de..f1cf17ddb5b0 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,7 @@
DIST qtlocation-5.15.2-861e372b.tar.gz 5431120 BLAKE2B c66e81f7e726b53000a0f8a4eafa9a4a6168aa08c89d4d0e2ef11b02e3598fd0b3f30dbd21e6c5436814bb88fa69c96d141b0d0d79f13239ec61396269af089a SHA512 b7cac8cd42185504c6140f1dcd4e8c0c749e3d8f22bf9977e97268e0ad6fbd3733e571a255ab7824eba31e30e707e804b07317f2ec9b7be15a4a5756c78c9e41
+DIST qtlocation-5.15.3-gentoo-kde-1.tar.xz 700 BLAKE2B 098f0fc3f25fbbc8f87e6c76881bb7f27c7786e487e7e162c0ab38a35d0c71c96ba3aa65a5fc67953b8495d1773a02dff272f36bed49917ad377eb9a8b69b67a SHA512 e446763a8e6e7e0a6615aa707f8d393444f2e2ac6a03ea87e12bd9bff130c97ce94238c15392dd00121e587c5212b37666a53acf96c25501f86068779678cef8
+DIST qtlocation-everywhere-opensource-src-5.15.3.tar.xz 6556680 BLAKE2B aa187e23ed544e380516d93f3cb83fcff73ee501e7b790eb55b9ca9ddcdbf96d31b8b645b70e003423bf6e8945e2fb06be0ba62785a1ba5680acca2129003d83 SHA512 755434db4cdea1c98159a2891c3efcda03fd03b144c37e7a71f57cb5d5dbc5ea1b35d1dcafa7301fc904ede910b4a9f7cfc834b7722cc06fcc360ad3be7b2886
DIST qtlocation-mapboxgl-5.15.2-d3101bbc.tar.gz 3726244 BLAKE2B e571a72e041b80b155eae7d171cee7f996fbe223c8d3337f549ea2a40472fc2da9dd8abf54238f22c1828d467aaf01307a61acecd3aedc4f5f7cabc06f48d830 SHA512 6e38e5ca0b9e17de690af79f4702278bdc933a74561aa135b3e82245df7d795602403048bcc5bce00237f774ce3957540a8bded1a71f8730a08da05dec1f039f
EBUILD qtlocation-5.15.2-r10.ebuild 1604 BLAKE2B e03e24a09ce4047332cdc6d65da88ee88d078283867523bde64b8ada59077b65e59cb22cb477065b3766b5fe5fad3f3fb01741e08f745ae54f5b0fd02d720649 SHA512 a34e5276f3a6ac15a20bfb8a5ebc7fbb7bf14d48a085d5a840a126130723c49877f97e3d6690fd734253c41adf8e8fd534a62c760abb9a87a4cdd901b99569c3
+EBUILD qtlocation-5.15.3.ebuild 1156 BLAKE2B 8f130cd2fe90dab996320629d22085eda16e66a79399de97fbfa152b782077ca2e333c5b18a515ad4003e64d49fb1d61ca25f95307c38a1bbcbdb01f8f3d8eda SHA512 3f0390a86aaeaf71dc95a294a20b99f7faa00050cdd93e1f56d61a7afacb6c8395b45b928e1119b4cc7b2617a873455ec011689981655c904cd5302536117e5a
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qtlocation/qtlocation-5.15.3.ebuild b/dev-qt/qtlocation/qtlocation-5.15.3.ebuild
new file mode 100644
index 000000000000..ba9e9fc91df0
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}