summaryrefslogtreecommitdiff
path: root/dev-qt/qttools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.7.9999.ebuild154
2 files changed, 0 insertions, 155 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index fd93bdee8c22..41f93f793abe 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -3,7 +3,6 @@ DIST qttools-everywhere-src-6.7.3.tar.xz 9022820 BLAKE2B e1eafdbc9a08b031a514807
DIST qttools-everywhere-src-6.8.0.tar.xz 9059032 BLAKE2B 83ec98a8cbaf049649b8df0ac6c478e5b1867b0034d8e8f57120dbc9b4c17b3b708bb14c9a7030bcca9330bc4eb1c0e54f44a249c5303f84129b14f42376d19d SHA512 e477c980446fe421484481537fb9997eca6595dae19e9bc7809d24e7685efb802fb704c97bacc77214070e6b7a0f7346f1537cc143e3fccb309bf14e9c8e8d75
EBUILD qttools-6.7.2.ebuild 4646 BLAKE2B 4a77d671a5311fcd7e6170bc29764560993be958cc8ea58d6c31d8132372a5f65197a69acd3eee45d211cbbf95ee653849faa7d98a302db07f60e3b79b3e4912 SHA512 69930be9d05a6fbb10c616b8ec8b664d40428abbf516777ac5fcf85adc4a2ed39a82bcbfbb988aef8568ac0a3adcb4939fb89e531e90bbda97c751c6ff0e3e49
EBUILD qttools-6.7.3.ebuild 4668 BLAKE2B aa642a2efd9c1aff8d3cba88a5be07983b2d914bf3258c689eb1426399efa250faa84d88acab47eb2d1e1bd017b5eba80c38991d20ffab900bba31a4e3146db6 SHA512 1ea708153a48fdce72de03cbc50dd53ab20c56081dd19fc7b55476320d36406a50114170fcfeb5857c953b14e37ccdd252663cd827b5da199e6df9f320e563e0
-EBUILD qttools-6.7.9999.ebuild 4668 BLAKE2B aa642a2efd9c1aff8d3cba88a5be07983b2d914bf3258c689eb1426399efa250faa84d88acab47eb2d1e1bd017b5eba80c38991d20ffab900bba31a4e3146db6 SHA512 1ea708153a48fdce72de03cbc50dd53ab20c56081dd19fc7b55476320d36406a50114170fcfeb5857c953b14e37ccdd252663cd827b5da199e6df9f320e563e0
EBUILD qttools-6.8.0.ebuild 4918 BLAKE2B eead259f4909d79ef42d1fcbaa5e2a8d4dc8d68deb09de6b7677b0f88242715433e02a4bc898f4b2883d9bc5dc33b97ce4127c8d275291e462e8343a2f304e3f SHA512 44095d57e066cca26132c5dea3aa3309365e2bf7e7004d27161f91ccecb55ad99a939a3088b0b8fd1e02a36317fe2a8720f81c94ec3245d9301e82f319f1a679
EBUILD qttools-6.8.9999.ebuild 4918 BLAKE2B eead259f4909d79ef42d1fcbaa5e2a8d4dc8d68deb09de6b7677b0f88242715433e02a4bc898f4b2883d9bc5dc33b97ce4127c8d275291e462e8343a2f304e3f SHA512 44095d57e066cca26132c5dea3aa3309365e2bf7e7004d27161f91ccecb55ad99a939a3088b0b8fd1e02a36317fe2a8720f81c94ec3245d9301e82f319f1a679
EBUILD qttools-6.9999.ebuild 4918 BLAKE2B eead259f4909d79ef42d1fcbaa5e2a8d4dc8d68deb09de6b7677b0f88242715433e02a4bc898f4b2883d9bc5dc33b97ce4127c8d275291e462e8343a2f304e3f SHA512 44095d57e066cca26132c5dea3aa3309365e2bf7e7004d27161f91ccecb55ad99a939a3088b0b8fd1e02a36317fe2a8720f81c94ec3245d9301e82f319f1a679
diff --git a/dev-qt/qttools/qttools-6.7.9999.ebuild b/dev-qt/qttools/qttools-6.7.9999.ebuild
deleted file mode 100644
index da97fd670c79..000000000000
--- a/dev-qt/qttools/qttools-6.7.9999.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_COMPAT=( {15..18} ) # see .cmake.conf for minimum
-LLVM_OPTIONAL=1
-
-# behaves very badly when qttools is not already installed, also
-# other issues to handle (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-QT6_RESTRICT_TESTS=1
-
-inherit desktop llvm-r1 optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool +qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets zstd
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- clang? ( ${LLVM_REQUIRED_USE} )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang qml )
-"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[network,sql,sqlite] )
- clang? (
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}=
- sys-devel/llvm:${LLVM_SLOT}=
- ')
- )
- designer? (
- ~dev-qt/qtbase-${PV}:6[network,xml,zstd=]
- zstd? ( app-arch/zstd:= )
- )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[network,gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- # prevent the clang test as it can abort due to bug #916098
- $(cmake_use_find_package clang WrapLibClang)
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
-
- $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}