summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/Manifest.gzbin11211 -> 11211 bytes
-rw-r--r--dev-qt/qtlocation/Manifest3
-rw-r--r--dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch51
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.8.ebuild2
-rw-r--r--dev-qt/qtwayland/Manifest2
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.8-r1.ebuild47
6 files changed, 104 insertions, 1 deletions
diff --git a/dev-qt/Manifest.gz b/dev-qt/Manifest.gz
index 6f91abd383b4..b3e108649701 100644
--- a/dev-qt/Manifest.gz
+++ b/dev-qt/Manifest.gz
Binary files differ
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 77bbe98d71a5..fbc1d1a25a35 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
+AUX qtlocation-5.15.8-mapboxgl-gcc13.patch 1648 BLAKE2B 37b5282d514f0282223ed4914c65bff098d3de72355226c7f9338262acc1dfea4ec490a03efea1f7785bf9d61a9d5586d32ad2b027776e4bc07f186c9741c929 SHA512 c323a07beff23c005278d6dfc27de30610056279a31258c8c20d711d936700b6246ad9dcbdf255c7bd0110607b3c2351699c2495140eab95733b268bccba7220
DIST qtlocation-5.15.8-gentoo-kde-1.tar.xz 3952 BLAKE2B 6084d14533ca2ba44249db817f1f0bb93e526fc14e4f4f32d9c99f7b231e25449b111bf9e08b8dca95928d3ac29f63a8e42cbd51d9cd0700344aad6982dd2ff9 SHA512 868e96a2a84bfb0e068957968c07b3558bef2c12517c5971b11e1b536a92ae80d0ca399355f8fadc0fcef2b272b77e6b30951f96ec7fbe174bb5a053567d2c9e
DIST qtlocation-everywhere-opensource-src-5.15.8.tar.xz 6559180 BLAKE2B 1b8feb5da8d564a6605d9106ec6399aea23a4f0b43f495baf61e14266e90d2d73cd310fb6d8514730867acba1aa26efb3072c213f22f19f72c2f554d76ab281b SHA512 a337fade917150c13fa2ea22ad1949f41541cea4ceb1f732ab53c20c2f19a63dcfc6f9f544ca64fdb5703d3ac8d2ec6e832f1f199a32e73a2f6c51febf53f514
-EBUILD qtlocation-5.15.8.ebuild 1146 BLAKE2B 141a6df9553c0cd1d6531c52acc25c376a6081fc3499f8ca968f6edf502531e564f47b3be09ee6f55d3121c32e7b4f92077c286c7b58d45ed1cd239fc4d687dc SHA512 f269471f3a9100f3d059134573dfc88465896e6d2dba9c2b89f93a66428dfd1ea1c9fe005653f9d588ad7961d68f1091642e6a72a5ff639016068b8c39c6d31b
+EBUILD qtlocation-5.15.8.ebuild 1212 BLAKE2B 3a828dab652937f17dec7eb827f22737554f8b25503065c62422b3139ee9eb2cb8ac5ca2935c46f2f12d5ee0a1ea6e4a258b0e0916ce9b8bedc71180a8cbc182 SHA512 80ec32c6e6a161665dcf0cdbe9838dc12484979e428b1ed08c4d8fbcc57546bbff7dc882b03e1da1c6a2eddd9afbde03189a9419a1424e765f392fa082dd78ed
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
new file mode 100644
index 000000000000..ba4e94e859fb
--- /dev/null
+++ b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
@@ -0,0 +1,51 @@
+From d8054f1efa0b97b291a6f8c7fff9090b0fd4328e Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Fri, 3 Mar 2023 11:39:58 +0100
+Subject: [PATCH] Add some missing cstdint inclusions (#872)
+
+GCC 13 removed some indirect inclusions of cstdint which this relied on.
+Include it explicitly to fix build errors.
+---
+ include/mbgl/util/geometry.hpp | 2 ++
+ include/mbgl/util/string.hpp | 1 +
+ src/mbgl/gl/stencil_mode.hpp | 2 ++
+ 3 files changed, 5 insertions(+)
+
+diff --git a/include/mbgl/util/geometry.hpp b/include/mbgl/util/geometry.hpp
+index a28c59a47d..283ec7dbbe 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mapbox/geometry/geometry.hpp>
+ #include <mapbox/geometry/point_arithmetic.hpp>
+ #include <mapbox/geometry/for_each_point.hpp>
+diff --git a/include/mbgl/util/string.hpp b/include/mbgl/util/string.hpp
+index 13498ccb92..2f6acb6410 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
+@@ -3,6 +3,7 @@
+ #include <sstream>
+ #include <string>
+ #include <cassert>
++#include <cstdint>
+ #include <cstdlib>
+ #include <exception>
+
+diff --git a/src/mbgl/gl/stencil_mode.hpp b/src/mbgl/gl/stencil_mode.hpp
+index bc959c9a73..fd00370f88 100644
+--- a/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
++++ b/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mbgl/util/variant.hpp>
+
+ namespace mbgl {
+--
+GitLab
diff --git a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
index 219efff528b3..a1ab77f7306e 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
@@ -39,6 +39,8 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+PATCHES=( "${FILESDIR}/${P}-mapboxgl-gcc13.patch" ) # bug 885431
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 94353f47987e..ce6b8e5bed5d 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,6 +1,8 @@
DIST qtwayland-5.15.8-gentoo-kde-1.tar.xz 44488 BLAKE2B bfdd7c2959eb99e115eaf01d617464359a549513958c997dd8b1a86bda755dec44d24b6619650bf385b2894a2001a712a344b093fc94e8cde40ac9c20323903e SHA512 3cd52fc78f2451c38c6d2b0dd958895016a94b255e38ff3909f40e4bcb1ef760332fde4cffd32ab11e868ce0afe6629f325613c88b8fd85ca28f1583194ce229
+DIST qtwayland-5.15.8-gentoo-kde-2.tar.xz 46592 BLAKE2B 0f2c460038a5b6f6fb7ea38edf61b392e95caa6356e8c070bde9d7939e20aaee4a45a581e08d04ad34f2a2da6317c2a16c40e58272d0c256fd16f0a1ce6fa34a SHA512 8b6c94e032a35f6ec6400fa292b1c7b864504d5c94d095c20fd41da8576eab4325bf7312b08cca00825aa858e175510b8b37c5877207fb4d60edde99c77c9886
DIST qtwayland-everywhere-opensource-src-5.15.8.tar.xz 568268 BLAKE2B b4e982015e25104b3270b48a180b5726ba85e83fd9616422422d8729dc09bc94bbeecfe2096e388eadb0930e4abfdd3b0349eba2bd1d8f742f0c74b5e72aeac5 SHA512 6c6e9dc20f98d71abd7dba54ff278bf4535e70f86bfc4e6dd46c1af7c87777f045a6aba02bba3eb786f7cf383da5fb72b03e1e6ec636c8be0cde0e4e5b7b5b2d
DIST qtwayland-everywhere-src-6.4.2.tar.xz 836720 BLAKE2B d8a6b84712081097775f083f3887c18eb001fd2beba32b2abc930ec3b932f6f19b347fe2fde3b98f35c1e7e31661974b13468fb176e73bdf557a330c80d847fd SHA512 29d3f3e7fade666bcd3145106f1d782122ac3fcf94811d25917c9f45af0dc8cddb3c2149545344d91e86f86490029555758ed2e180f241703251c22c7ec15122
+EBUILD qtwayland-5.15.8-r1.ebuild 1008 BLAKE2B 3a090b525823841c5aa13162aae1d657feb03603f09b38004266d36c3139201749b89ef8ac4236b4ac9417a43bf2e755ace0429053e821d5e25107ef97425743 SHA512 e40d2b554c95a4c02dd934ccb90ed1f14047d5a2f9b4e2e26ebd9ff7eecb3b34917911aa4d7847683d45a0342d6b8f6b8e765e24cf014c58e2d7d773d8393322
EBUILD qtwayland-5.15.8.ebuild 1002 BLAKE2B 4a77721f71912a69ac8da399cf959dccbf1141a7ba4f2a10e64a5bbfac97be16925a271767a227d84756aa256d0a419a4575a65c98ab402c5fd8bba3991868b6 SHA512 4591113cdcb1cc58cd2740d555243b4ffea4c507a2ef3ce3a06c2982dec8da850256d78347a1843b16455d313f4175d421451f93b6fd00bf387be1f86a01ea7b
EBUILD qtwayland-6.4.2.ebuild 438 BLAKE2B b419dc79923c1f81cf59b47d3f95cf43372260430cd16593089229011756c78663d062ce5b23464df27753427257bcea89ed745c0f8f0a4a1b7e7328dad60441 SHA512 a6d1cd0314a2dbcd74e3a4cc3ba2cba7b4145331c0b7617fe387cbeea4d9cb0643ab20d897df6953a21274771d3e64a6e99dce79bf41d33383508fb7b037c32e
MISC metadata.xml 584 BLAKE2B ad42909b120209835e121a29de558d338bae4348eb55e69a94e8ac8b54f26564df0a750839bef9418ae8056a0d24f234615247a610b8287f5b0fbffbc60193f2 SHA512 86fd81d63b19fc6e95bdcb92e9da9b03861248a4e78e9de36aca6996e61644ab8bce7a60ca22ee7ad86fefc9b407a1fd0136240b8fdfa3c40a149444ab1dcbe2
diff --git a/dev-qt/qtwayland/qtwayland-5.15.8-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.8-r1.ebuild
new file mode 100644
index 000000000000..9cceea0f85cb
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=2
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}