summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild')
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
index fba573262bf6..866ed8213865 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -40,3 +40,8 @@ BDEPEND="
${PYTHON_DEPS}
"
PATCHES=( "${FILESDIR}/destdir.patch" )
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}