summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/cv_bridge-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cv_bridge/cv_bridge-9999.ebuild')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-9999.ebuild b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
index 422225d82b4f..582de3e58f72 100644
--- a/dev-ros/cv_bridge/cv_bridge-9999.ebuild
+++ b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -16,9 +15,16 @@ IUSE=""
RDEPEND="
dev-ros/rosconsole
- >=media-libs/opencv-3:=[contrib(+)]
- dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ >=media-libs/opencv-3:=[contrib(+),png,jpeg,tiff]
+ $(python_gen_cond_dep "dev-libs/boost:=[threads,python,\${PYTHON_USEDEP}]")
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ )
"
-DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/boostpython.patch" )