summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/files/boostpython.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cv_bridge/files/boostpython.patch')
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
index 72fac8087363..a6192f98be24 100644
--- a/dev-ros/cv_bridge/files/boostpython.patch
+++ b/dev-ros/cv_bridge/files/boostpython.patch
@@ -2,14 +2,17 @@ Index: cv_bridge/CMakeLists.txt
===================================================================
--- cv_bridge.orig/CMakeLists.txt
+++ cv_bridge/CMakeLists.txt
-@@ -5,11 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+@@ -5,14 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
if(NOT ANDROID)
find_package(PythonLibs)
-- if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
-- find_package(Boost REQUIRED python)
+-
+- if(PYTHONLIBS_VERSION_STRING VERSION_LESS "3.8")
+- # Debian Buster
+- find_package(Boost REQUIRED python37)
- else()
-- find_package(Boost REQUIRED python3)
+- # Ubuntu Focal
+- find_package(Boost REQUIRED python)
- endif()
+ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
else()