summaryrefslogtreecommitdiff
path: root/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
index 7a610fadd9fb..76db5fae27db 100644
--- a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -14,8 +14,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/pluginlib
+ dev-ros/pluginlib:=
dev-libs/tinyxml2:=
dev-ros/roscpp
dev-ros/rospy
@@ -24,6 +23,14 @@ RDEPEND="
dev-ros/bondcpp
dev-libs/boost:=
dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest )"
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}