summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-0.6.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.11.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.11.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-ros/genpy/genpy-0.6.11.ebuild b/dev-ros/genpy/genpy-0.6.11.ebuild
index 29c86a165741..a5796a02b2e9 100644
--- a/dev-ros/genpy/genpy-0.6.11.ebuild
+++ b/dev-ros/genpy/genpy-0.6.11.ebuild
@@ -9,16 +9,18 @@ KEYWORDS="~amd64 ~arm"
inherit ros-catkin
DESCRIPTION="Python ROS message and service generators"
-HOMEPAGE="http://wiki.ros.org/genpy"
+HOMEPAGE="https://wiki.ros.org/genpy"
LICENSE="BSD"
SLOT="0/${PV}"
IUSE=""
-RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)
"
PATCHES=( "${FILESDIR}/yaml.patch" )