summaryrefslogtreecommitdiff
path: root/dev-ros/geodesy/geodesy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/geodesy/geodesy-9999.ebuild')
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
index ea8aaeb6424f..88ea377b0cc7 100644
--- a/dev-ros/geodesy/geodesy-9999.ebuild
+++ b/dev-ros/geodesy/geodesy-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
-VER_PREFIX=geographic_info-
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -17,18 +15,21 @@ IUSE=""
RDEPEND="
dev-ros/angles
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/tf
dev-ros/unique_id
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
dev-libs/boost:=
"
DEPEND="${RDEPEND}
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? (
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+PATCHES=( "${FILESDIR}/py3.patch" )